Bug 429551 - Upgrade maven to 2.0.8
Upgrade maven to 2.0.8
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: maven2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Fernando Nasser
Fedora Extras Quality Assurance
:
Depends On: 499539 500242 500245 500246 500247 500248 500249 500251 500252 500253 500254 500256 500257 500261 500264 500265 500266 500267 500268 500269 500270 500271 518010 518205 518219 518233 518238 518381 518634 518650 520485 520491 520500 520501
Blocks: 486360 518495 520001 520235
  Show dependency treegraph
 
Reported: 2008-01-21 11:05 EST by Benoit Decherf
Modified: 2009-09-02 09:33 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 09:33:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benoit Decherf 2008-01-21 11:05:39 EST
Description of problem:
could you upgrade maven to 2.0.7 ?
Comment 1 Benoit Decherf 2008-02-12 09:34:46 EST
Maven 2.0.7 is a prerequisite to continuum 1.1, that's why I need this upgrade. 



Comment 2 Deepak Bhole 2008-02-12 11:01:43 EST
Hi Benoit. I am working on this atm. The problem is that maven upgrade is quite
complicated, as it requires a host of other packages to be added/updated. The
update I am currently working on will bump maven to 2.0.8, and I am going to try
my best to get it in before the feature freeze.
Comment 3 Bug Zapper 2008-05-14 00:49:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Harshad RJ 2008-06-16 04:25:37 EDT
Maven 2.0.7 or higher is required for Lift (www.liftweb.net)

Please update this as quick as possible. I am willing to help if you tell me how.
Comment 5 Jeff Gustafson 2008-07-10 15:18:16 EDT
Count me as another vote for pushing ahead with an updated Maven.  We've run
into some subtle bugs in the 2.0.4 version and would love to be able to use the
newer version as a rpm package.
Comment 6 Sandro Mathys 2008-11-26 09:22:00 EST
I'd need at least 2.0.6 to build jakarta-commons-compress which is necessary to build tvbrowser (tvbrowser.org).
Comment 7 Harshad RJ 2008-12-04 22:00:39 EST
Fedora 10 has dawned and we are still missing mvn 2.0.7+

Deepak, can you please let me know whether you are still working on this?
Comment 8 Deepak Bhole 2008-12-08 16:24:42 EST
I have completed the initial groundwork for 2.0.8. Fernando and his team will be handling the rest and the import into Fedora. I am re-assigning accordingly.
Comment 9 Nik Lam 2009-02-15 05:47:37 EST
Hi, I'd be interested in hearing the status of this. How likely is it that a more current version of Maven will make it into F11?
Comment 10 Jerry James 2009-02-17 09:13:51 EST
Echo comment #9.  If manpower is a problem, could you post a list of tasks that need to be performed either here or on fedora-devel-java-list?  Like others who have commented here, I need maven 2.0.6 or later to interact with my employer's repository successfully.  I'm willing to lend a hand to help this effort along.
Comment 11 Andrew Overholt 2009-03-04 14:12:51 EST
Any status update here?  It would be nice to have a wiki page or tracker bugs so others know how they can help.
Comment 12 Jerry James 2009-04-03 11:13:49 EDT
It's been 4 months since the last update in comment #8.  What is going on?  This bug is now blocking my attempt to introduce findbugs-maven-plugin into Fedora.  It needs maven 2.0.7+.  Could somebody working on this please give us a status update?  I'm still willing to help, but I need to know what needs work.
Comment 13 Alexander Kurtakov 2009-04-06 11:17:37 EDT
This bug is also blocking Eclipse 3.5 update because the Jetty version we need requires maven 2.0.6+ to build. And this is the last dependency to get done before starting doing Eclipse 3.5 builds.
Comment 14 Fernando Nasser 2009-04-15 17:49:00 EDT
Hi guys, please be patient, we are trying to bootstrap a maven2 2.0.8 set of RPMs in a staging area. Yong has taken the WIP set that Deepak had and is in the second cycle of the bootstrapping (we had some plugin version conflicts, pom issues etc., as things have changed a lot in the upstream maven2).  Unfortunately it is nothing that adding more people to it will happen, at least not at this moment.  Once the bootstrap is done, some cleanup and some adjustments to the Requires are implemented and tested, we will start the Koji building in a separate tag that Jess will create for us (so we don't break Rawhide while it is being done).  I will try and keep you guys posted on the progress by commenting on this JIRA on a weekly base.  Regards to all.
Comment 15 Sandro Mathys 2009-04-16 00:39:12 EDT
Patient? The current version of mavenm in Fedora (2.0.4) is 2 years (and some days) old! And 2.0.8 which you guys are working on is old by now, too - the current stable release is 2.1.0 (after .0.9 and .0.10 were released in the meantime). I understand that this is lots of work, but maven is a really important tool and the version in Fedora should never get 2 years old.
Comment 16 Andrew Overholt 2009-04-16 10:57:07 EDT
Thanks for the update, Fernando.  I understand this is a lot of work.  We all look forward to a newer version of maven in Fedora.
Comment 17 Deepak Bhole 2009-05-07 09:17:34 EDT
*** Bug 499588 has been marked as a duplicate of this bug. ***
Comment 18 Fernando Nasser 2009-05-07 10:04:41 EDT
Hi Deepak, Yong has just completed the bootstraping of 2.0.8 after several long weeks of work.  We are now in the process of planing how to get that into Rawhide.

So that BZ should actually have this as a pre-requisite.  Actually, it may be easier to go through 2.0.9 as a way to get to 2.0.10, so we probably need one in-between ;-)
Comment 19 Deepak Bhole 2009-05-07 11:02:10 EDT
Ah sorry, you're right. We need 2.0.8 as an intermediate stage first. I will re-open that 2.0.10 issue tentatively.
Comment 21 Andrew Overholt 2009-05-13 13:34:56 EDT
(In reply to comment #20)
> OK, for all that offered to help and that are package reviewers

Everyone who is a Fedora contributor can be a package reviewer.
Comment 22 Jerry James 2009-05-13 13:39:44 EDT
If someone has time, would full reviews be helpful?  Or would they just be distracting at this point and we should do only the prereviews?
Comment 23 Alexander Kurtakov 2009-05-13 14:49:58 EDT
Make the bug depends on all the Pre-reviews.
Comment 24 Fernando Nasser 2009-05-13 14:58:39 EDT
The packages change between the phases of the bootstrapping so you would be reviewing something not final.  Also, we have urgency in getting these imported into CVS so we can start the bootstraping builds.
Comment 25 Fernando Nasser 2009-05-13 15:17:37 EDT
This is the build order prepared by Deepak.  Please give priorities to the ones higher in this list so we can go and import/build them as they are processed.

       b+i maven2-common-poms
       b+i maven-wagon
	   b+i saxpath
	   b+i backport-util-concurrent
	   b+i bndlib
	   b+i pmd
	   b+i plexus-classworlds
	   b+i plexus-utils
	   b+i plexus-containers
	   b+i modello a15
	   b+i itext
	   b+i plexus-cdc
	   b+i plexus-maven-plugin
	   b+i plexus-xmlrpc
	   b+i plexus-cli
	   b+i plexus-digest
	   b+i dumbster
	   b+i plexus-mail-sender
	   b+i plexus-velocity
	   b+i directory-naming
	   b+i jakarta-commons-jxpath
	   b+i jakarta-commons-configuration
	   b+i jakarta-commons-dbcp
	   b+i easymock
	   b+i javacvs

-> build maven2 in bootstrap mode (--with bootstrap), install that copy 
       b+i maven-surefire
	   b+i maven2-plugin-shade
	   b+i plexus-resources
	   b+i plexus-naming
	   b+i plexus-registry
	   b+i maven-doxia
	   b+i maven-doxia-sitetools
	   b+i maven-shared
	   b+i maven-plugin-tools
	   b+i maven-embedder
	   b+i maven-scm
	   b+i maven-enforcer-rule-api
	   b+i maven-archiver
 

Where b+i => build and then install
Comment 26 Andrew Overholt 2009-05-14 11:13:07 EDT
I took care of the initial pre-review of the following bugs:

#500242 #500245 #500246 #500247 #500248 #500249 #500251 #500252
Comment 27 Jerry James 2009-05-14 15:21:58 EDT
I took care of #500253.
Comment 28 Andrew Overholt 2009-05-14 16:47:49 EDT
I started on bug #500254, bug #500256, and bug #500257.
Comment 29 Andrew Overholt 2009-05-14 16:59:19 EDT
Also, bug #500259.
Comment 30 Alexander Kurtakov 2009-05-15 08:19:21 EDT
I took care of #500261, #500264, #500265.
Comment 31 Alexander Kurtakov 2009-05-15 09:56:18 EDT
And #500266, #500267, #500268 are ready.
Comment 32 Alexander Kurtakov 2009-05-15 10:28:12 EDT
Also #500269, #500270, #500271 are also ready.
Comment 33 Andrew Overholt 2009-05-15 10:34:30 EDT
I believe all of these are now either accepted for pre-review or waiting on changes from Fernando.  Thanks to Alex and Jerry.
Comment 34 Fernando Nasser 2009-05-20 16:18:42 EDT
OK, I've built as many as I could (skipped pmd and itext as we have higher versions, so we will try those).

Thanks for all the pre-reviewers!

We are however now stuck on #500248 with a license problem and without that package we can't proceed (I've already asked Deepak).

I will be away, and be back in June 1st (all the others in my team are working on a product at the moment).  If someone have some time and disposition and could try and disentangle the #500248 situation in the meanwhile that would be of great help.

Regards to all,
Fernando
Comment 35 Fernando Nasser 2009-05-20 17:44:17 EDT
Oh, #50252 as well.

It seems we have lots of problems w.r.t. the licenses of the Plexus project.

I decided to hold on trying to respin the remaining plexus bits as well (there are 3 more in pre-review stage).
Comment 36 Fernando Nasser 2009-05-20 18:04:26 EDT
I meant #500252
Comment 37 Sandro Mathys 2009-05-20 18:44:50 EDT
I raised those licensing issues to the plexus guys in their IRC channel, but there's not been too many people in there and everyone has been idling so far. Maybe I'll get an answer later (depending on their timezones or so), but it'd be probably good if someone brought those issues to their mailing lists.
Comment 39 Jens Petersen 2009-05-28 23:03:40 EDT
I filed a couple of jira's for plexus-cli and plexus-mail-sender upstream at codehaus.
Comment 40 Fernando Nasser 2009-06-01 09:19:35 EDT
If they are shipping it, as this is the same situation in 2.0.9, they must have either: 1) got an e-mail or something from the plexus guys clarifying license 2) Ignored or failed to notice this problem.

Thanks for filing the bugs.  I guess we have to wait till someone responds.

I had some hopes I could continue the bootstrap today but it seems we are still stuck :-(
Comment 41 Jack Tanner 2009-06-01 12:36:27 EDT
Just for the record, the upstream issue tracking is

http://jira.codehaus.org/browse/PLX-417
http://jira.codehaus.org/browse/PLX-418
Comment 42 Jack Tanner 2009-06-01 17:57:33 EDT
I'm not familiar with the Maven devels, but other Apache projects tend to have developers who are very informed about licenses. My gut is that this is all going to be resolved favorably. In the meantime, one suggestion is to proceed with the bootstrap but mark packages as updates-testing. That way the interested users can help test and validate the bootstrap, but the software won't yet be shipped to a wide audience.
Comment 43 Fernando Nasser 2009-06-02 17:07:52 EDT
Even if we don't ship at all but can continue with the bootstrap that would help.  There is enough time before we have to ship this and even promote Rawhide to it for us to get someone's attention at Apache and solve the license problem.

What I would need now was the creation of the cvs for plexus-cli and the others that are blocked so I could continue following Deepak's build recipe.
Comment 44 Fernando Nasser 2009-06-02 17:09:20 EDT
Forgot to mention, we will still have a full review (after some cleanups) to be done before we mass merge these maven 2.0.8 stuff into Rawhide.  We can even add FIXMEs to the spec file saying the license issue must be resolved before the full review can be passed.
Comment 45 Andrew Overholt 2009-06-03 14:59:43 EDT
It would be great if proceeding with the bootstrapping while the legal issues are being resolved is acceptable.  spot?
Comment 46 Tom "spot" Callaway 2009-06-03 15:05:21 EDT
I'm extremely uncomfortable with doing that. I don't want the legal issues to get papered over.
Comment 47 Bug Zapper 2009-06-09 05:25:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 48 Fernando Nasser 2009-06-12 12:56:26 EDT
I guess F12 is our goal now :-(
Comment 49 Jack Tanner 2009-08-18 17:45:00 EDT
The upstream licensing issues have apparently been resolved.

http://jira.codehaus.org/browse/PLX-417
http://jira.codehaus.org/browse/PLX-418
Comment 50 Milos Jakubicek 2009-08-29 09:40:45 EDT
The recent build of 2.0.8 in rawhide lacks some deps:

Error: Missing Dependency: maven-shared-plugin-tools-java >= 2.2 is needed by package maven2-plugin-plugin-2.0.8-1.3.fc12.noarch (rawhide)                   
Error: Missing Dependency: maven-shared-reporting-impl is needed by package maven2-plugin-plugin-2.0.8-1.3.fc12.noarch (rawhide)                             
Error: Missing Dependency: maven-shared-plugin-tools-beanshell >= 2.2 is needed by package maven2-plugin-plugin-2.0.8-1.3.fc12.noarch (rawhide)              
Error: Missing Dependency: maven-shared-archiver >= 2.3 is needed by package maven2-plugin-jar-2.0.8-1.3.fc12.noarch (rawhide)

Are the dependencies correct? If yes, shouldn't also the BR of maven-shared* be versioned? Can I help by resolving them somehow?
Comment 51 Andrew Overholt 2009-08-31 09:18:28 EDT
Sorry, I stupidly added some versioned deps before getting the maven-shared update finished.  You can track the status of the main upgrade here:

https://fedoraproject.org/wiki/MavenUpdate

We're *almost* finished with the remaining deps which will fix this.  If this is a big deal in the mean time, we can untag the latest maven build from rawhide.
Comment 52 Andrew Overholt 2009-09-01 15:32:25 EDT
I have a build going now in non-bootstrap mode:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1648598
Comment 53 Andrew Overholt 2009-09-02 09:33:01 EDT
Now that the non-bootstrap-mode build has succeeded, I think we can close this.  Thanks to all for their help.  Now on to 2.2.x for Fedora 13!

http://koji.fedoraproject.org/koji/buildinfo?buildID=130231

Note You need to log in before you can comment on or make changes to this bug.