Bug 661906 - [abrt] rhythmbox-0.13.1-2.fc14: rb_shell_guess_source_for_uri: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
Summary: [abrt] rhythmbox-0.13.1-2.fc14: rb_shell_guess_source_for_uri: Process /usr/b...
Keywords:
Status: CLOSED DUPLICATE of bug 666291
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4b4269a98894aac96e48536d629...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-09 22:56 UTC by Gerhard
Modified: 2012-03-21 17:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-21 17:53:15 UTC


Attachments (Terms of Use)
File: backtrace (30.54 KB, text/plain)
2010-12-09 22:56 UTC, Gerhard
no flags Details
ogg stream m3u that triggers segfault (38 bytes, audio/x-mpegurl)
2010-12-13 14:40 UTC, Dave Allan
no flags Details

Description Gerhard 2010-12-09 22:56:54 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: rhythmbox --sm-client-id 10637bba48ddc465c2129111728120250800000020750057
component: rhythmbox
crash_function: rb_shell_guess_source_for_uri
executable: /usr/bin/rhythmbox
kernel: 2.6.35.9-64.fc14.x86_64
package: rhythmbox-0.13.1-2.fc14
rating: 4
reason: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: 1. Wanted to open a playlist with nautilus.
time: 1291627082
uid: 500

Comment 1 Gerhard 2010-12-09 22:56:56 UTC
Created attachment 467865 [details]
File: backtrace

Comment 2 Dave Allan 2010-12-12 03:59:13 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  This crash is 100% reproducible, 3/3 times
2.  Go to http://www.amazon.com/s/ref=nb_sb_ss_c_1_17?url=search-alias%3Ddigital-music&field-keywords=tom+petty+refugee&sprefix=tom+petty+refugee
3. Click on the little black and white play icon to play a preview of a song.
4. Choose 'Open with Rhythmbox'
5. Rhythmbox will segfault


Comment
-----
I don't know if it's specific to this URL, I assume not, but I haven't tested.

Comment 3 Dave Allan 2010-12-13 14:40:55 UTC
Created attachment 468394 [details]
ogg stream m3u that triggers segfault

Importing this m3u triggers the segfault on my system.

Comment 4 Dave Allan 2010-12-13 14:43:42 UTC
From what I can tell *any* playlist causes RhythmBox to crash.  It's not specific to any particular stream format or URL.  IMO, this BZ should be severity high as it makes RhythmBox largely unusable for me.

Comment 5 junior 2010-12-16 01:17:48 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.In firefox web browser URL http://www.internode.on.net/residential/entertainment/broadband_radio/#AllInternodeRadioStreams
2.Clicked on link http://media.on.net/radio/131.m3u Rhythmbox is set as default handler for files of type m3u
3.Rhythmbox crashed (as it always does)

Comment 6 abrt-bot 2012-03-21 17:53:15 UTC
Backtrace analysis found this bug to be similar to bug #666291, closing as duplicate.

Bugs which were found to be similar to this bug: bug #649941, bug #652893, bug #666291, bug #669328, bug #670527, bug #675541, bug #700739, bug #737039, bug #741798

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 666291 ***


Note You need to log in before you can comment on or make changes to this bug.