Bug 119386 - (FC2t2-cdboot) Installation CD doesn't boot
Installation CD doesn't boot
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: 119396 119458 119465 119681 120312 120524 120967 121285 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-03-29 18:40 EST by Michiel Toneman
Modified: 2007-11-30 17:10 EST (History)
27 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-28 21:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michiel Toneman 2004-03-29 18:40:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031010 Epiphany/1.0.6

Description of problem:
The installation CD (disk 1) of FC2-Test2 wont boot on a HP Vectra
VEi8 model. 

The same computer boots RH 9 fine, and the FC2-T2 disk has been
verified and works perfectly on an AMD Athlon 1.2Ghz homebuilt system.

The of the Vectra are:

PIII 600
256Mb PC100 Ram

IDEPM = Seagate 13Gb
IDEPS = Empty
IDESM = IDE cdrom
IDESS = Empty

It doesn't even try to boot, the system just gives the "non-system
disk or disk error" message.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot up computer with known-good FC2-Test2 disk 1 in drive
2. System doesn't boot (or boots from HD if configured to do so)
3. Profit?

Actual Results:  The installer should start

Expected Results:  The installer doesn't start

Additional info:
Comment 1 Eugenia Loli-Queru 2004-03-29 20:25:25 EST
It does not boot here either. This machine is the same AthlonXP 
machine that I have installed countless OSes including RH/Fedora, but 
this specific release of Fedora Test 2 just doesn't boot, it thinks 
that the CD is not bootable.
I booted to my Slackware and mounted the CD, everything seems to be 
intact and I am certain that there were not md5um or burning errors.

The machine has an Award BIOS, IDE hdds and CDs (1 DVD-ROM and 1 CD-
RW). Because this machine has 2 CD devices, I tried booting with 
both, but to no avail. The BIOS thinks that this is not a bootable CD.
Comment 2 Eugenia Loli-Queru 2004-03-29 21:03:26 EST
More info:
I tried the CD on my other machine, an AMD Duron 1.3 GHz with an 
AMiBIOS and a completely no-name 52x CD-ROM and it *does* work on 
that machine (so there is definetely a new booting bug here and not a 
case of a user error).

More people seem to have the same problem btw:

Is there a chance that a fixed ISO might be offered to a specific URL 
for us who can't boot the current one? If not, at least please make 
sure that this bug is fixed before final release.
Comment 3 Bill Nottingham 2004-03-29 21:32:06 EST
*** Bug 119396 has been marked as a duplicate of this bug. ***
Comment 4 Graydon Saunders 2004-03-29 21:37:22 EST
Booting from the FC2-test1 cd, swapping CDs at the boot: prompt, and 
carrying on from there worked in my case, as per a suggestion on the 
mailing list.  (hard drive install/ fc2t1->fc2t2 update worked 
Comment 5 Ed Fletcher 2004-03-30 00:11:05 EST
Same as the rest - had to boot from FC1T1 disk and switch to FC2T2
disk at the first prompt.  Install seems to go fine from there.

Motherboard is a Gigabyte GA-7VM400M-P with Award bios v6.00PG dated
2003/11/24 (latest).  I have no IDE hard disks, just two SATA disks
and an LG DVD/CD burner GSA-4081B on the secondary IDE bus.

I did get it to boot on a Compaq EVO N800c laptop.  Don't know what
the reason for sucess there is though.
Comment 6 MP 2004-03-30 12:35:38 EST
I am able to boot, but when I get to the installer options (e.g. 
choice graphical or text install) no matter what I choice text or 
graphical - I received the following error:

StandardError: Invalid modeline in file:
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
    /mnt/runtime done
    disabling /dev/loop0
you may safely reboot your system.

I am using the DVD iso provided at fedora.redhat.com.  My machine is 
a Dell Precision 420 (P3-800).  I have run Red Hat 7.2/8.0/9 Fedora 1 
all on this machine without any problems.
Comment 7 Christian Paratschek 2004-03-30 12:39:19 EST
same problem here:

PIII 550 MHz
mainboard: via technologies, vt82c  
cd-rom: plextor plexwriter 24/10/40 (connected as primary slave)

the same thing happened with mandrake 10 community (but it was
possible to boot from cd 2 with mdk)

this (4 year old computer) has seen billions of linux-installs, always
booted fine, so it's probably fc2t2s boot-bug.

Comment 8 Ron Yorston 2004-03-30 14:34:34 EST
Won't boot on my Athlon XP, Gigabtye GA-7VAX, HP CD-Writer Plus 8100
system.  Though my Dell Latitude L400 boots successfully from the CD.
Comment 9 VnPenguin 2004-03-30 16:34:24 EST
The same bug here: Athlon 1800 box with LITE-ON LTR-48246S (ATAPI 48X
CD-ROM CD-R/RW CD-MRW drive). No problem with FC1 and other distro.
Comment 10 Bill Nottingham 2004-03-30 17:05:48 EST
*** Bug 119409 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2004-03-30 17:06:19 EST
*** Bug 119458 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2004-03-30 17:06:38 EST
*** Bug 119465 has been marked as a duplicate of this bug. ***
Comment 13 Walker Aumann 2004-03-30 17:48:59 EST
Are reports of success with booting from the CD useful in tracking
this down?
Comment 14 Jeremy Katz 2004-03-30 18:02:49 EST
This is very odd since the version of syslinux hasn't changed since
test1.  Can people check if boot.iso boots?  
Comment 15 Eugenia Loli-Queru 2004-03-30 18:38:29 EST
According to this guy (who had the same problem like the rest of us) 
the boot.iso alone did boot: http://www.redhat.com/archives/fedora-
test-list/2004-March/msg02107.html (he had other problems after that, 
but the point is that his boot.iso did boot, while the normal full 
ISO is just not recognized as bootable)
Comment 16 Jeremy Katz 2004-03-30 18:55:01 EST
Okay, then for people that it fails for -- what are you using to burn
your CD software-wise and also what sort of burner are you using?
Comment 17 Eugenia Loli-Queru 2004-03-30 19:08:43 EST
I am using Cheetah Burner on Windows XP. It has always worked well 
for all my needs (including older fedora/RH versions).
My burner is a Memorex DVD/CD-RW combo drive: 48x24x16x48

I don't think the problem can be found on the burner 
software/hardware. I think the problem is with the booting procedure 
on the ISO itself and the way some BIOSes think that it is not 

I had two different CD devices on that machine trying to boot from 
the CD and it wouldn't boot. And on my Duron (with a different BIOS) 
it did boot. The Duron CD device is a crappy 100% no-name CD-ROM, and 
it worked. My AthlonXP (where fedora2t2 doesn't boot, but it is a 
machine that is 100% compatible with many OSes and older fedoras/RHs) 
has a branded Matshita DVD-ROM and a BTC CD-RW, both way more 
compatible than the Duron's CD-ROM. So my gut feeling says that there 
is indeed a *newly introduced* incompatibility with the ISO and some 
Comment 18 Graydon Saunders 2004-03-30 19:18:23 EST
Jeremy - 
I burned the image using cdrecord as of FC2-test1 + updates + 
rawhide, using a Plextor combo drive.  
/proc/ide/ide1/hdc says PLEXTOR CD-R PX-320A 
That same drive has written piles of CDs, many bootable, without 
error, including RH9 and FC1 installation sets. 
Comment 19 Eugenia Loli-Queru 2004-03-30 20:20:15 EST
I thought I should give Red Hat the benefit of the doubt, so I 
reburned the ISO from my PowerMac, using Apple's "Disk Utility" 
software. So that is different software, different burner and I even 
used a different RW media (10x 700 MB).

I had the exact same results. None of the two CD devices on my 
AthlonXP would boot the CD. I think it is now clear: there is a new 
bug in your booting code that makes the ISO not what some BIOSes 
expect and so they are treated as non-bootable.
Comment 20 Graydon Saunders 2004-03-30 22:52:37 EST
A CD with boot.iso on it works for me; the machine boots, the install 
starts, everything proceeds right up until it tells me this is a test 
release and I tell it not to exit. 
Comment 21 Florin Andrei 2004-03-31 00:30:17 EST
Me too. It doesn't boot on my two home PCs.

Downloaded the i386 binary isos via BitTorrent. MD5SUM is fine.
Burned the first CD with cdrecord on a Red Hat 9 system:
cdrecord dev=0,0,0 -v speed=4 FC2-test2-i386-disc1.iso
CD-Writer is Sony DVD RW DRU-510A which works flawlessly otherwise.
The blank CDs are some really crappy Memorex 48x, but they're fine if
you write them at a low speed and anyway i can mount them and read
files. And i wrote two of them, thinking that the first one was bad
for some reason - the second one fails just the same.

One system that fails is a MSI NForce1 mobo, AthlonXP/1800, the CD-ROM

The other system that fails is a cheap mobo, PIII/600, some kind of
Comment 22 Jean Francois Martinez 2004-03-31 00:53:54 EST
I am pretty sure the problem comes from the kernel used in the
platform who did the recording.

1)  I made mediacheck on two CD RWs who had failed booting.  Both had
I/O errors at exactly 67% of completion ie at two thirds and I think
at this point the CD shifts gears.  By lowering recording speed to 24x
I succeeded to record a CD/R (not RWs), who passed the test but had a
BIG slowdown at 67% as if trying to reread each sector two or three
time before succeeding.   This CD failed to boot in any of my high
speed IDE drives (despite having passed the mediacheck on one of them)
but booted unreliably from a 24x SCSI (CD reader)

ALL of the above CDs  were being made on RedHat 9 with
kernel-2.4.20-30.9 and the current cdrecord (who hasn't moved since
summer 2003 and has successfully recorded FC1 and FC2test1).  
During the recording with this kernel the behaviour of xcdroast was
unlike what I was used to:  a) machine became severaly irressponsive
(no DMA?)   b) the fill ratio of the buffer and Fifo varied constantly
between 0 and 100% with the speed also varying erratically.  Normal
behaviour is: machine reamins responsive, fill ratio of buffer rarely
goes under 90/95%, recording speed varies little from second to second
but has a general trend for acceleration.

Notice that with this kernel NO CD/R recorded at 48x succeeded in
booting be it from the IDE readers or from the 24x SCSI reader.  One
who was recorded at 24x succeed booting on the SCSI but more often
than not it failed.

Then I recorded a CD/R on the vanilla kernel shipped with Fedora Core
1 and behaviour of xcdroast was back top normal.  A CD recorded at 48x
still failed to boot from the IDE readers but realiably booted from
the SCSI reader.  Could be that my CDs are not that good (but they
worked for FC1T1). I still haven't tried to lower the recording spped
but the fact is that a CD recorded at 48x with FC1 looks more reliable
than one recorded at 24x with kernel-2.4.20-30.9.
Comment 23 Sean Earp 2004-03-31 00:57:13 EST
Booting to the FC2T2 Disc 1 fails for me also.  It was burned on Mac OS 10.3.3 using 
Roxio Toast on a PHILIPS  CDD5101 burner from a BitTorrent download that checks out 
fine with the MD5 checksums.

The computer that it fails to boot on is an Athlon xp 2500+/Soyo KT400 Dragon Ultra MB/
Memorex DVD drive set to Secondary Master.  (Boots to FC2T1 Disc 1 just fine)

The EXACT SAME DISC boots fine on a P4 3GHz/Intel 865mb/TDK 48X CDRW set as 
secondary master.

I am also able to boot to    boot.iso  with no problems.  If there is any other information 
you need, let me know and I'll pull it up for you.
Comment 24 Michiel Toneman 2004-03-31 01:46:29 EST
I cooked a second disk1 at a low speed using a CD-R instead of a CD-RW
just to be sure, but this exhibited the same behaviour as the first
disk. First disk was burned using K3b, second one using gcombust. 

I then proceeded to download and burn FC2 Test1 disk1. This booted and
got me to the "boot:" prompt. Swapped out the CD for FC2 Test2 disk1
and pressed <ENTER>. The installation proceeded fine from that point
Comment 25 Scott Sloan 2004-03-31 02:38:05 EST
Failed for me. Used cd swap trick to get it going. I burnt the disk using


which was the latest from the development tree.
Comment 26 Frank Larsen 2004-03-31 03:33:01 EST
I tried to boot the FC2t2 CD on several machines with diferent
'normal' cd-rom drives without luck. Then found that if WOULD boot on
my laptops MATSHITA UJDA710 DVD(read)/CD(born) drive on my Asus B1000
(PIII, 512mb)

The CD was burnt from ISO image using NERO burn 6
Comment 27 Michael A. Peters 2004-03-31 04:08:26 EST
I have the EXACT SAME issue with Mandrake Community 10

boot.iso does work.
I burned with cdrecord from FC2T1 - which burns FCT1 CD's that do boot.

But check with the Mandrake people - they have the same issue with
their Community Download 10
Comment 28 Michael A. Peters 2004-03-31 04:12:51 EST
With Mandrake, they have a boot floppy that does work to boot the system.
Perhaps a boot floppy image could be made and spread to the mirrors?

1.44MB is a lot easier to download than a FC1T1 iso.
Comment 29 Ron Yorston 2004-03-31 06:21:14 EST
The CD was burnt on my Athlon XP machine using the HP CD-Writer Plus
8100 and the cdrecord from FC1.  The CD passes the media check when it
boots on my Latitude, but it won't boot on the Athlon.
Comment 30 Chen Nan 2004-03-31 10:14:24 EST
Same here. FC2T2 CD1 failed to boot.

ISO file MD5 checksum ok. CD was created using xcdroast on RH9.

Athlon XP 2500+
ABit NF7-S (nForce 2)

RH9 and FC1 cds can boot on the same machine.
Comment 31 Need Real Name 2004-03-31 11:15:23 EST
me to ;(

MD% ok - tried with xcdroast & cdrecord

Seeing as respin just isn't going to happen...

Can i suggest putting an additional small boot.iso up on the mirrors
for people to use that are having problems.
Comment 32 Chen Nan 2004-03-31 11:51:56 EST
>Same here. FC2T2 CD1 failed to boot.
>ISO file MD5 checksum ok. CD was created using xcdroast on RH9.
>Athlon XP 2500+
>ABit NF7-S (nForce 2)
>RH9 and FC1 cds can boot on the same machine.

Update: The boot.iso works, the installation started successfully.
Comment 33 Thorsten Leemhuis 2004-03-31 12:44:54 EST
Same problem here on one machine. Two others boot fine with the same
CD. Burned with cdrecord.

AMD Athlon(tm) XP 3000+
Asus A7N8X-Deluxe (nForce2), Bios 1006

A Knoppix c't 3.4 with isolinux boots fine on this machine.

BTW: From
Error scenario: Unable to boot from CD1.
Why: Unknown; this only seems to happen with some CD-ROM drives
Solution: Boot from CD2 instead.
Comment 34 Leonard den Ottolander 2004-03-31 17:12:52 EST
MP (comment #6) please file a *separate* bug report for your issue.

No valid mode lines? Even in text mode? That seems anaconda or xorg
config related.

Dell Precision 420, what video card does that have?
Comment 35 Féliciano Matias 2004-03-31 17:37:02 EST

	[PATCH] EDD: Get Legacy Parameters
	From: Matt Domsch <Matt_Domsch@dell.com>
	Patch below from Patrick J. LoPresti and myself.  Patrick describes:
	Why this patch?  The problem is that the legacy BIOS interface
	(INT13/AH=3D08) for querying the disk geometry returns different values
	than the extended INT13 interface which the EDD code currently uses.
	is because the legacy interface only provides a 10-bit cylinder field, so
	modern BIOSes "lie" about the head/sector counts in order to make more of
	the disk visible within the first 1024 cylinders.

  find enclosed short ISO images test results ...

test-boot-1034.iso - boot
test-boot-2034.iso - boot
test-boot-35.iso   - boot
test-boot-928.iso  - boot
test-boot-929.iso  - doesn't boot
test-boot-930.iso  - boot
test-boot-939.iso  - boot
test-boot-942.iso  - boot

And http://archives.mandrakelinux.com/cooker/2004-03/msg04336.php

I had the not uncommon problem of CD 1 failing to boot. The cause seems to
be that CD 2 uses floppy emulation whilst CD 1 doesn't. See

I followed the instructions in the paragraph with the heading "Booting the
installer" to burn a new version of CD 1 that uses floppy emulation. This
new CD 1 now boots quite happily on my machine.

Hope this help.
Comment 36 Jean Francois Martinez 2004-04-01 00:56:56 EST
I tried what I told in another post: downgrade the recording speed and
use a differnt kernel (see above for the reasons I have to be
suspicious of the latest update to the kernel of RedHat 9) but to no

About what someone said here (the fact FC2T2 is not using CD
emulation) I will try to reproduce the problem (ie remake the CD with
and without floppy emulation) but in case it is that then I complain:
it would mean that FC2T2 is usig a feature not supported by even
quiyte recent boxes (mine is a 2GHz Athlon bought in Feb 2003)
Comment 37 Harald Hoyer 2004-04-01 09:37:29 EST
*** Bug 119681 has been marked as a duplicate of this bug. ***
Comment 38 Michael Doppler 2004-04-01 10:49:48 EST
Same problem here on a VIA EPIA CL Motherboard ( VIA CLE266 North
Bridge / VIA VT8235 Southbridge ).

I suspect this to be a syslinux/isolinux problem. 

The syslinux version itself has already been ruled out as a problem in
Comment #14 of this bug, but maybe there are any significant changes
in the syslinux config in comparison to FC2 test1?
Comment 39 Féliciano Matias 2004-04-01 11:31:22 EST
Another pointer to Mandrake experience with Linux 2.6 :
"Can't boot windows xp after installing rc1"

Comment 40 Jared Smith 2004-04-01 13:36:42 EST
Same problem here on an HP d220 desktop.  Boot.iso works fine, but
disk 1 of FC2T2 doesn't boot.  This same disk boots fine on my Compaq
Evo laptop.  I verified the md5 checksum of the ISO before burning,
and also checked the disk with the anaconda-runtime checksum checker
(can't remember it's name) tool.  It passed with flying colors...  Any
idea why it won't boot?  If it makes any difference, I've tried it
both an CD-ROM and DVD-ROM drive in the desktop machine, but it won't
boot from either.

I'm more than happy to be a guinea pig for testing anything...
Comment 41 Jeff Lindberg 2004-04-02 00:32:44 EST
Add me to the list of people who have issues booting FC2 Test 2 CD on 
*one* of my systems.  The same disk which refuses to boot on a Tyan 
S1834 (Dual 800MHz PIII - VIA chipset), boots just fine on an Asus 
A7M266D (Dual Athlon MP 1800, AMD 760 chipset) and a Tyan S2688 (Dual 
Athlon MP 1900, AMD 760 chipset) system.

By "refusing to boot", I mean the system doesn't recognize CD #1 as a 
bootable disk.

ISO's were verified against MD5SUM prior to burning.  Burned three 
copies of disk #1 on three different CD writers (using Nero 
one at 8x and the other two at 4x.  Fails to boot on all three CDs on 
the S1834 and boots fine on the other two systems.
Comment 42 Jeff Lindberg 2004-04-02 00:39:39 EST
I should mention, too, that FC2 Test 1 CD#1 boots fine on the S1834 
system that won't boot FC2 Test 2 CD#2.
Comment 43 schiebe 2004-04-02 01:52:20 EST
Same here. Cant boot with FC2 test 2 CD1 on my P2B-S (PIII). I tried
it with a Sony Cd-Burner, a LG-DVD and with a LiteON- DVD. I burned
with k3b, in the shell and with nero. Always the same. But on my
A7V333 the CD was/were (i dont know:) booting well. 
Comment 44 Russell Coker 2004-04-02 03:34:42 EST
On my Athlon 2600 with a "Phoenix AwardBIOS" I can boot from my  
Plexstor SCSI CD drive but not from a Pioneer IDE DVD drive which is  
Maybe this is just an IDE issue, I can't see any reports of problems  
with SCSI CD-ROMs.  
Comment 45 Sean Bruno 2004-04-02 15:37:49 EST
One more for this bug...

Custom PIII system using a Pioneer DVDROM to read the CDR.

There apears to be no boot image for the system.
Comment 46 Eugenia Loli-Queru 2004-04-02 15:41:22 EST
There is no reason to detail what CD-ROMs you got. This is a BIOS 
issue. It seems that BIOSes used *mostly* with computers using 
AthlonXP are affected. It would more useful to detail what BIOS 
exactly you got.

Besides, the bug has already being fixed on the Linux kernel, all Red 
Hat has to do is pull the patch in in their kernel.
Comment 47 Jean Francois Martinez 2004-04-02 16:04:10 EST
To compound on comment  #44: I have been unable to boot on any of the
two IDE CD drives from my Athlon XP and on the IDE CD drive from my
old K6, but the later has an SCSI CD drive and I can boot from it.
Comment 48 Eugenia Loli-Queru 2004-04-02 16:08:39 EST
>has an SCSI CD drive and I can boot from it.

Yes, this is normal. SCSI cards (and even most IDE cards) have *their 
own BIOS* to do a lot of stuff, they don't ask the PC's BIOS how to 
boot a CD. So to recap, this is a BIOS problem, not a CD device one. 
Having a SCSI card will help, because they have their own BIOS.
Comment 49 Jared Smith 2004-04-02 16:19:00 EST
Well, I'll add another data point or two related to the BIOS.

Every machine I've had problems on has been an Intel Pentium 4 system
, not an Athlon XP.  The machine I'm currently having problems on has
an MSI 865GM2-LS motherboard in it, with BIOS version W6743IMS v5.3

I'm also seeing the same problem on an HP d220, and I'll report its
BIOS version one I can get my hands on the box again.
Comment 50 Larry Nguyen 2004-04-03 12:13:16 EST
Eugenia, #46: Not really because of BIOS on AthlonXP box. My box is 
PIII and CD1 doesn't boot. Weird thing is it boots under vmware ;). 
So I guess it's BIOS issue. The drive is LG DVD-ROM. CD1s were 
created several times using both CD-R, DVD+RW on two different 
machines using kernel 2.4 and 2.6 and they still won't boot, except 
when I use vmware4 
Comment 51 Eugenia Loli-Queru 2004-04-03 13:54:19 EST
>Eugenia, #46: Not really because of BIOS on AthlonXP box.

Did you read that I wrote "*mostly*"?
Comment 52 cris farmer 2004-04-03 18:02:24 EST
Mine would not boot either.  AMD Athlon XP  1gig memory.  Burnt on a
windows xp PC running easy CD 5.  Switching from fc2 test1 to fc2
test2 at the boot prompt worked for me also.
Comment 53 Dan Hollis 2004-04-04 01:07:26 EST
Shuttle SB52G2 with Celeron 2600.

FC2T1 boots perfectly.
FC2T2 does not boot at all. Neither CD nor DVD images.

This is not faulty hardware. I've done every possible hardware swap
and reburning CD/DVD and verifying md5sum etc and confirmed 100% it's
a bug in the FC2T2 ISOs themselves.
Comment 54 Leonard den Ottolander 2004-04-04 10:56:21 EDT
All this "me too" seems unnecessary if no details on the machine's
BIOS are provided. The fact that booting fails on various machines has
been established, so now we need to know which machines/BIOSes are

Comment #35 suggests that the problem is related to the location of
the boot catalog in the image. (Too bad that is not mentioned inline
there.) So at least there is a workaround. And if this is a BIOS issue
as it appears to be all one can do is work around it (ie create images
that fullfill the BIOS restrictions).

Comment #39 is about a different issue (both involve the BIOS, but
they are different issues). A bit confusing Feliciano to add that info
here. This is a disk drake issue. Partitioning tools should not change
existing geometry which is already written to the partition table. If
the partition table and the BIOS conflict data from the partition
table should always be used.
Comment 55 Michael Doppler 2004-04-04 18:54:31 EDT
I got FC2 test2 to boot by recreating the CD1 iso image:

1. Copy the files from FC2 test2 CD1 to a temporary directory:
        cp -a /mnt/CD1mntpoint /tmp/FC2test2

2. Create a new CD1 iso image:
        cd /tmp/FC2test2
        mkisofs -v -r -T -J -V 'Fedora Core 1.91 CD 1' -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 20 -boot-info-table -l -R -o /tmp/FC2test2-CD1.iso .

3. Burn the new iso image /tmp/FC2test2-CD1.iso.
Comment 56 Markus 'Domes-DOS' Weis 2004-04-06 12:26:09 EDT
Same problem with me ... no matter what I try to boot from CD, it
works: Win98, RH9, FC1, Free BSD 5.2 all work fine, but FC2-test2-CD1
I burned my FC2-test2-CDR's using dvdrecord on RH9 on the correctly
downloaded ISO-images.

Here's some BIOS DETAILS that I collected with some PCs of mine and
the PC's of some friends:

These machines did not boot the FC2-test2-CD1, but booted from the CDR
made with the 4MB boot.iso:
- Asus P5a, AMD K6-2, Award Bios, Asus DVD drive
- Asus P5a, AMD K6-2, Award Bios, Toshiba CDR drive
- QDI Legend, Pentium III, Award Bios, Toshiba CDR drive
- Aopen AX59 Pro, AMD K6, Award Bios, Acer CDR drive

These machine did not work neither with FC2-test2-CD1, nor with the
CDR made with the 4MB boot.iso:
- Asus P/I-XP55T2P4, Pentium 133, Award Bios, Toshiba CDR drive - it
managed to boot somehow ... output was some strange ascii-chars, then
failed (but this happened with RH8 and RH9, too), even failed with the
4MB iso-boot-CD

These machines worked fine:
- a Siemens Scenic (Pentium 166) notebook with Phoenix NoteBios 4.0
booted from FC2-test2 CD1 quite fine.
- Asus Board A7A266, AMD Athlon, Award Medallion Bios 6.0, Samsung
DVD-Drive (Secondary Master)
- Asus P4B533, Award Bios, Samsung DVD drive

After recreating FC2-test2-CD1 according to comment#55 it worked fine
on all machines except the Asus P/I-XP55T2P4 PC, but that's a familiar
problem to me.

So in my case it seems that the newer machines (younger than 3 years)
with Award-BIOS run fine.
The older machines (3-6 years) with Award BIOS seem to have problems,
especially those with Award Bios v4.51PG.
Googl'ing 'award bios cd boot problem' brings some proof here ...
seems that other people have problems with Award-BIOS'es as well.
Comment 57 michael mastrangelo 2004-04-06 20:28:12 EDT
When I do the trick (put in test 1 cd and then switch to test 2 cd) it
also messes up and when it asks for the next cd it doesnt pop out the
cdrom like fedora core 1 did... 

Also it has problems with my windows partitions... It freezes like
mandrake 10 does. So i cant "review" the changes...
Comment 58 Abe Drier 2004-04-06 22:10:36 EDT
I was successful in switching from the Test-1 CD-1 to Test-2 CD-1.  I 
have a white box with Award Modular BIOS V6.00PG.  When I permitted 
the installation process to check disk 1, it reported that CD-1 was 
corrupted.  However, I did a successfull install.  If you need the 
detailed configuraiton options of the BIOS, let me know and I will 
collect them.
Comment 59 Jan Bielawski 2004-04-06 22:32:44 EDT
The Test 1/2 CD switch didn't work for me but the following little
addition did the trick:

1. Insert the Test 1 CD.
2. At the boot: prompt switch to the Test 2 CD. Do not hit Return.
3. Push F5 for the rescue mode information. The rescue mode info
screen appears.
4. Push F1 to go back to the main screen again.
5. NOW push Return.

It booted from there. If this was a regular C program I'd say it
behaved like an uninitialized variable bug...
Comment 60 Hugo Oliveira 2004-04-07 04:41:04 EDT
I have the same problem my board is a Gigabyte GA-8SIMLH-P with a 
SIS651 Chipset, and a Combo LG. I also try in other older machines 
but the problem doesn’t occur. In my opinion the problem is due to 
Chipset models. The older boards that I use have all Intel chipset.

I use a DOS boot diskette with a loadlin pointing to the first CD of 
FC2T2 to solve the problem. 

Comment 61 Dave Rogers 2004-04-07 05:44:13 EDT
Following proceedure in Comment #59 from Jan Bielawski works on all
six of my machines. I had previously tried reburning the CD with the
steps in Comment #55 but this did not boot on all machines. I have to
agree with Jan's analysis of the potential source of the problem: no
code changed but the _path_ through the code does and it works.
Comment 62 Thorsten Leemhuis 2004-04-07 12:12:14 EDT
FYI: I was also able to rebuild the FC1 CD (suimilar to comment #55)
and boot from it where the CD burned from the ISO did not work. I
tried with  -boot-load-size 4 and -boot-load-size 20, both worked.

Is somebody @redhat/"responsible" interested in more details / tests
on my system that had problems with the ISO? Like the test in

Comment 63 Martin A. Boegelund 2004-04-07 15:22:58 EDT
"Me too!"
Can't boot from FC2t2.
"P4 Mainboard, L4S5MG Series, SiS chipset", Celeron 2GHz, Award Bios
Comment 64 Tim Powers 2004-04-07 18:54:12 EDT
With FC2T2 the isos don't contain any padding whatsoever. When we burn discs in-house 
for testing using cdrecord we add "-pad padsize=150s". Are any of you adding this, and 
has it helped or is there no change? I'm not sure what the equivalent args are for the 
Windows apps people are using, so you'll have to investigate to see if the burn app even 
provides this functionality.

Something we're trying now (as of today for internal RHEL and Fedora isos) is to use a 
newer mkisofs which defaults to 
adding 150s inside the iso itself instead of relying on it during the CD burn. We're not sure 
if this will solve this specific problem, but with luck it will. I'll get with Elliot Lee to see if he 
can generate a test set of isos for a rawhide tree this week so that it can be tested widely.
Comment 65 Tim Powers 2004-04-07 19:19:18 EDT
In addition to #64, and in response to #55 we're going to try using "-boot-load-size 20" 
instead of "-boot-load-size 4" which is what we are curently using.
Comment 66 Florin Andrei 2004-04-07 22:40:55 EDT
Tim, i'm using cdrecord-2.0-11.9.1, i didn't add any -pad option to
it, just a very minimal set of options (dev, speed, -v and that's
about it) and yet the FC2T2 installer failed to boot.
Comment 67 Michael Doppler 2004-04-08 04:19:20 EDT
I am not sure the -boot-load-size 20 is the parameter that makes the 
difference (see comment #62). I have to admit that I didn't read the 
isolinux docs, which suggest using -boot-load-size 4, when choosing 
the value for this parameter. So I rather believe that the padsize 
change in newer mkisofs versions you mentioned fixes the issue. But 
because it can't be ruled out that it was the -boot-load-size 20 that 
did the trick, tests by people having the problem would be 

So everyone who has problems booting FC2 test2: 
Please try to remake your CD1 as described in comment #55 with -boot-
load-size 4 and another time with -boot-load-size 20 and report:
- Which of the -boot-load-size parameters worked.
- What mkisofs version you were using to create the image.
- What Motherboard and BIOS you testet this with.

I have been using mkisofs 2.01a24 on cygwin to remake the image by 
the way.
Comment 68 Tim Powers 2004-04-08 07:56:58 EDT
Florin: Can you please try burning with "-pad padsize=150s" please?
Comment 69 Ron Yorston 2004-04-08 14:08:51 EDT
I've tried "-pad padsize=150s".  It doesn't make any difference, the
CD still won't boot.
Comment 70 Tim Powers 2004-04-08 14:13:26 EDT
Ron: Thanks for the feedback. That helps narrow it down (to what, we still don't know).
Comment 71 Anthony Green 2004-04-08 21:54:08 EDT
Add me to the list.  It doesn't get recognized as a bootable ISO on 
a) Dell Precision with Pheonix A06 bios, and
b) IBM Thinkpad, bios version 1.04 (1NET10WW)

I believe I tried all the various mkisofs and cdrecord options listed
above on my RHEL3 host, however I have a bit more to add...

Prior to trying the ISO images from the net, I was manually
constructing a live CD from the Fedora Core 2 test2 RPMS and had no
problem booting.  Then I started upgrading the RPMS to the latest
development RPMS.  Everything was working perfectly until I copied the
new kernel (kernel-2.6.5-1.308.i586.rpm) into my isolinux directory. 
Now it won't boot (except in VMWare).  After a bit of googling I
stumbled across this problem and tried the official test2 ISOs in
order to reproduce the problem.

Looking forward to a fix...
Comment 72 Jonathan M. Prigot 2004-04-08 22:19:21 EDT
All isolinux disks worked on my systems: Soyo 6BA+ IV-2BA5 w/Award 
4.51PG, and Soyo K7VIA-2AA4 w/Award 6.00PGN. The original disc 1 
worked on my HP d300, and an old Micron machine w/Phoenix BIOS. 
Comment 73 Captain 2004-04-09 01:18:29 EDT

* burn boot.iso (~4.2Megs) on a CD
* run that CD and at the boot prompt insert FC2test2 CD1
  and type:

/isolinux/vmlinuz initrd=/isolinux/initrd.img ramdisk_size=8192

CD1 resumed operations and install worked fine for me!
Comment 74 Elaine Normandy 2004-04-09 12:57:08 EDT
I had the same problem.  Fixed it by using instructions in comment 55.

Athlon processor, bios info from meidecode

SMBIOS 2.2 present.
33 structures occupying 939 bytes.
Table at 0x000F0800.
Handle 0x0000
        DMI type 0, 19 bytes.
        BIOS Information
                Vendor: Award Software International, Inc.
                Version: 6.00 PG
                Release Date: 04/01/2003
                Address: 0xE0000
                Runtime Size: 128 kB
                ROM Size: 256 kB
Comment 75 Tom Horsley 2004-04-10 20:54:35 EDT
Just to add to the collection of "me too's", the FC2 test2 CD 1
won't boot on my abit KT7A-RAID system. It apparently tries, because
the ATAPI BOOT: message shows up for a fraction of a second, then
it immediately switches to the normal hard disk boot.

If I burn a copy of the images/boot.iso it does boot from that,
but that kernel has no CD driver, fortunately the CD-RW I was
using is SCSI, so I was able to install using the scsi CD-RW
to read the media after booting with boot.iso on the IDE drive
(the scsi drive isn't bootable at all).
Comment 76 Need Real Name 2004-04-11 11:33:33 EDT
I've had the same problem. My system was not booting from CD-rom.
However after changing my BIOS to boot from SCSI instead of CDROM I
could boot my system from the SCSI-cdrom.
Comment 77 Jeremy Katz 2004-04-11 14:34:31 EDT
*** Bug 120524 has been marked as a duplicate of this bug. ***
Comment 78 Martin A. Boegelund 2004-04-11 16:15:29 EDT
Couldn't boot from the original FC2test2 CD1.
Followed the instructions in #55, and the resulting CD boots, so this
works for me.
"P4 Mainboard, L4S5MG Series, SiS651 chipset", Celeron 2GHz, Award Bios
Comment 79 Vladimir Vukicevic 2004-04-11 20:34:08 EDT
Boot failed as well; EPoX 8RDA+ motherboard (nVidia nForce2 based),
BIOS version 6A61 BPAA (latest one according to the epox update
utility).  AthlonXP.
Comment 80 Captain 2004-04-12 03:39:19 EDT
Followup on my tests in order to reproduce a non-bootable CD1 of FC2test2:

"isodebug /dev/cdrom" shows the same "mkisofs" options for FC1-CD1 and
FC2test2. The only difference to my iso image is:
FC1-CD1 and FC2test2 were built with mkisofs1.14, while I did my iso
images with mkisofs2.01a24 (mkisofs2.01a24 is shipped with FC2test2)

But that doesn't seem to be the reason for the non-bootable
FC2test2-CD1 on my test-box, since I also made an image with
mkisofs1.14 and it booted fine.

Still the only differences I get are:
* size of the iso image of FC2test2-CD1 is different to the original
size (mine is 15megs bigger)

* boot.cat and isolinux.bin are modified differently by mkisofs:

bytes     28 29 30:
FC2test2: 03 06 00
boot.iso: 79 05 00
my image: EB FC 04

bytes     12 13 14
FC2test2: 03 06 00
boot.iso: 79 05 00
my image: EB FC 04

This seems to be the checksum created by the mkisofs option
-boot-info-table. When I omitted the option -boot-info-table for
mkisofs my FC2test2-CD1 wasn't bootable, but ISOLINUX reported a
checksum error at boot:
ISOLINUX 2.00 2003-12-12 isolinux: Image checksum error, sorry...
Boot failed: press a key to retry... 

..while the message of the original FC2test2-CD1 is:
Boot from ATAPI-CDROM: Failure ...
GRUB loading stage2

..and it continues to boot the installation of FC2test2 from the harddisk.
Comment 81 Rich Hart 2004-04-12 10:01:40 EDT
Include Shuttle sn41g2 in the won't boot list.  Trying to boot from
NEC DVD_RW ND-1300A, XP2600 processor
Comment 82 Heinz Hemken 2004-04-13 01:59:41 EDT
Hi All,

I tried the workaround suggested in #55, but mkisofs said:

[root@wallstreet FC2test2]# mkisofs -v -r -T -J -V 'Fedora Core 1.91
CD 1' -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot
-boot-load-size 20 -boot-info-table -l -R -o /tmp/FC2test2-CD1.iso .
mkisofs 2.0 (i686-pc-linux-gnu)
Scanning .
Scanning ./cdrom
Scanning ./cdrom/Fedora
Scanning ./cdrom/Fedora/base
Excluded: ./cdrom/Fedora/base/TRANS.TBL
Scanning ./cdrom/Fedora/RPMS
Excluded: ./cdrom/Fedora/RPMS/TRANS.TBL
Excluded: ./cdrom/Fedora/TRANS.TBL
Scanning ./cdrom/images
Scanning ./cdrom/images/pxeboot
Excluded: ./cdrom/images/pxeboot/TRANS.TBL
Excluded: ./cdrom/images/TRANS.TBL
Scanning ./cdrom/isolinux
Excluded: ./cdrom/isolinux/TRANS.TBL
Excluded: ./cdrom/TRANS.TBL
mkisofs: Uh oh, I cant find the boot catalog directory 'isolinux'!

I then tried the workaround in #73, and it seems to have worked. I am
on CD 2. I have an old Phoenix or Award BIOS, from 1997 on a 133 MHz

If this thread persists, I'll send more specifics.
Comment 83 Martin A. Boegelund 2004-04-13 14:39:18 EDT
In reply to #67.
Sorry for the redundancy of info, but I think it's better to have
everything in one place:

My "original" FC2test2 CD1 did NOT boot. So I followed the
instructions in #55 and #67 to make new CD1's with different
-boot-load-size parameters.

As requested in #67, my info is:
- both -boot-load-size 4 AND -boot-load-size 20 worked; CD1 booted OK
with each parameter value.
- mkisofs used: mkisofs-2.0-11.9.1 (rpm -q in RH9 system)
- Motherboard: L4S5MG/651+ Ver1.0d 09/10/2002.
  Chipset: SiS651.
  BIOS: AwardBIOS v6.00PG.

Hope this helps tracking this one down.
I'll gladly provide additional info if required.
Comment 84 Tim Powers 2004-04-13 15:51:45 EDT
OK. Thanks to everyone for the info. The problem isn't nailed down yet, but a common 
theme is that mkisofs-2+ works, wheras the older 1.x version we were using may be the 

Something to note: With the new mkisofs we should get the 150s padding within the iso 
for free, so it may solve other potential problems as well.

FC2T3 will use the newer mkisofs for iso creation, so hopefully the problem magically 
Comment 85 Anthony Green 2004-04-13 16:19:49 EDT
WRT comment #84, this is not my experience.  I am using mkisofs-2.0-11
on RHEL3 and I don't believe it works.
Comment 86 Tim Powers 2004-04-13 16:33:24 EDT
In response to #85: The mkisofs we'll be using is mkisofs-2.01, that may or may not make 
any difference.
Comment 87 Jeremy Katz 2004-04-15 17:12:35 EDT
*** Bug 120967 has been marked as a duplicate of this bug. ***
Comment 88 advax 2004-04-15 20:49:27 EDT
followed the recipe #55, CD boots but says it can't test media as
there is no checksum; don't see "checksum" in manpages for mkisofs or
cdrecord so not sure how to do this.

mkisofs 2.0-11.9.1
Creative CDROM as per duplicate # 120967 above
Comment 89 Anthony Green 2004-04-18 12:16:38 EDT
Re: comment #87 - FYI, I downloaded cdrtools-2.00.3, and that version
of mkisofs _did_ create a bootable ISO.
Comment 90 Captain 2004-04-18 12:24:58 EDT
Anthony, Jeremy,

so far all my numerous attempts to recreate a non-bootable test2-CD1
failed. Just the original test2-CD1 fails to boot on my test-machine.

If you have a test2-CD1 iso made with a newer version of mkisofs, just
email me the URL to download and I will try it!
Comment 91 Bill Nottingham 2004-04-19 23:22:42 EDT
*** Bug 121285 has been marked as a duplicate of this bug. ***
Comment 92 Miloslav Trmac 2004-04-21 11:06:14 EDT
*** Bug 120312 has been marked as a duplicate of this bug. ***
Comment 93 Cliff Haerden 2004-04-21 12:56:37 EDT
why is this call closed ??? I still see no easy solution. Has somebody
a working iso ???
Comment 94 Leonard den Ottolander 2004-04-21 13:03:43 EDT
Because your report was found to be a duplicate of this one. The issue
is tracked here. You could have seen that.
Comment 95 Cliff Haerden 2004-04-21 13:12:12 EDT
hmzz sorry i got a mail that said that this problem was solved sorry.
Comment 96 Captain 2004-04-21 14:25:14 EDT
Please post the cause and/or solution!!
Comment 97 Cliff Haerden 2004-04-21 14:41:37 EDT
Well captain that was the same thing I thought when I read the mail
and so I came over here to check it out. That's why I also asked above
why this issue was solved because there is no solution :-) WOW What an
explication so I see it is changed again to open ...

So still no solution except some gui's that recreated the cd or
something like that. I would love to see some of them making an ISO of
their disk :-) 
Comment 98 Captain 2004-04-26 14:39:28 EDT
I installed FC2test3(!) today (got the iso's from a mirror which
already enabled the 1.92 directory by accident) and CD1 booted just
fine on my "problem machine"

So I think the problem is solved - at least on my machine. 
Comment 99 Cliff Haerden 2004-04-26 15:07:00 EDT
Wel I have found a solution for this issue however I don't know if it
is a good one. So people try this it is pretty easy :-)

You download cd1 of rc1
boor from it and then when you have to press enter to install you
place disk one of fedora rc2 :-)

It worked over here. Seems the boot sector of the disk was some kind
of messed up ...

Comment 100 Thorsten Leemhuis 2004-04-28 11:50:56 EDT
FC2T3 works for me, T2 did not (see Comment #33). Solved for me.
Comment 101 Florin Andrei 2004-04-30 02:28:23 EDT
FC2test3 works for me on a machine where the previous version didn't work.

Note You need to log in before you can comment on or make changes to this bug.