Bug 801383 - [abrt] kernel: [213799.962012] WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397 iwlagn_tx_skb+0x99d/0xa20 [iwlwifi]()
[abrt] kernel: [213799.962012] WARNING: at /builddir/build/BUILD/kernel-3.2.f...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:a99f7ca89c4db9f12d0931fa24f...
:
: 785913 803382 803680 806380 806576 806719 808794 809664 810008 810191 810751 811222 811455 813645 813886 816589 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 07:12 EST by Steven Bakker
Modified: 2012-10-05 08:55 EDT (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 08:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Bakker 2012-03-08 07:12:01 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.7-1.fc16.x86_64 root=/dev/mapper/vg_cluestix-lv_root ro rd.lvm.lv=vg_cluestix/lv_root rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rd.luks.uuid=luks-d36539d7-14b0-418e-8e52-63083a017792 rhgb LANG=en_US.UTF-8 rd.lvm.lv=vg_cluestix/lv_swap
kernel:         3.2.7-1.fc16.x86_64
reason:         [213799.962012] WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397 iwlagn_tx_skb+0x99d/0xa20 [iwlwifi]()
time:           Thu 08 Mar 2012 13:11:15 CET

backtrace:
:[213799.962012] WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/iwlwifi/iwl-agn-tx.c:397 iwlagn_tx_skb+0x99d/0xa20 [iwlwifi]()
:[213799.962015] Hardware name: Latitude E6420
:[213799.962016] Tx while agg.state = 2
:[213799.962018] Modules linked in: wacom usb_storage tcp_lp fuse lockd rfcomm bnep snd_hda_codec_hdmi snd_hda_codec_idt binfmt_misc uvcvideo arc4 videodev media v4l2_compat_ioctl32 uinput snd_hda_intel ppdev snd_hda_codec joydev btusb dell_wmi dell_laptop sparse_keymap bluetooth snd_hwdep dcdbas snd_seq microcode snd_seq_device snd_pcm i2c_i801 iwlwifi parport_pc parport iTCO_wdt mac80211 iTCO_vendor_support snd_timer snd e1000e cfg80211 soundcore snd_page_alloc rfkill sunrpc xts gf128mul dm_crypt sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[213799.962049] Pid: 13919, comm: thunderbird-bin Not tainted 3.2.7-1.fc16.x86_64 #1
:[213799.962051] Call Trace:
:[213799.962052]  <IRQ>  [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
:[213799.962062]  [<ffffffff8106de46>] warn_slowpath_fmt+0x46/0x50
:[213799.962067]  [<ffffffff814c6790>] ? skb_release_data+0x110/0x120
:[213799.962073]  [<ffffffffa02a206d>] iwlagn_tx_skb+0x99d/0xa20 [iwlwifi]
:[213799.962077]  [<ffffffffa029fdaa>] iwlagn_mac_tx+0x1a/0x30 [iwlwifi]
:[213799.962089]  [<ffffffffa0221bd5>] __ieee80211_tx+0x175/0x2a0 [mac80211]
:[213799.962098]  [<ffffffffa02242ba>] ieee80211_tx_pending+0xca/0x270 [mac80211]
:[213799.962102]  [<ffffffff81074d18>] tasklet_action+0x78/0x140
:[213799.962105]  [<ffffffff81075378>] __do_softirq+0xb8/0x230
:[213799.962108]  [<ffffffff81056395>] ? check_preempt_curr+0x75/0xa0
:[213799.962112]  [<ffffffff815ebfec>] call_softirq+0x1c/0x30
:[213799.962115]  [<ffffffff81016275>] do_softirq+0x65/0xa0
:[213799.962117]  [<ffffffff8107578e>] irq_exit+0x9e/0xc0
:[213799.962119]  [<ffffffff815ec8a3>] do_IRQ+0x63/0xe0
:[213799.962123]  [<ffffffff815e21ee>] common_interrupt+0x6e/0x6e
:[213799.962124]  <EOI>  [<ffffffff815e9eb4>] ? sysret_audit+0x16/0x20

smolt_data:
:
:
:General
:=================================
:UUID: 654e6044-9eed-466b-8a4e-c4a61f876224
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_GB.utf8
:Platform: x86_64
:BogoMIPS: 5388.32
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2701
:System Memory: 7867
:System Swap: 9983
:Vendor: Dell Inc.
:System: Latitude E6420 01
:Form factor: Laptop
:Kernel: 3.2.7-1.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4631:33329:4136:1171) pci, None, STORAGE, N/A
:(32902:7247:4136:1171) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4631:33313:4136:1171) pci, sdhci-pci, BASE, N/A
:(32902:294:4136:1171) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:4136:1171) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:4136:1171) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7188:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7202:4136:1171) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:130:32902:4897) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(32902:10282:4136:1171) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:7213:4136:1171) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4136:1171) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4136:1171) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4136:1171) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:7194:4136:1171) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_cluestix-lv_root / ext4 4096 4096 7967173 5493006 5093646 1998848 1720260 1720260
:/dev/sda2 /boot ext4 1024 1024 508745 411104 385504 128016 127785 127785
:/dev/mapper/vg_cluestix-lv_home /home ext4 4096 4096 51767759 17363986 14772447 12959744 12534022 12534022
:
Comment 1 Dave Jones 2012-03-08 11:48:43 EST
possibly same root cause as bug 785913. This is a different state for the same WARN_ON.
Comment 2 Dave Jones 2012-03-14 11:49:48 EDT
*** Bug 803382 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2012-03-19 10:51:48 EDT
*** Bug 803680 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2012-03-22 13:10:22 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-22 13:13:04 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-03-22 13:22:31 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-23 12:35:50 EDT
*** Bug 806380 has been marked as a duplicate of this bug. ***
Comment 8 Hongwen Qiu 2012-03-23 21:59:31 EDT
(In reply to comment #6)
> [mass update]
> kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
> Please retest with this update.

The same bug still exists in the kernel-3.3.0-4
Comment 9 Dave Jones 2012-03-26 10:57:29 EDT
*** Bug 806576 has been marked as a duplicate of this bug. ***
Comment 10 Dave Jones 2012-03-26 10:57:42 EDT
*** Bug 806719 has been marked as a duplicate of this bug. ***
Comment 11 Dave Jones 2012-04-02 12:52:31 EDT
*** Bug 808794 has been marked as a duplicate of this bug. ***
Comment 12 Josh Boyer 2012-04-04 08:36:52 EDT
*** Bug 809664 has been marked as a duplicate of this bug. ***
Comment 13 Josh Boyer 2012-04-05 08:12:59 EDT
*** Bug 810191 has been marked as a duplicate of this bug. ***
Comment 14 Josh Boyer 2012-04-05 08:13:17 EDT
*** Bug 810008 has been marked as a duplicate of this bug. ***
Comment 15 Josh Boyer 2012-04-09 09:52:23 EDT
*** Bug 810751 has been marked as a duplicate of this bug. ***
Comment 16 Josh Boyer 2012-04-10 09:55:27 EDT
*** Bug 811222 has been marked as a duplicate of this bug. ***
Comment 17 Josh Boyer 2012-04-11 06:32:17 EDT
*** Bug 811455 has been marked as a duplicate of this bug. ***
Comment 18 Josh Boyer 2012-04-18 08:44:26 EDT
*** Bug 813645 has been marked as a duplicate of this bug. ***
Comment 19 Josh Boyer 2012-04-18 12:48:49 EDT
*** Bug 813886 has been marked as a duplicate of this bug. ***
Comment 20 John W. Linville 2012-04-26 09:42:15 EDT
*** Bug 785913 has been marked as a duplicate of this bug. ***
Comment 21 John W. Linville 2012-04-26 09:43:15 EDT
*** Bug 816589 has been marked as a duplicate of this bug. ***
Comment 22 Otso Helenius 2012-05-07 12:39:32 EDT
This error suddenly appeared.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 23 Thomas Janssen 2012-05-11 15:31:36 EDT
It simply happened. Nothing really to reproduce, but it wasn't the first time. Just being online and out of the blue (for me) internet is gone. I can see then ABRT coming up with this problem. Sorry that i can't say anymore about it.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 24 Josh Boyer 2012-09-04 13:35:22 EDT
Has anyone hit this on 3.4 or 3.5 kernels?
Comment 25 Stanislaw Gruszka 2012-10-05 08:55:25 EDT
Assume this is fixed.

Note You need to log in before you can comment on or make changes to this bug.