Bug 759909 - gnome-shell-hotplug-sniffer: Crash in __lxstat64() when listing directories
gnome-shell-hotplug-sniffer: Crash in __lxstat64() when listing directories
Status: CLOSED DUPLICATE of bug 699087
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:dd7bfa94ab7a3387f326f8c2f27...
:
: 768747 770918 772049 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-04 14:59 EST by foxsite
Modified: 2012-03-30 10:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 10:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (2.23 KB, text/plain)
2011-12-04 14:59 EST, foxsite
no flags Details
File: smolt_data (3.56 KB, text/plain)
2011-12-04 14:59 EST, foxsite
no flags Details
File: maps (7.67 KB, text/plain)
2011-12-04 14:59 EST, foxsite
no flags Details
File: backtrace (45.67 KB, text/plain)
2011-12-04 15:00 EST, foxsite
no flags Details

  None (edit)
Description foxsite 2011-12-04 14:59:49 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-shell-hotplug-sniffer
comment:        just rebooting the system
executable:     /usr/libexec/gnome-shell-hotplug-sniffer
kernel:         3.1.2-1.fc16.i686.PAE
pid:            2080
pwd:            /
reason:         Process /usr/libexec/gnome-shell-hotplug-sniffer was killed by signal 6 (SIGABRT)
time:           dim. 04 déc. 2011 20:09:26 CET
uid:            1000
username:       gabriel
var_log_messages: Dec  4 20:09:27 serveur2 abrt[2104]: Saved core dump of pid 2080 (/usr/libexec/gnome-shell-hotplug-sniffer) to /var/spool/abrt/ccpp-2011-12-04-20:09:26-2080 (94474240 bytes)

backtrace:      Text file, 46771 bytes
dso_list:       Text file, 2279 bytes
maps:           Text file, 7851 bytes
smolt_data:     Text file, 3648 bytes

build_ids:
:1df53725e371c75ee897f32d82ec0497ecbb8599
:bdbcb7ad0ae16806e9002af3c6d1ec65353108a0
:96b666a7f6d7a80ea6f9aef54f0cdd0f6190c058
:641296f1c3020865058939e8629a44acffcc3339
:92b99890f5d3dd6816e1a8125e9de9ac08931ac7
:11e752a8e19a41ab95fc6d418fcc0a706fefcf27
:5b853064c3d832d471e71bb67b714a7f69ff11d3
:647951954dab9eadcf521b97c5f9d7566b1e79c8
:20ddd2a05db5d53ece42fdb93c9fb5d0eed3cdad
:42859023e4ec83a16446984b1e0c7510a38731c4
:6d01d6f2ddfe61d9889587b56d269c586b084b70
:d1bd2374eb12ee6116690a80ce23d695b3d585e8
:36cc7c0490b1d29bbe496654fe01dea01f6c8615
:fb138a019cd93aa6212be49f31654f7bcb474640
:3b5d160bc67e95593211fd623fc34ee2ca23381a
:12da4d1dc9764d3990ab6a2def5a88c4687d4550
:40e3e5b910a2762887fba4cecdb950ad85cc7359
:85d6747093886eff44cf10e88d3eb9c88b6eb95d
:adca4c604227da51f7a095c00f343e39dda76d54
:4ad17dce13b95c3f6543c3ab56624e321dc1fce8
:6ad77e91d5cc02288d676787c163373f4fefe8fa
:8403f33f0be1a3653acd05b560f87aa1363d02d7
:d7cd016536dcce05ea28a1219c92eb9507121fa3
:0cc5c4bc97b347c85c28a24db9e236d4c727ed91
:d94f52f020f5a21d89ce70745a9bfb78cee38ba4
:5cd0f4c765c0e8ddbacdaf009616909639fbf804
:82674b49345364df4c158e8258b93fd4d8fdbae0
:10cec21724c13b95ec03f00985b0405412817a49

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-VPQpH4k9wV,guid=79d387692a3df20cdf881a1d0000004b
:XDG_SESSION_COOKIE=12686c0ce2817fda5d36ef7900000025-1323022132.793588-704019611
:XDG_RUNTIME_DIR=/run/user/gabriel
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/tmp/keyring-PRSaxg/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1641,unix/unix:/tmp/.ICE-unix/1641
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:XDG_VTNR=1
:USERNAME=gabriel
:GDMSESSION=gnome
:XDG_SESSION_ID=1
:GPG_AGENT_INFO=/tmp/keyring-PRSaxg/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-VPQpH4k9wV,guid=79d387692a3df20cdf881a1d0000004b
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-gabriel-gXJOXj/database
:USER=gabriel
:DBUS_STARTER_BUS_TYPE=session
:SHLVL=1
:PWD=/home/gabriel
:GDM_LANG=fr_FR.utf8
:GNOME_KEYRING_CONTROL=/tmp/keyring-PRSaxg
:LANG=fr_FR.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=gabriel
:HOME=/home/gabriel
Comment 1 foxsite 2011-12-04 14:59:53 EST
Created attachment 540421 [details]
File: dso_list
Comment 2 foxsite 2011-12-04 14:59:55 EST
Created attachment 540422 [details]
File: smolt_data
Comment 3 foxsite 2011-12-04 14:59:59 EST
Created attachment 540423 [details]
File: maps
Comment 4 foxsite 2011-12-04 15:00:02 EST
Created attachment 540424 [details]
File: backtrace
Comment 5 Owen Taylor 2012-01-05 14:10:35 EST
*** Bug 770918 has been marked as a duplicate of this bug. ***
Comment 6 Owen Taylor 2012-01-05 14:11:02 EST
*** Bug 768747 has been marked as a duplicate of this bug. ***
Comment 7 Owen Taylor 2012-01-05 14:13:12 EST
This could conceivably be a dup of bug 743613 - the crash is in an entirely different place, but that bug does lead to memory corruption. On the other hand, its strange that you've hit this crash 3 times in exactly the same place, and nobody else has ever hit it - that would point to a more deterministic crash condition.
Comment 8 Owen Taylor 2012-01-05 14:19:52 EST
*** Bug 772049 has been marked as a duplicate of this bug. ***
Comment 9 Michael Schwendt 2012-03-21 12:30:32 EDT
Hmmm, abrt-bot pointed out that this bug would be similar to bug 771202 (claws-mail), but all I find similar is the assertion that leads to SIGABRT:

| GLib:ERROR:gvarianttypeinfo.c:186:g_variant_type_info_check: assertion failed: (0 <= index && index < 24)
Comment 10 abrt-bot 2012-03-30 10:41:38 EDT
Backtrace analysis found this bug to be similar to bug #699087, closing as duplicate.

Bugs which were found to be similar to this bug: 
  control-center: bug #694157, bug #697179, bug #699087, bug #719370, bug #720113, bug #720734, bug #723507, bug #723799, bug #725163, bug #729605, bug #730850, bug #731349, bug #735532, bug #735985, bug #737053, bug #753871, bug #761554, bug #766223, bug #766224, bug #771220, bug #784260, bug #784262, bug #788257, bug #788743, bug #804994, bug #805502, bug #807663
  gnome-color-manager: bug #695888
  gnome-shell: bug #770918, bug #772049, bug #783132
  imsettings: bug #740175

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 699087 ***

Note You need to log in before you can comment on or make changes to this bug.