Bug 104492 - Can't access launchers in gnome-panel drawer
Can't access launchers in gnome-panel drawer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
: 105346 105662 107131 107242 107616 107648 109323 109575 109864 110836 110841 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-16 08:59 EDT by Marco Aurelio Torino Ribeiro
Modified: 2007-11-30 17:10 EST (History)
17 users (show)

See Also:
Fixed In Version: 2.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 10:50:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
button-widget.c fix for drawer problem (6.24 KB, patch)
2003-10-31 09:59 EST, Gene Czarcinski
no flags Details | Diff

  None (edit)
Description Marco Aurelio Torino Ribeiro 2003-09-16 08:59:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
When I insert any launchers in a drawer from gnome-panel, it works fine. I am
able to click the launchers and the application opens (in my case, I put some
"kinds" of Terminals in the drawer, like "My account terminal", "Root terminal",
etc.)
But after I log out from gnome and then log in again, I can't access the
launchers in the drawer anymore. I click the icons and they simply don't
"respond". It's just like I am clicking on an empty drawer.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1.Insert a drawer in the gnome-panel
2.Insert any launchers in the drawer
3.Log out from gnome
4.Log in again into gnome
5.Try to access the launchers in the drawer
    

Actual Results:  Nothing happened.

Expected Results:  Tha applications in the drawer should have opened.

Additional info:
Comment 1 Bill Nottingham 2003-09-26 15:54:31 EDT
*** Bug 105662 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-09-26 15:54:42 EDT
*** Bug 105346 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Larsson 2003-10-06 11:00:56 EDT
This has been fixed in cvs on the gnome-2-4 branch.
Comment 4 Bill Nottingham 2003-10-16 00:15:25 EDT
*** Bug 107131 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2003-10-16 00:28:22 EDT
*** Bug 107242 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2003-10-21 22:25:23 EDT
*** Bug 107616 has been marked as a duplicate of this bug. ***
Comment 7 Gene Czarcinski 2003-10-31 07:33:41 EST
*** Bug 107648 has been marked as a duplicate of this bug. ***
Comment 8 Gene Czarcinski 2003-10-31 08:01:31 EST
http://bugzilla.gnome.org/show_bug.cgi?id=121072

This a real pain and a shame that it is not fixed in time for FC 1
Comment 9 Gene Czarcinski 2003-10-31 09:57:32 EST
OK, I am attaching a patch which works for me.

The fix was entered into the gnome-panel cvs soon after 2.4.0 on 16 Sep and
appears to only involve button-widget.c

I created the patch by getting the current cvs of gnome-panel and doing a diff
-u between the tarball from gnome-panel-2.4.0-3.src.rpm and the cvs version.

This applies and compiles clean BUT I did a quick and dirty of just taking
whatever was in button-widget.c rather than figuring out the precise up2date for
the fix.  Therefore, CAUTION: this may break something else.

Perhaps someone more familiar with this code could take a look.
Comment 10 Gene Czarcinski 2003-10-31 09:59:03 EST
Created attachment 95627 [details]
button-widget.c fix for drawer problem
Comment 11 Gene Czarcinski 2003-10-31 14:58:37 EST
I have looked over the three additional fixes incorporated into this patch and
they are both minor and relatively contained in button-widget.c.

I have built a modified rpm and tested the update and it works.
Comment 12 Gene Czarcinski 2003-11-19 16:12:18 EST
Alternatively, gnome-panel-2.4.1 is now available.  This includes the
updates to button-widget.c
Comment 13 Gene Czarcinski 2003-11-20 12:51:40 EST
OK, in irc fedora-bugs, Bill Nottingham indicated that the "fix" needs
more testing.  Hopefully, some of you on the CC list can do some
testing and report results here.  I have built some rpms for the fix
and made them available on ftp://czar.net/pub/

Patch applied to 2.4.0:
ftp://czarc.net/pub/gnome-panel-2.4.0-3.gc2.i386.rpm
ftp://czarc.net/pub/gnome-panel-2.4.0-3.gc2.src.rpm

gnome-panel-2.4.1 with redhat patches fixed for 2.4.1:
ftp://czarc.net/pub/gnome-panel-2.4.1-0.gc1.i386.rpm
ftp://czarc.net/pub/gnome-panel-2.4.1-0.gc1.src.rpm

I am currently running with gnome-paenl-2.4.1 but also ran for a few
days with only the draw-fix-patch.  In both cases, the draw now works
and I have had no other problems.
Comment 14 Edmond Hui 2003-11-22 21:34:07 EST
Just tried out the 2.4.1-0 rpm and it seem to work fine for me
Comment 15 Michal Jaegermann 2003-11-23 16:37:13 EST
> Just tried out the 2.4.1-0 rpm and it seem to work fine for me

Not really. 2.4.1 seems to have a new annoying problem.  With
an "auto-hide" panel any action which shows a panel also "opens"
drawers and a panel will not hide until drawers are closed
manually.

OTOH with 2.4.0-3.gc2 and an "auto-hide" panel does not seem to
be even possible to pick up panel actions. Drawers deactivate
immediately when a mouse pointer moves out of a panel area even
if it stays within a drawer.
Comment 16 Jeff MacDonald 2003-12-03 16:37:39 EST
I just did an rpm -Uvh and tried gnome-panel-2.4.0-3.gc2.i386.rpm, and
the problem with auto-hide persists.. I am about to try
gnome-panel-2.4.1-0.gc1.i386.rpm
Comment 17 Jeff MacDonald 2003-12-03 16:48:26 EST
2.4.1-0.gc1 is working a little better than the 2.4.0 version.
however, when I move the mouse into the panel, the drawer
automatically opens, which keeps the panel from hiding. once I close
the drawer the panel hides.


Comment 18 Gene Czarcinski 2003-12-04 08:20:47 EST
OK, I do not use autohide so that problem does not "bother" me and I
have not looked to see if it have been fixed upstream.

At this point, the choice (IMHO) is having the buttons in a drawer
work (2.4.1) but if panel hiding is used, the drawer(s) auto open OR
have the buttons in drawers not work at all.
Comment 19 Jef Spaleta 2004-01-28 17:29:58 EST
*** Bug 109323 has been marked as a duplicate of this bug. ***
Comment 20 Jef Spaleta 2004-01-28 17:30:58 EST
*** Bug 109575 has been marked as a duplicate of this bug. ***
Comment 21 Jef Spaleta 2004-01-28 17:31:43 EST
*** Bug 109864 has been marked as a duplicate of this bug. ***
Comment 22 Jef Spaleta 2004-01-28 17:32:25 EST
*** Bug 110836 has been marked as a duplicate of this bug. ***
Comment 23 Jef Spaleta 2004-01-28 17:33:35 EST
*** Bug 110841 has been marked as a duplicate of this bug. ***
Comment 24 Don Himelrick 2004-02-19 11:48:18 EST
Whats going on with me is that the drawer has the focus instead of the
lauchers inside the drawer.  Clicking anywhere inside the drawer, like
on one of the launchers, should activate the launcher, not the drawer.
 Someone needs to move the lauchers back on top?
Comment 25 Don Himelrick 2004-02-19 11:51:56 EST
Whats going on with me is that the drawer has the focus instead of the
lauchers inside the drawer.  Clicking anywhere inside the drawer, like
on one of the launchers, should activate the launcher, not the drawer.
 Someone needs to move the lauchers back on top?

Comment 26 Mark McLoughlin 2004-02-20 09:19:50 EST
This bug was fixed with gnome-panel 2.4.1. Apologies in the delay in
getting an update out.

I'm going to release an update with gnome-panel 2.4.2, hopefully next
week. I'll close this bug then.
Comment 27 Mark McLoughlin 2004-02-23 17:42:52 EST
I've just released a testing update which should fix this issue.
Please test it out and let us know if it fixes your problem.

Details on the update:
http://www.redhat.com/archives/fedora-test-list/2004-February/msg01512.html
Comment 28 Matthew Wilkens 2004-02-23 18:48:59 EST
Just updated to the testing release.  Drawers work as expected.  Thanks.
Comment 29 Need Real Name 2004-02-23 20:09:28 EST
Hallelujah!  Fixed indeed.  Many thanks.
Comment 30 Don Himelrick 2004-02-24 14:31:34 EST
Drawers and autohiding work much better now, thanks.

However, I noticed that with an empty (no launchers) unexpanded right
panel (orientation right, uncheck expand, uncheck autohide, check show
hide buttons, check arrows on hide buttons) it sometimes gets into a
funk in either the top right or lower right corner and it just
hides/unhides as fast as it can.  (That's pretty damn fast!) I have a
hell of a time trying to click on it to get it stop.

I don't know if I like an unexpanded panel going all the way to the
top or bottom of the screen when you click on the top or bottom
(respectively) hide button.  Sometimes when I click the bottom hide
button it just moves the expanded panel so that it is right above the
main panel.  It stays expanded but does NOT cover up the clock or any
other part of the main bottom panel.  Other times is goes to an
unexpanded panel with just the top expand button showing below the
time displayed on the main panel.  In this case it does cover up part
of the main bottom panel.
Comment 31 Mark McLoughlin 2004-02-24 15:10:19 EST
Thanks for testing the update. But please don't do the "However, I
noticed this other bug..." thing - please open a new bug instead :-)
Comment 32 Don Himelrick 2004-02-24 16:00:00 EST
O.K. I'm just learning bugzetiquette :)

Bug 116741 is the new bug.
Comment 33 Mark McLoughlin 2004-03-02 10:50:11 EST
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) with a fix
for this bug is now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/

Note You need to log in before you can comment on or make changes to this bug.