Bug 426766 - (TB8a97ef57) TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for int() with base 10: 'None'
TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for int() w...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 405071 411831 412271 424941 426980 427145 427769 431417 roke 438373 438686 440462 441682 447175 465197 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-25 21:49 EST by Woosung Choi
Modified: 2008-10-14 12:04 EDT (History)
14 users (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Woosung Choi 2007-12-25 21:49:35 EST
Description of problem:
When I manage my network by using system-config-netwrok and reboot my machine, I
never see system-config-network again.

Version-Release number of selected component (if applicable):
FEDORA 8

How reproducible:
Can not reproduced, my machine is gone.

Steps to Reproduce:
It can not be reproduced but I attach my procedure when I meet this.
1. Add eth2
2. delete eth2
3. add eth3
4. add usb0
5. delete eth3
6. delete eth2 again.
  
Actual results:
Can not execute system-config-network.

Expected results:
system-config-network must be worked.

Additional info:
Exception screen.

Component: system-config-network
Version: 1.4.3
Summary: TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for
int() with base 10: 'None'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
277, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
289, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
780, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
692, in load
    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])
ValueError: invalid literal for int() with base 10: 'None'

Local variables in innermost frame:
hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0x8616b6c>
i: 2
self: HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=8139too
HardwareList.Ethernet.eth0.Description=Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+
HardwareList.Wireless.eth1.Status=ok
HardwareList.Wireless.eth1.Name=eth1
HardwareList.Wireless.eth1.Type=Wireless
HardwareList.Wireless.eth1.Card.ModuleName=ipw2100
HardwareList.Wireless.eth1.Description=Intel Corporation PRO/Wireless LAN 2100
3B Mini PCI Adapter
HardwareList.Modem.Modem0.Status=설정 마침
HardwareList.Modem.Modem0.Name=Modem0
HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem
HardwareList.Modem.Modem0.Type=Modem
HardwareList.Modem.Modem0.Description=Generic Modem

isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x887810c>
hw: Hardware.Status=설정 마침
Hardware.Name=Modem0
Hardware.Modem.DeviceName=/dev/modem
Hardware.Type=Modem
Hardware.Description=Generic Modem

dev: Modem0
wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0x887822c>

----
some of this log contain Korean character. It means configuration done.
Comment 1 Jiri Moskovcak 2008-01-03 03:49:12 EST
According to log the problem in /etc/wvdial.conf - you have None as Baud value 
and s-c-n doesn't handle this value. I'm working on better handling dial-up 
configuration, so I'll try to fix this asap. For now, you have to edit the conf 
file manually and set the preffered bit rate manually.

Jirka
Comment 2 Jiri Moskovcak 2008-01-04 06:18:51 EST
*** Bug 426980 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Moskovcak 2008-01-04 06:19:35 EST
*** Bug 427145 has been marked as a duplicate of this bug. ***
Comment 4 Jiri Moskovcak 2008-01-10 07:42:16 EST
*** Bug 424941 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Moskovcak 2008-02-01 07:38:13 EST
*** Bug 411831 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Moskovcak 2008-02-01 08:14:21 EST
*** Bug 405071 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Moskovcak 2008-02-01 08:15:29 EST
*** Bug 412271 has been marked as a duplicate of this bug. ***
Comment 8 Jiri Moskovcak 2008-02-01 08:39:56 EST
*** Bug 427769 has been marked as a duplicate of this bug. ***
Comment 9 Jiri Moskovcak 2008-02-04 08:33:42 EST
*** Bug 431417 has been marked as a duplicate of this bug. ***
Comment 10 Jiri Moskovcak 2008-02-13 04:26:33 EST
*** Bug 432581 has been marked as a duplicate of this bug. ***
Comment 11 Jiri Moskovcak 2008-03-25 09:25:09 EDT
*** Bug 438686 has been marked as a duplicate of this bug. ***
Comment 12 Harald Hoyer 2008-03-31 05:42:39 EDT
*** Bug 438373 has been marked as a duplicate of this bug. ***
Comment 13 Harald Hoyer 2008-04-07 10:00:32 EDT
*** Bug 440462 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2008-04-07 10:34:46 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 15 Fedora Update System 2008-04-09 01:20:05 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 16 Jiri Moskovcak 2008-04-09 10:39:27 EDT
*** Bug 441682 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2008-04-22 18:38:52 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Harald Hoyer 2008-05-19 04:34:43 EDT
*** Bug 447175 has been marked as a duplicate of this bug. ***
Comment 19 Harald Hoyer 2008-10-14 12:04:02 EDT
*** Bug 465197 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.