Bug 657657 - [abrt] gnome-media-2.32.0-1.fc14: get_channel_map_for_card: Process /usr/bin/gnome-volume-control was killed by signal 6 (SIGABRT)
[abrt] gnome-media-2.32.0-1.fc14: get_channel_map_for_card: Process /usr/bin/...
Status: CLOSED DUPLICATE of bug 669866
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:b7f7e820a561a9f2a4d410474c0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 20:41 EST by Xi Yang
Modified: 2012-03-21 13:14 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 13:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (25.79 KB, text/plain)
2010-11-26 20:41 EST, Xi Yang
no flags Details

  None (edit)
Description Xi Yang 2010-11-26 20:41:03 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: gnome-volume-control
comment: It seems the ALSA on my computer does not working properly.
component: gnome-media
crash_function: get_channel_map_for_card
executable: /usr/bin/gnome-volume-control
kernel: 2.6.35.6-48.fc14.x86_64
package: gnome-media-2.32.0-1.fc14
rating: 4
reason: Process /usr/bin/gnome-volume-control was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1290821823
uid: 500

How to reproduce
-----
1. change to "Hardware" page
2. click on "test speakers"
3. it crashed
Comment 1 Xi Yang 2010-11-26 20:41:06 EST
Created attachment 463183 [details]
File: backtrace
Comment 2 ryans 2010-12-02 01:21:16 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. open GNOME Sound Preferences
2. changed profile setting under Hardware tab to Digital Stereo Duplex
3. clicked Test Speakers


Comment
-----
The speaker test doesn't initiate; Sound Preferences crashes without begining the test
Comment 3 it_rom 2010-12-08 10:45:39 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. i don't know
2.
3.
Comment 4 Jacob Peyron 2010-12-09 08:46:53 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. In gnome sound preferences go to the hardware tab.
2. In the profile section I selected: 
3. Digital stereo dublex (IEC958) and pressed configure which created the crash.


Comment
-----
I am having trouble with my sound-settings. I was messing around with the settings because I get sound, but I get it to two sources at the same time, where one source is from the computer itself (!?). It has to come from the same soundcard, or at least I think it is, I only have one intergrated chip. But the computers intergrated "speakers" outputs the sound as well. The computer is a HP Compaq dc7800p and the sound card is what the computer was shipped with.
Comment 5 Bruce Barbour 2010-12-09 15:13:36 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.go to sound in gnome
2.try to adjust sound reception in Skype
3.change from headset to onboard sound


Comment
-----
changing sound control
Comment 6 Brian Livermore 2010-12-11 17:31:10 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Changed profile to "Digital Stereo Duplex"
2. Clicked "Test Speakers"
3. CRASH!!!!!
Comment 7 tobyknudsen@gmail.com 2010-12-13 12:14:23 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I was fiddling with the gnome sound app, no further context to offer
2.
3.
Comment 8 Mikko Eley 2010-12-14 11:33:22 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. change sound device
2. change from duplex to one channel on audio4DJ card
3. press test speakers


Comment
-----
the output of my external soundcard disapeared so I was trying to get it back as an output option in sound prefs by unpluging the card, changing channels etc
Comment 9 tobyknudsen@gmail.com 2010-12-15 06:21:11 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I was fiddling with the gnome sound app, 
2. selected Test Speakers
3.
Comment 10 meme23 2010-12-16 19:27:08 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Was having problems out of my sound(getting static, likely due to this bug) and was selecting one of the other outputs(stereo -> surround)
2. Crashed. 
3.
Comment 11 Bruce Barbour 2010-12-16 22:33:43 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Trying to get sound in Volume control settings

2.Tested speakers, crash
3.
Comment 12 Jan Vlug 2010-12-28 07:29:59 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. happened while changing and testing sound configuration.
Comment 13 meme23 2010-12-29 12:48:20 EST
(In reply to comment #10)
> Package: gnome-media-2.32.0-1.fc14
> Architecture: i686
> OS Release: Fedora release 14 (Laughlin)
> 
> 
> How to reproduce
> -----
> 1. Was having problems out of my sound(getting static, likely due to this bug)
> and was selecting one of the other outputs(stereo -> surround)
> 2. Crashed. 
> 3.

Additional information. 

This appears to be kernel related. If I use kernel 2.6.35.6-48, the sound works just fine. Every kernel since then, including 2.6.35.10-74 which was released yesterday apparently, will allow sound once(the drum login window sound), and maybe a second time but after that it is only static. 

Anyone else able to verify this?
Comment 14 Nick Pierpoint 2011-01-07 04:43:16 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
I didn't know it had crashed
Comment 15 Nick Pierpoint 2011-01-07 04:43:55 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
I didn't know it had crashed
Comment 16 Nick Pierpoint 2011-01-20 19:23:44 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I don't remember it crashing
2.
3.
Comment 17 Nick Pierpoint 2011-01-20 19:24:19 EST
Package: gnome-media-2.32.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I don't remember it crashing
2.
3.
Comment 18 abrt-bot 2012-03-21 13:14:47 EDT
Backtrace analysis found this bug to be similar to bug #669866, closing as duplicate.

Bugs which were found to be similar to this bug: 
  control-center: bug #694777, bug #695039, bug #698901, bug #720666, bug #735987, bug #754731, bug #758657, bug #759400, bug #772680
  gnome-media: bug #579620, bug #583222, bug #624578, bug #646872, bug #647890, bug #665859, bug #669866, bug #677818, bug #700955

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 669866 ***

Note You need to log in before you can comment on or make changes to this bug.