Bug 861955 - [abrt] nautilus-3.6.0-1.fc18: g_list_prepend: Process /usr/libexec/nautilus-shell-search-provider was killed by signal 11 (SIGSEGV)
[abrt] nautilus-3.6.0-1.fc18: g_list_prepend: Process /usr/libexec/nautilus-s...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cosimo Cecchi
Fedora Extras Quality Assurance
abrt_hash:b7364667df0c07149cce3443b60...
:
: 859945 861087 862139 862985 862990 863000 863026 863531 864860 864919 865036 868196 868933 869284 869285 870198 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 08:39 EDT by Ricardo Silva
Modified: 2012-12-10 02:12 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 15:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.36 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: environ (1.08 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: backtrace (21.59 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: cgroup (130 bytes, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: maps (46.87 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: dso_list (9.60 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: var_log_messages (1.08 KB, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details
File: open_fds (750 bytes, text/plain)
2012-10-01 08:39 EDT, Ricardo Silva
no flags Details

  None (edit)
Description Ricardo Silva 2012-10-01 08:39:19 EDT
Version-Release number of selected component:
nautilus-3.6.0-1.fc18

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/libexec/nautilus-shell-search-provider
crash_function: g_list_prepend
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

truncated backtrace:
:Thread no. 1 (7 frames)
: #0 g_list_prepend at glist.c:283
: #1 g_queue_push_head at gqueue.c:346
: #2 cursor_callback at nautilus-search-engine-tracker.c:176
: #3 g_simple_async_result_complete at gsimpleasyncresult.c:775
: #4 complete_in_idle_cb_for_thread at gsimpleasyncresult.c:843
: #8 g_main_context_iteration at gmain.c:3351
: #9 g_application_run at gapplication.c:1620
Comment 1 Ricardo Silva 2012-10-01 08:39:22 EDT
Created attachment 619771 [details]
File: core_backtrace
Comment 2 Ricardo Silva 2012-10-01 08:39:24 EDT
Created attachment 619772 [details]
File: environ
Comment 3 Ricardo Silva 2012-10-01 08:39:27 EDT
Created attachment 619773 [details]
File: backtrace
Comment 4 Ricardo Silva 2012-10-01 08:39:29 EDT
Created attachment 619774 [details]
File: limits
Comment 5 Ricardo Silva 2012-10-01 08:39:31 EDT
Created attachment 619775 [details]
File: cgroup
Comment 6 Ricardo Silva 2012-10-01 08:39:35 EDT
Created attachment 619776 [details]
File: maps
Comment 7 Ricardo Silva 2012-10-01 08:39:37 EDT
Created attachment 619777 [details]
File: dso_list
Comment 8 Ricardo Silva 2012-10-01 08:39:39 EDT
Created attachment 619778 [details]
File: var_log_messages
Comment 9 Ricardo Silva 2012-10-01 08:39:41 EDT
Created attachment 619779 [details]
File: open_fds
Comment 10 Cosimo Cecchi 2012-10-18 14:52:08 EDT
*** Bug 864919 has been marked as a duplicate of this bug. ***
Comment 11 Cosimo Cecchi 2012-10-18 14:53:17 EDT
*** Bug 864860 has been marked as a duplicate of this bug. ***
Comment 12 Cosimo Cecchi 2012-10-18 14:53:37 EDT
*** Bug 859945 has been marked as a duplicate of this bug. ***
Comment 13 Cosimo Cecchi 2012-10-18 14:55:08 EDT
*** Bug 862985 has been marked as a duplicate of this bug. ***
Comment 14 Cosimo Cecchi 2012-10-18 14:55:25 EDT
*** Bug 862990 has been marked as a duplicate of this bug. ***
Comment 15 Cosimo Cecchi 2012-10-18 14:55:49 EDT
*** Bug 863026 has been marked as a duplicate of this bug. ***
Comment 16 Cosimo Cecchi 2012-10-18 14:56:10 EDT
*** Bug 863000 has been marked as a duplicate of this bug. ***
Comment 17 Cosimo Cecchi 2012-10-18 15:10:05 EDT
*** Bug 862139 has been marked as a duplicate of this bug. ***
Comment 18 Cosimo Cecchi 2012-10-18 15:10:16 EDT
*** Bug 863531 has been marked as a duplicate of this bug. ***
Comment 19 Cosimo Cecchi 2012-10-18 15:10:50 EDT
*** Bug 865036 has been marked as a duplicate of this bug. ***
Comment 20 Cosimo Cecchi 2012-10-18 15:14:50 EDT
This was also reported upstream here [1] and I now pushed a number of fixes to both git master and gnome-3-6 branches. The fix will be available in the next round of GNOME updates in Fedora.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=686168
Comment 21 Cosimo Cecchi 2012-10-18 15:25:52 EDT
*** Bug 861087 has been marked as a duplicate of this bug. ***
Comment 22 Cosimo Cecchi 2012-10-19 11:48:33 EDT
*** Bug 868196 has been marked as a duplicate of this bug. ***
Comment 23 Cosimo Cecchi 2012-11-05 12:10:10 EST
*** Bug 868933 has been marked as a duplicate of this bug. ***
Comment 24 Cosimo Cecchi 2012-11-05 12:10:49 EST
*** Bug 869284 has been marked as a duplicate of this bug. ***
Comment 25 Cosimo Cecchi 2012-11-05 12:11:01 EST
*** Bug 869285 has been marked as a duplicate of this bug. ***
Comment 26 Cosimo Cecchi 2012-11-05 12:12:10 EST
*** Bug 870198 has been marked as a duplicate of this bug. ***
Comment 27 Fedora Update System 2012-11-05 12:15:11 EST
nautilus-3.6.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nautilus-3.6.2-1.fc18
Comment 28 Fedora Update System 2012-12-06 12:03:44 EST
nautilus-3.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nautilus-3.6.3-2.fc18
Comment 29 Fedora Update System 2012-12-10 02:12:43 EST
nautilus-3.6.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.