Bug 1359680 - bug00201 test failure
Summary: bug00201 test failure
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gd
Version: 25
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Skalický
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1359561 (view as bug list)
Depends On:
Blocks: ZedoraTracker PPCTracker ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2016-07-25 09:53 UTC by Dan Horák
Modified: 2016-07-30 18:23 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-30 18:23:47 UTC


Attachments (Terms of Use)

Description Dan Horák 2016-07-25 09:53:55 UTC
The bug00201 test fails on s390x, both in F-24 and Rawhide.

...
make  check-TESTS
make[2]: Entering directory '/builddir/build/BUILD/libgd-2.2.3/tests'
make[3]: Entering directory '/builddir/build/BUILD/libgd-2.2.3/tests'
PASS: bmp/bmp_null
PASS: bmp/bmp_im2im
PASS: freetype/bug00132
PASS: gd/gd_null
PASS: gd/gd_num_colors
PASS: gd/gd_versiontest
PASS: gd/gd_im2im
PASS: gd2/gd2_empty_file
PASS: gd2/php_bug_72339
PASS: gd2/gd2_read_corrupt
PASS: gd2/gd2_null
PASS: gd2/gd2_im2im
PASS: gd2/gd2_read
PASS: gdimagearc/bug00079
PASS: gdimagecolorclosest/gdimagecolorclosest
PASS: gdimagecolordeallocate/gdimagecolordeallocate
PASS: gdimagecolorexact/gdimagecolorexact
PASS: gdimagecolorreplace/gdimagecolorreplace
PASS: gdimagecolorresolve/gdimagecolorresolve
PASS: gdimagecolortransparent/gdimagecolortransparent
PASS: gdimagecopy/bug00007
PASS: gdimagecopy/bug00081
PASS: gdimagecopyresampled/basic
PASS: gdimagecopyresampled/basic_alpha
PASS: gdimagecopyresampled/exact_alpha
FAIL: gdimagecopyresampled/bug00201
PASS: gdimagecopyrotated/bug00020
PASS: gdimagecrop/php_bug_72494
PASS: gdimagefile/gdnametest
PASS: gdimagefill/bug00002_1
PASS: gdimagefill/bug00002_2
PASS: gdimagefill/bug00002_3
PASS: gdimagefill/bug00002_4
PASS: gdimagefill/bug00104_1
PASS: gdimagefilledarc/php_bug43828
PASS: gdimagefilledellipse/bug00010
PASS: gdimagefilledellipse/bug00191
PASS: gdimagefilledellipse/github_bug_00238
PASS: gdimagefilledpolygon/bug00100
PASS: gdimagefilledpolygon/gdimagefilledpolygon0
PASS: gdimagefilledpolygon/gdimagefilledpolygon1
PASS: gdimagefilledpolygon/gdimagefilledpolygon2
PASS: gdimagefilledpolygon/gdimagefilledpolygon3
PASS: gdimagefilledpolygon/php_bug_64641
PASS: gdimagefilledrectangle/bug00004
PASS: gdimagefilledrectangle/bug00078
PASS: gdimagefilledrectangle/bug00106_gdimagefilledrectangle
PASS: gdimagefilltoborder/bug00037
PASS: gdimagefilltoborder/github_bug_215
PASS: gdimagefilter/gdCopyBlurred
PASS: gdimageline/gdimageline_aa_outofrange
PASS: gdimageline/bug00072
PASS: gdimageline/bug00077
PASS: gdimageline/bug00111
PASS: gdimageline/gdimageline_aa
PASS: gdimageline/gdimageline_bug5
PASS: gdimageline/gdImageAALine_thickness
PASS: gdimageline/github_bug_167
PASS: gdimageopenpolygon/gdimageopenpolygon0
PASS: gdimageopenpolygon/gdimageopenpolygon1
PASS: gdimageopenpolygon/gdimageopenpolygon2
PASS: gdimageopenpolygon/gdimageopenpolygon3
PASS: gdimagepixelate/gdimagepixelate
PASS: gdimagepolygon/gdimagepolygon0
PASS: gdimagepolygon/gdimagepolygon1
PASS: gdimagepolygon/gdimagepolygon2
PASS: gdimagepolygon/gdimagepolygon3
PASS: gdimagerectangle/bug00003
PASS: gdimagerectangle/bug00106_gdimagerectangle
PASS: gdimagerectangle/github_bug_00172
PASS: gdimagerotate/bug00067
PASS: gdimagerotate/php_bug_64898
PASS: gdimagescale/github_bug_00218
PASS: gdimagescale/bug_overflow_large_new_size
PASS: gdimagescatterex/bug00208_1
PASS: gdimagescatterex/bug00208_2
PASS: gdimagesetpixel/bug00186
PASS: gdimagesetpixel/gdeffectmultiply
PASS: gdimagesetpixel/gdeffectoverlay
PASS: gdimagestringft/gdimagestringft_bbox
PASS: gdimagestringftex/gdimagestringftex_returnfontpathname
PASS: gdimagetruecolortopalette/php_bug_72512
PASS: gdinterpolatedscale/gdModesAndPalettes
PASS: gdinterpolatedscale/gdTrivialResize
PASS: gdnewfilectx/gdnewfilectx_null
PASS: gdtiled/bug00032
PASS: gdtransformaffineboundingbox/github_bug_00221
PASS: gif/bug00005_2
PASS: gif/bug00181
PASS: gif/bug00227
PASS: gif/gif_null
PASS: gif/bug00005
PASS: gif/bug00006
PASS: gif/bug00060
PASS: gif/bug00066
PASS: gif/gif_im2im
PASS: jpeg/bug_github_18
PASS: jpeg/jpeg_empty_file
PASS: jpeg/jpeg_im2im
PASS: jpeg/jpeg_null
PASS: jpeg/jpeg_read
PASS: jpeg/jpeg_resolution
PASS: png/bug00011
PASS: png/bug00033
PASS: png/bug00086
PASS: png/bug00088
PASS: png/bug00193
PASS: png/png_im2im
PASS: png/png_null
PASS: png/png_resolution
PASS: tga/bug00084
PASS: tga/bug00247
PASS: tga/bug00247a
PASS: tga/bug00248
PASS: tga/bug00248a
PASS: tga/tga_null
PASS: tiff/tiff_dpi
PASS: tiff/tiff_im2im
PASS: tiff/tiff_null
PASS: wbmp/wbmp_null
PASS: wbmp/wbmp_im2im
PASS: webp/bug00111
PASS: xbm/github_bug_170
PASS: xpm/bug00166
PASS: xpm/bug00185
PASS: xpm/color_name
============================================================================
Testsuite summary for GD 2.2.3
============================================================================
# TOTAL: 126
# PASS:  125
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See tests/test-suite.log
Please report to https://github.com/libgd/libgd/issues
============================================================================
Makefile:3274: recipe for target 'test-suite.log' failed
make[3]: Leaving directory '/builddir/build/BUILD/libgd-2.2.3/tests'
make[3]: *** [test-suite.log] Error 1
Makefile:3380: recipe for target 'check-TESTS' failed
make[2]: Leaving directory '/builddir/build/BUILD/libgd-2.2.3/tests'
Makefile:4328: recipe for target 'check-am' failed
make[1]: Leaving directory '/builddir/build/BUILD/libgd-2.2.3/tests'
make[2]: *** [check-TESTS] Error 2
make[1]: *** [check-am] Error 2
...


see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2297337 for full logs


Version-Release number of selected component (if applicable):
gd-2.2.3-1.fc25


Additional info:
gd-2.2.2-1.fc25 builds OK.

Comment 1 Dan Horák 2016-07-25 09:55:38 UTC
And because it fails also on ppc64, I suspect a data endian error.

Comment 2 Dan Horák 2016-07-25 09:57:33 UTC
tests/gdimagecopyresampled/bug00201.log contains:

gdimagecopyresampled/bug00201.c:68: Total pixels changed: 190 with a maximum channel difference of 255.
FAIL gdimagecopyresampled/bug00201 (exit status: 1)

Comment 3 Remi Collet 2016-07-25 10:04:40 UTC
Is version 2.2.3 the 1st version to fail ?

Comment 4 Peter Robinson 2016-07-25 10:06:46 UTC
*** Bug 1359561 has been marked as a duplicate of this bug. ***

Comment 5 Remi Collet 2016-07-25 10:09:06 UTC
Upstream bug tracker: 
https://github.com/libgd/libgd/issues/278

Comment 6 Dan Horák 2016-07-25 10:17:43 UTC
(In reply to Remi Collet from comment #3)
> Is version 2.2.3 the 1st version to fail ?

yes, 2.2.2 builds fine, seems this is a new test in 2.2.3

Comment 7 Remi Collet 2016-07-25 10:31:52 UTC
As I don't have access to a builder for now, can you please provide the _out.png and _diff.png ? (should be in the build tree, as the .log)

Comment 8 Jan Kurik 2016-07-26 04:48:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 9 Dan Horák 2016-07-26 06:49:53 UTC
adding -ffp-contract=off to CFLAGS resolves (workarounds?) the problem we see, we have already used this workaround in other pkgs

Comment 10 Fedora Update System 2016-07-26 08:54:49 UTC
gd-2.2.3-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fb3b00a12c

Comment 11 Fedora Update System 2016-07-28 05:59:51 UTC
gd-2.2.3-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fb3b00a12c

Comment 12 Fedora Update System 2016-07-30 18:23:44 UTC
gd-2.2.3-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.