Bug 185946 - (FC5Turkish) Anaconda crashes while selecting languages at install time
Anaconda crashes while selecting languages at install time
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 186048 186099 186243 186528 186615 186640 186688 186902 187336 187931 190203 191071 195855 196850 205035 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-20 06:36 EST by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 14:39:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report (73.97 KB, text/plain)
2006-03-20 06:36 EST, Mayank Jain
no flags Details
Turkish Language bug (1001 bytes, text/plain)
2006-03-22 11:37 EST, Sameh Attia
no flags Details

  None (edit)
Description Mayank Jain 2006-03-20 06:36:29 EST
Created attachment 126343 [details]
Crash report
Comment 1 Mayank Jain 2006-03-20 06:36:29 EST
Description of problem:
- Anaconda crashes with a dump while installing language packages.


Version-Release number of selected component (if applicable):
anaconda-11.0.5-1.i386.rpm
anaconda-runtime-11.0.5-1.i386.rpm


How reproducible:
1) I used network boot (did not tried with other boot methods)
2) Accepted all default options till reaching the Install packages screen
3) Checked all packages from all groups (checked nothing from network servers).
4) When reaching the Language selection, scrolled down to the last language &
started checking languages using keyboard (space + up).
5) Crash occured at (or near) Turkish language


Actual results:
- Crash happens at (or near) Turkish language

Expected results:
- All languages should get checked


Additional info:
- Crash does not happens if we start selecting packages from language packs &
then move up to other package groups.

* Crash log is attached
Comment 2 Mayank Jain 2006-03-20 07:22:34 EST
[majain@makuchaku fc5]$ cat comps.xml  | grep fonts-ISO8859-9-75dpi --color -n
-A 3 -B 4
7602-    <langonly>tr</langonly>
7603-    <packagelist>
7604-      <packagereq type="conditional"
requires="kdelibs">kde-i18n-Turkish</packagereq>
7605-      <packagereq type="conditional"
requires="openoffice.org-core">openoffice.org-langpack-tr_TR</packagereq>
7606:      <packagereq type="conditional"
requires="xorg-x11-server-Xorg">fonts-ISO8859-9-75dpi</packagereq>
7607-      <packagereq type="conditional"
requires="xorg-x11-server-Xorg">xorg-x11-fonts-ISO8859-9-100dpi</packagereq>
7608:      <packagereq type="conditional"
requires="xorg-x11-server-Xorg">xorg-x11-fonts-ISO8859-9-75dpi</packagereq>
7609-    </packagelist>
7610-  </group>

This shows that fonts-ISO8859-9-75dpi package is required, however it does not
exists in the tree.

Please do the needfull.

:)
Thanks
Comment 3 Chris Lumens 2006-03-21 10:00:48 EST
*** Bug 186048 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2006-03-21 11:38:54 EST
While it shouldn't be listed, we also shouldn't be crashing on packages that
don't exist
Comment 5 Jeremy Katz 2006-03-21 12:33:19 EST
*** Bug 186099 has been marked as a duplicate of this bug. ***
Comment 6 Henri Ala-Peijari 2006-03-21 18:50:34 EST
Mouse clikcing all the way to the last set of packages to make an "everything"
install and then...nooo..crash! :-)

Comment 7 Chris Lumens 2006-03-22 09:55:51 EST
*** Bug 186243 has been marked as a duplicate of this bug. ***
Comment 8 Sameh Attia 2006-03-22 11:37:54 EST
Created attachment 126486 [details]
Turkish Language bug
Comment 9 Sameh Attia 2006-03-22 11:40:11 EST
Me too haviong this bug.
It even happens after installtion is finished and rebboting the system if you
attempt to install it from "Add/Remove Software" menu.
Comment 10 Jeremy Katz 2006-03-22 14:39:07 EST
Bug in the yum conditional code.  I've committed a fix to yum both on the 2.6
branch and HEAD
Comment 11 Chris Lumens 2006-03-23 23:26:00 EST
*** Bug 186528 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2006-03-24 13:34:14 EST
*** Bug 186615 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2006-03-24 17:04:11 EST
*** Bug 186640 has been marked as a duplicate of this bug. ***
Comment 14 Rahul Sundaram 2006-03-25 08:03:28 EST
*** Bug 186688 has been marked as a duplicate of this bug. ***
Comment 15 Paul Nasrat 2006-03-27 07:26:53 EST
*** Bug 186902 has been marked as a duplicate of this bug. ***
Comment 16 Mayank Jain 2006-03-27 07:51:43 EST
Pirut also crashes when selecting Turkish language support.
Comment 17 Chris Lumens 2006-03-30 09:25:23 EST
*** Bug 187336 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2006-04-04 15:28:02 EDT
*** Bug 187931 has been marked as a duplicate of this bug. ***
Comment 19 Chris Lumens 2006-04-28 14:59:18 EDT
*** Bug 190203 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2006-06-18 21:16:47 EDT
*** Bug 195855 has been marked as a duplicate of this bug. ***
Comment 21 Chris Lumens 2006-06-27 09:56:06 EDT
*** Bug 196850 has been marked as a duplicate of this bug. ***
Comment 22 Mayank Jain 2006-07-12 02:51:03 EDT
*** Bug 191071 has been marked as a duplicate of this bug. ***
Comment 23 BiRKaN 2006-07-13 16:42:14 EDT
I have selected English Language at initial installation.
After installation finished successfully I have upgraded yum to yum-2.6.1-0.fc5
after that required rpms downloaded and it works fine :)
Comment 24 Jeremy Katz 2006-09-06 01:51:36 EDT
*** Bug 205035 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.