Bug 588039

Summary: [abrt] crash in gthumb-2.11.3-1.fc13: Process /usr/bin/gthumb was killed by signal 6 (SIGABRT)
Product: [Fedora] Fedora Reporter: Christoph Wickert <cwickert>
Component: gthumbAssignee: Christian Krause <chkr>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: ageha.stg, alex, behdad, benjavalero, benoit.alary, bloch, bugzilla, bugzilla, chucka, ckteo88, corbet, daviddoria, edi, eduardonunesp, evlyons, eyeneeserver, fedora, ian.springer, jan.kratochvil, jogood, johnmargaritopoulos, ken, kloutvor, laurenthoudijk, marbolangos, michel, mjc, mray271, nuno.dias, oo_0987654321, p_s_oberoi, rvokal, steevithak, tcpip4000, telpelass, tim.liim, vassieux, walter.klammer, wd8oqx, whpgf, wlplqlw
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: abrt_hash:dbd6ed4debce4bc81914c4aece333e58877773a8
Fixed In Version: gthumb-2.11.5-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-26 22:40:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace none

Description Christoph Wickert 2010-05-02 06:40:49 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gthumb
comment: gthumb crashed when I launched it after upgrading to F13.
component: gthumb
executable: /usr/bin/gthumb
global_uuid: dbd6ed4debce4bc81914c4aece333e58877773a8
kernel: 2.6.33.2-57.fc13.x86_64
package: gthumb-2.11.3-1.fc13
rating: 4
reason: Process /usr/bin/gthumb was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. upgrade to F13
2. start gthumb
3. crash!
Comment 1 Christoph Wickert 2010-05-02 06:40:51 EDT
Created attachment 410778 [details]
File: backtrace
Comment 2 Christoph Wickert 2010-05-02 06:47:47 EDT
On the console I see 

$ gthumb 
failed to create drawable

** ERROR **: Unable to initialize GtkClutter
aborting...
Comment 3 Jonathan Corbet 2010-05-13 18:38:46 EDT
<metoo>

Any attempt to run gthumb just yields the message shown above.  This is Rawhide 64-bit, with gthumb-2.11.3-1.fc14.x86_64.
Comment 4 Karel Klíč 2010-05-25 05:22:57 EDT
*** Bug 584509 has been marked as a duplicate of this bug. ***
Comment 5 Karel Klíč 2010-05-25 05:23:01 EDT
*** Bug 590930 has been marked as a duplicate of this bug. ***
Comment 6 Benjamín Valero Espinosa 2010-05-31 14:21:48 EDT
*** Bug 595960 has been marked as a duplicate of this bug. ***
Comment 7 Benjamín Valero Espinosa 2010-05-31 14:26:35 EDT
*** Bug 596854 has been marked as a duplicate of this bug. ***
Comment 8 Benjamín Valero Espinosa 2010-05-31 14:27:57 EDT
*** Bug 597255 has been marked as a duplicate of this bug. ***
Comment 9 Benjamín Valero Espinosa 2010-05-31 14:28:57 EDT
*** Bug 597299 has been marked as a duplicate of this bug. ***
Comment 10 Benjamín Valero Espinosa 2010-05-31 14:29:49 EDT
*** Bug 597572 has been marked as a duplicate of this bug. ***
Comment 11 Benjamín Valero Espinosa 2010-05-31 14:30:39 EDT
*** Bug 597817 has been marked as a duplicate of this bug. ***
Comment 12 Benjamín Valero Espinosa 2010-05-31 14:34:09 EDT
I have a Nvidia card and I'm using the Nouveau driver. In my case, installing the package 'mesa-dri-drivers-experimental' has solved this issue.
Comment 13 Benjamín Valero Espinosa 2010-05-31 14:36:23 EDT
The duplicates happen with 32-bit, not only with 64.
Comment 14 Heiko Adams 2010-05-31 14:51:56 EDT
Installing 'mesa-dri-drivers-experimental' solved the problem here too
Comment 15 Benjamín Valero Espinosa 2010-05-31 15:16:49 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Fabien Archambault 2010-06-01 03:48:32 EDT
Same here for the mesa-dri-drivers-experimental solution...

There are still some warning while loading :
$ gthumb 

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_ellipsize: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_angle: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkMisc'

(gthumb:29021): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_ellipsize: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_angle: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkMisc'

(gthumb:29021): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_ellipsize: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_angle: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkMisc'

(gthumb:29021): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_ellipsize: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkLabel'

(gthumb:29021): Gtk-CRITICAL **: gtk_label_set_angle: assertion `GTK_IS_LABEL (label)' failed

(gthumb:29021): GLib-GObject-WARNING **: invalid cast from `GtkHBox' to `GtkMisc'

(gthumb:29021): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed
Comment 17 Steevithak 2010-06-02 01:29:17 EDT
I think I'm seeing this same bug. I installed Gthumb to replace the crappy "shotwell" thing that came with F13 but when I try to start Gthumb, it crashes silently, followed a few seconds later by one of two things: 1) abrt briefly appears and then crashes itself or 2) abrt appears and says Gthumb crashed but won't let me report it due to a "bad trace" 

When I look in /var/log/messages I see this:

Jun  2 00:21:04 triffid abrt[3716]: saved core dump of pid 3715 (/usr/bin/gthumb) to /var/cache/abrt/ccpp-1275455949-3715.new/coredump (2892963840 bytes)

Jun  2 00:21:04 triffid abrtd: Directory 'ccpp-1275455949-3715' creation detected

Jun  2 00:21:04 triffid abrt[3716]: size of '/var/cache/abrt' >= 1250 MB, deleting 'ccpp-1275455949-3715'

Jun  2 00:21:04 triffid abrt[3716]: Lock file '/var/cache/abrt/ccpp-1275455949-3715.lock' is locked by process 1309

Jun  2 00:21:06 triffid abrtd: '/var/cache/abrt/ccpp-1275455949-3715' does not exist

Jun  2 00:21:06 triffid abrtd: Corrupted or bad crash /var/cache/abrt/ccpp-1275455949-3715 (res:1), deleting


I'm running an up-to-date Fedora 13 on a Dell Inspiron 8600 laptop. Gthumb worked great on F12, F11, F10, etc. This is the first time I've seen any problems running Gthumb on Fedora on this box.
Comment 18 Benjamín Valero Espinosa 2010-06-02 03:31:21 EDT
Your case seems different, because your laptop has an ATI card.

It seems that the problem in this particular crash is that Gthumb in F13 depends on CLutter for the slideshow, but on Nvidia cards Clutter needs installed the experimental mesa drivers and crashes if not.

If this is really the problem, it should be solved or at least added to Common Bugs, although Gthumb is not installed by default.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Steevithak 2010-06-02 11:07:41 EDT
Actually, my Dell Inspiron 8600 laptop has an nVidia card: nVidia Corporation NV34M [GeForce FX Go5200 64M](rev a1). 

What is the "clutter" thing that needs to be installed? I did a "yum list clutter*" but got a whole page full of stuff, so I'm not sure what to install.
Comment 20 Fabien Archambault 2010-06-02 11:20:39 EDT
Here is the installed files in my laptop:
# yum list installed | grep clutter
clutter.x86_64                    1.2.8-1.fc13                  @updates        
clutter-gtk.x86_64                0.10.4-1.fc13                 @fedora
Comment 21 Steevithak 2010-06-02 11:31:44 EDT
Ok, thanks, looks like that wasn't the problem. RPM shows those two packages as already installed:

rpm -q clutter:
clutter-1.2.8-1.fc13.i686

rpm -q clutter-gtk:
clutter-gtk-0.10.4-1.fc13.i686

What about the "experimental mesa drivers" mentioned in comment 18? Should I try installing those (and if so, what's the package name) ?
Comment 22 Benjamín Valero Espinosa 2010-06-02 12:01:37 EDT
The package for 3D support in Nvidia cards (with Nouveau) is mesa-dri-drivers-experimental.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Steevithak 2010-06-02 12:24:58 EDT
Cool, that fixed it! After installing mesa-dri-drivers-experimental, gthumb loads without crashing. I guess the next obvious question is why would gthumb require 3d graphics acceleration to display 2D photos? Aside from the apparent dependency bug in the gthumb package that doesn't let yum/rpm know it needs the mesa drivers, is there a bug in gthumb itself? It seems bizarre that it should even need 3d, much less crash when it's not available?
Comment 24 Benjamín Valero Espinosa 2010-06-02 12:36:56 EDT
(In reply to comment #23)
> Cool, that fixed it! After installing mesa-dri-drivers-experimental, gthumb
> loads without crashing. I guess the next obvious question is why would gthumb
> require 3d graphics acceleration to display 2D photos? Aside from the apparent
> dependency bug in the gthumb package that doesn't let yum/rpm know it needs the
> mesa drivers, is there a bug in gthumb itself? It seems bizarre that it should
> even need 3d, much less crash when it's not available?    

You should read the previous posts :D Gthumb uses Clutter for the slideshow, but it should work without 3D, or at least disabled the 3D transitions.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Steevithak 2010-06-02 14:17:26 EDT
Ok, understood. I didn't realize they'd added fancy 3D stuff to the slide show.

So would it make sense to file a separate bug upstream on Gthumb for "not properly detecting whether 3D support is present" or something along those lines? Or does this bug pretty much cover it?
Comment 26 larry 2010-06-02 23:16:29 EDT
well, i'm using neither ATI nor nVidia card cuz i have Fedora 13 installed as a guest on VMWare Server 2.0.0.2643.  i've tried mesa-dri-drivers-experimental and it didn't work.
Comment 27 Fabien Archambault 2010-06-03 02:22:00 EDT
I am not sure, but perhaps you need to install the additions or something like this in order to allow VMWare to do some 3D.
Comment 28 larry 2010-06-03 03:24:43 EDT
i think VMWare Server doesn't support 3D acceleration in guests.  oh well, i'll just switch to Shotwell then.
Comment 29 Michael J. Chudobiak 2010-06-08 10:22:07 EDT
*** Bug 598244 has been marked as a duplicate of this bug. ***
Comment 30 Juan P. Daza P. 2010-06-10 08:19:06 EDT
Package: gthumb-2.11.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Open an image from desktop folder


Comment
-----
Opening a png image from desktop folder gives this crash.
Comment 31 Benjamín Valero Espinosa 2010-06-10 08:32:14 EDT
Juan, if you open Gthumb from the Applications menu it doesn't crash?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 32 Juan P. Daza P. 2010-06-11 08:14:52 EDT
(In reply to comment #31)
> Juan, if you open Gthumb from the Applications menu it doesn't crash?
> 

Yes, it crash also.

> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers
Comment 33 Benjamín Valero Espinosa 2010-06-11 09:13:54 EDT
Juan, try to install the package mesa-dri-drivers-experimental, as said in comment 22 as a possible workaround.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 34 David Doria 2010-06-14 09:32:01 EDT
Package: gthumb-2.11.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. run 'gthumb .' or 'gthumb image.png'
Comment 35 Jonathan Corbet 2010-06-16 11:46:11 EDT
FWIW, the mesa-dri-drivers-experimental fix does not work for me.  I'm running basic Intel graphics.  I'm also running custom kernels, of course, so maybe I've configured out something important.  Before anybody asks: stock kernels don't currently boot on this system for reasons I intend to track down once I've recovered a bit from recent travel.
Comment 36 Ken Dubrick 2010-06-21 16:54:06 EDT
Package: gthumb-2.11.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just opening the program
2.
3.
Comment 37 Eduardo Pereira 2010-06-22 21:34:31 EDT
Package: gthumb-2.11.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. while start
2.
3.
Comment 38 Michel Alexandre Salim 2010-06-23 05:35:23 EDT
Filed in GNOME Bugzilla (and this bug also get mentioned in LWN -- it appears Jon Corbet is also affected: http://lwn.net/Articles/392261/)
Comment 39 Michael J. Chudobiak 2010-06-23 07:51:17 EDT
This is fixed upstream, and the fix will appear in gThumb 2.11.4 (due to be released Monday June 28). Slideshow functionality should degrade gracefully if clutter is not usable.

As a side note: the old slideshow code was horrible to look at, hard to understand, and prone to odd effects (with dual display systems, for example). The new clutter-based code is very clean and elegant, due to clutter's easy-to-use API. That is why clutter was used, not because gThumb will be displaying 3D images or holograms or whatever.

- Mike
Comment 40 Petr Kloutvor 2010-06-25 11:11:52 EDT
Package: gthumb-2.11.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Connect Sony Ericsson J10i
2.launch gthumb
3.
Comment 41 Tim Taiwanese Liim 2010-07-01 17:50:23 EDT
Re: Comment #39
Michael,
Is there any workaround before we get gthumb 2.11.4 in F13?  Thanks.
I installed mesa-dri-drivers-experimental but apparently it does not
help; gthumb still core dumps.  I have
  01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)        
which is neither ATI or nVidia.
Comment 42 Fedora Update System 2010-07-16 19:14:50 EDT
gthumb-2.11.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gthumb-2.11.5-1.fc13
Comment 43 Michel Alexandre Salim 2010-07-16 19:17:40 EDT
I've not heard from Behdad, so since there's been two releases in which this bug is fixed upstream, I'm pushing an update.

Please test and vote up the package above if it fixes the issue for you. It works on my computer, which since it has an ATi Evergreen card, is not supported even with the experimental DRI drivers.
Comment 44 Michel Alexandre Salim 2010-07-16 19:18:41 EDT
*** Bug 608215 has been marked as a duplicate of this bug. ***
Comment 45 Michel Alexandre Salim 2010-07-16 19:19:33 EDT
*** Bug 608581 has been marked as a duplicate of this bug. ***
Comment 46 Michel Alexandre Salim 2010-07-16 19:20:04 EDT
*** Bug 608633 has been marked as a duplicate of this bug. ***
Comment 47 Michel Alexandre Salim 2010-07-16 19:21:04 EDT
*** Bug 606255 has been marked as a duplicate of this bug. ***
Comment 48 Michel Alexandre Salim 2010-07-16 19:21:34 EDT
*** Bug 606491 has been marked as a duplicate of this bug. ***
Comment 49 Michel Alexandre Salim 2010-07-16 19:21:58 EDT
*** Bug 609708 has been marked as a duplicate of this bug. ***
Comment 50 Michel Alexandre Salim 2010-07-16 19:22:31 EDT
*** Bug 613925 has been marked as a duplicate of this bug. ***
Comment 51 Michel Alexandre Salim 2010-07-16 19:23:04 EDT
*** Bug 614203 has been marked as a duplicate of this bug. ***
Comment 52 Michel Alexandre Salim 2010-07-16 19:29:26 EDT
*** Bug 613505 has been marked as a duplicate of this bug. ***
Comment 53 Michel Alexandre Salim 2010-07-16 19:29:50 EDT
*** Bug 613503 has been marked as a duplicate of this bug. ***
Comment 54 Michel Alexandre Salim 2010-07-16 19:30:12 EDT
*** Bug 607786 has been marked as a duplicate of this bug. ***
Comment 55 Michel Alexandre Salim 2010-07-16 19:34:54 EDT
*** Bug 604256 has been marked as a duplicate of this bug. ***
Comment 56 Michel Alexandre Salim 2010-07-16 19:35:19 EDT
*** Bug 604975 has been marked as a duplicate of this bug. ***
Comment 57 Michel Alexandre Salim 2010-07-16 19:35:45 EDT
*** Bug 606135 has been marked as a duplicate of this bug. ***
Comment 58 Michel Alexandre Salim 2010-07-16 19:37:39 EDT
*** Bug 607846 has been marked as a duplicate of this bug. ***
Comment 59 Michel Alexandre Salim 2010-07-16 19:38:47 EDT
*** Bug 611286 has been marked as a duplicate of this bug. ***
Comment 60 Michel Alexandre Salim 2010-07-16 19:39:07 EDT
*** Bug 612037 has been marked as a duplicate of this bug. ***
Comment 61 Michel Alexandre Salim 2010-07-16 19:39:25 EDT
*** Bug 612038 has been marked as a duplicate of this bug. ***
Comment 62 Michel Alexandre Salim 2010-07-16 19:39:43 EDT
*** Bug 612377 has been marked as a duplicate of this bug. ***
Comment 63 Michel Alexandre Salim 2010-07-16 19:41:56 EDT
*** Bug 602615 has been marked as a duplicate of this bug. ***
Comment 64 Fedora Admin XMLRPC Client 2010-07-17 18:08:54 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 65 Tim Taiwanese Liim 2010-07-18 23:55:20 EDT
Re: Comment #42
Michel,
Please advise how to update gthumb for test.  I tried this just now:
    [root@taiwan ~]# rpm -qf /usr/bin/gthumb 
    gthumb-2.11.3-1.fc13.i686
    [root@taiwan ~]# yum update --enablerepo=updates-testing gthumb
    Loaded plugins: presto, refresh-packagekit
    Setting up Update Process
    No Packages marked for Update
    [root@taiwan ~]# date
    Sun Jul 18 23:48:53 EDT 2010
Did I miss anything?  Thanks!
Comment 66 John Good 2010-07-22 22:38:53 EDT
I tried the mesa- and clutter-gtk workarounds then I found Comment 65 and entered the yum update ... given, and it found version 2.11.5 which works just fine.

Thanks, guys.
Comment 67 Gerhard 2010-07-23 00:25:59 EDT
After the update, I can't determine the problem any more. Thx a lot! ;-)
Comment 68 Alex Bartl 2010-07-23 03:24:18 EDT
2.11.5 works, thx!
Comment 69 Tim Taiwanese Liim 2010-07-23 10:09:46 EDT
Re: Comment #66
John,
Thanks for info.  I tried the same yum update ...  last night, and it
worked this time.  Apparently 2.11.5 reached update-testing repo
between 7/18 and 7/22.

Yes, it worked!  Right before update, gthumb-2.11.3-1.fc13.i686 still
had core dump immediately after start.  After update, no more core
dump, BUT now 2.11.5-1 got stuck (for >8 hours) in the "Loading..." 
stage in one of my directories.  Well, that will be addressed in
another bug.  For now, no more core dump!

I added the worked comment to the page pointed to in Comment #42.
Comment 70 Christian Krause 2010-07-25 12:58:00 EDT
*** Bug 618012 has been marked as a duplicate of this bug. ***
Comment 71 Christian Krause 2010-07-25 12:58:44 EDT
*** Bug 617080 has been marked as a duplicate of this bug. ***
Comment 72 Christian Krause 2010-07-25 12:59:06 EDT
*** Bug 615638 has been marked as a duplicate of this bug. ***
Comment 73 Fedora Update System 2010-07-26 22:39:56 EDT
gthumb-2.11.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 74 Christian Krause 2010-07-27 15:54:41 EDT
*** Bug 618605 has been marked as a duplicate of this bug. ***