Bug 759784 - [abrt] gitg-0.2.5-1.fc16: sigandset: Process /usr/bin/gitg was killed by signal 6 (SIGABRT)
[abrt] gitg-0.2.5-1.fc16: sigandset: Process /usr/bin/gitg was killed by sign...
Status: CLOSED DUPLICATE of bug 759736
Product: Fedora
Classification: Fedora
Component: gitg (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ignacio Casal Quinteiro (nacho)
Fedora Extras Quality Assurance
abrt_hash:a8decad55612d20e9f9ef22afc6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-03 14:33 EST by Scott Schmit
Modified: 2012-03-30 11:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 11:28:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (2.90 KB, text/plain)
2011-12-03 14:33 EST, Scott Schmit
no flags Details
File: dso_list (6.80 KB, text/plain)
2011-12-03 14:33 EST, Scott Schmit
no flags Details
File: maps (33.62 KB, text/plain)
2011-12-03 14:33 EST, Scott Schmit
no flags Details
File: smolt_data (3.32 KB, text/plain)
2011-12-03 14:33 EST, Scott Schmit
no flags Details
File: backtrace (13.70 KB, text/plain)
2011-12-03 14:33 EST, Scott Schmit
no flags Details

  None (edit)
Description Scott Schmit 2011-12-03 14:33:36 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        gitg
crash_function: sigandset
executable:     /usr/bin/gitg
kernel:         3.1.2-1.fc16.x86_64
pid:            15007
reason:         Process /usr/bin/gitg was killed by signal 6 (SIGABRT)
time:           Sat 03 Dec 2011 02:08:15 PM EST
uid:            1000
username:       draco
xsession_errors: 

backtrace:      Text file, 14024 bytes
dso_list:       Text file, 6960 bytes
environ:        Text file, 2965 bytes
maps:           Text file, 34422 bytes
smolt_data:     Text file, 3398 bytes

comment:
:I have a git repository with two branches: master and local. Local is branched from master with tracking enabled
:The master branch is acting like a vendor branch, and they have diverged, so I'm in the middle of merging master into local and have staged all the changes, but wanted to look at the tree before continuing.
:
:I selected "all branches" and then gitg crashed.
:
:On my console, I have:
:***MEMORY-ERROR***: gitg[15007]: GSlice: assertion failed: sinfo->n_allocated > 0
:Aborted (core dumped)

var_log_messages:
:Dec  3 12:47:10 kvothe yum[6454]: Installed: gitg-libs-0.2.5-1.fc16.x86_64
:Dec  3 12:47:15 kvothe yum[6454]: Installed: gitg-0.2.5-1.fc16.x86_64
:Dec  3 14:08:15 kvothe abrt[15060]: Saved core dump of pid 15007 (/usr/bin/gitg) to /var/spool/abrt/ccpp-2011-12-03-14:08:15-15007 (40497152 bytes)
Comment 1 Scott Schmit 2011-12-03 14:33:38 EST
Created attachment 540132 [details]
File: environ
Comment 2 Scott Schmit 2011-12-03 14:33:40 EST
Created attachment 540133 [details]
File: dso_list
Comment 3 Scott Schmit 2011-12-03 14:33:41 EST
Created attachment 540134 [details]
File: maps
Comment 4 Scott Schmit 2011-12-03 14:33:43 EST
Created attachment 540135 [details]
File: smolt_data
Comment 5 Scott Schmit 2011-12-03 14:33:44 EST
Created attachment 540136 [details]
File: backtrace
Comment 6 abrt-bot 2012-03-30 11:28:38 EDT
Backtrace analysis found this bug to be similar to bug #759736, closing as duplicate.

Bugs which were found to be similar to this bug: 
  control-center: bug #759925, bug #765867, bug #766278
  edb: bug #761407
  empathy: bug #766323
  gnome-online-accounts: bug #759804, bug #759892, bug #765747, bug #765758
  gnome-settings-daemon: bug #759970, bug #760595, bug #766330
  gnome-shell: bug #759736, bug #759943, bug #759944, bug #760146, bug #760936, bug #765613, bug #767807
  gnome-terminal: bug #766329, bug #767854
  gnome-utils: bug #767814, bug #767815
  gvfs: bug #759894
  ibus: bug #795253
  libreoffice: bug #761089
  pidgin: bug #746105
  rhythmbox: bug #760314
  synergy: bug #759969
  telepathy-mission-control: bug #800467

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 759736 ***

Note You need to log in before you can comment on or make changes to this bug.