Bug 701802 - [abrt] rhythmbox-0.13.3-1.fc14: memblock_free: Process /usr/bin/rhythmbox was killed by signal 6 (SIGABRT)
Summary: [abrt] rhythmbox-0.13.3-1.fc14: memblock_free: Process /usr/bin/rhythmbox was...
Keywords:
Status: CLOSED DUPLICATE of bug 703242
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a1bd1272908e3f4cd576492cf58...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-03 22:01 UTC by Richard Ryniker
Modified: 2012-03-21 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-21 17:30:22 UTC


Attachments (Terms of Use)
File: backtrace (64.95 KB, text/plain)
2011-05-03 22:01 UTC, Richard Ryniker
no flags Details
File: comment (2.33 KB, text/plain)
2011-05-03 22:01 UTC, Richard Ryniker
no flags Details

Description Richard Ryniker 2011-05-03 22:01:01 UTC
abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 66505 bytes
cmdline: rhythmbox '/home/ryniker/.gvfs/cdda mount on sr1'
Attached file: comment, 2386 bytes
component: rhythmbox
Attached file: coredump, 211656704 bytes
crash_function: memblock_free
executable: /usr/bin/rhythmbox
kernel: 2.6.35.9-64.fc14.x86_64
package: rhythmbox-0.13.3-1.fc14
rating: 4
reason: Process /usr/bin/rhythmbox was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1304458686
uid: 501

How to reproduce
-----
1. Play locally generated CD
2.
3.

Comment 1 Richard Ryniker 2011-05-03 22:01:03 UTC
Created attachment 496644 [details]
File: backtrace

Comment 2 Richard Ryniker 2011-05-03 22:01:13 UTC
Created attachment 496645 [details]
File: comment

Comment 3 Richard Ryniker 2011-05-06 02:01:56 UTC
Looks like this may not be a media problem.  When I insert a new copy of the CD, Rythmbox fails to play the first track of the CD:

Failed to open output device: pa_stream_writable_size() failed: Connection terminated

but continues and plays the second track OK.  Pulseaudio problem?

Rythmbox crashed when play was paused and Quit selected from the menu.  VLC plays the same media without a problem, and the CD plays in audio equipment without trouble, which suggests this is not really a media problem.

To reproduce:

1. Load the CD.

2. Select "Open Rythmbox Music Player" from the "Audio Disc" pop-up.

   Rythmbox says "Could not find the album on MusicBrainz."
   This is expected; it contains material I recorded.

   Rythmbox displays the eight tracks on the CD, with appropriate time  information.

3. Select "Play".  This generates the following interesting data in /var/log/messages:

May  5 21:57:17 ryniker pulseaudio[10820]: asyncq.c: q overrun, queuing locally
May  5 21:57:17 ryniker pulseaudio[10820]: asyncq.c: q overrun, queuing locally
May  5 21:57:17 ryniker pulseaudio[10820]: asyncq.c: q overrun, queuing locally
May  5 21:57:17 ryniker pulseaudio[10820]: asyncq.c: q overrun, queuing locally
May  5 21:57:17 ryniker pulseaudio[10820]: asyncq.c: q overrun, queuing locally
May  5 21:57:17 ryniker pulseaudio[10820]: asyncq.c: q overrun, queuing locally
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11379 of process 11379 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
May  5 21:57:18 ryniker pulseaudio[11379]: pid.c: Stale PID file, overwriting.
May  5 21:57:18 ryniker kernel: [12289321.843680] ALSA sound/usb/clock.c:242: 6:1:1: cannot get freq at ep 0x1
May  5 21:57:18 ryniker kernel: [12289321.915045] ALSA sound/usb/clock.c:242: 6:1:1: cannot get freq at ep 0x1
May  5 21:57:18 ryniker kernel: [12289321.985535] ALSA sound/usb/clock.c:242: 6:1:1: cannot get freq at ep 0x1
May  5 21:57:18 ryniker kernel: [12289322.086520] ALSA sound/usb/clock.c:242: 6:1:1: cannot get freq at ep 0x1
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11385 of process 11379 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11386 of process 11379 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11387 of process 11379 (/usr/bin/pulseaudio) owned by '501' RT at priority 5.
May  5 21:57:18 ryniker pulseaudio[11379]: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.Spawn.ChildExited
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11392 of process 11392 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
May  5 21:57:18 ryniker pulseaudio[11392]: pid.c: Daemon already running.
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11393 of process 11393 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
May  5 21:57:18 ryniker pulseaudio[11393]: pid.c: Daemon already running.
May  5 21:57:18 ryniker rtkit-daemon[2595]: Successfully made thread 11394 of process 11394 (/usr/bin/pulseaudio) owned by '501' high priority at nice level -11.
May  5 21:57:18 ryniker pulseaudio[11394]: pid.c: Daemon already running.
May  5 21:57:22 ryniker pulseaudio[11379]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
May  5 21:57:22 ryniker pulseaudio[11379]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_usb_audio'. Please report this issue to the ALSA developers.
May  5 21:57:22 ryniker pulseaudio[11379]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
May  5 21:57:23 ryniker pulseaudio[11379]: ratelimit.c: 9 events suppressed
May  5 21:57:29 ryniker pulseaudio[11379]: ratelimit.c: 6 events suppressed

Comment 4 bugsfedora 2011-05-29 14:22:53 UTC
Package: rhythmbox-2.90.1-10.git20110502.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I try to run stream radio when I download packages.

Comment 5 Esteban Contreras-Vazquez 2011-06-13 03:36:32 UTC
Package: rhythmbox-2.90.1-10.git20110502.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I was listening a radio station, the connection fell down and I went oway, whn I got back after a wile, I pushed the play button (which were not playing) and Rhythmbox breaked.

Comment 6 Esteban Contreras-Vazquez 2011-06-17 23:54:00 UTC
Package: rhythmbox-2.90.1-10.git20110502.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Problems playing radio station (monkeyradio.org)

Comment 7 eblix08 2011-11-01 18:51:56 UTC
Package: rhythmbox-0.13.3-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Listen
2. Pause
3. Play


Comment
-----
Nothing special that I haven't done a hundred times before.

Comment 8 abrt-bot 2012-03-21 17:30:22 UTC
Backtrace analysis found this bug to be similar to bug #703242, closing as duplicate. This bug seems to belong to component gstreamer, gstreamer-plugins-base, gstreamer-plugins-good or pulseaudio.

Bugs which were found to be similar to this bug: 
  Miro: bug #644785, bug #671915, bug #675872
  clementine: bug #688736
  empathy: bug #727661
  exaile: bug #621163, bug #647450, bug #651874
  gnome-gmail-notifier: bug #676950
  gstreamer: bug #622115, bug #628957, bug #684379, bug #714366
  pidgin: bug #630761, bug #650671, bug #675521, bug #702179, bug #705795
  pulseaudio: bug #626187, bug #640207
  radiotray: bug #681392, bug #691767, bug #693902, bug #719455
  rhythmbox: bug #621126, bug #621145, bug #627396, bug #628092, bug #647839, bug #657634, bug #659797, bug #662137, bug #664387, bug #665694, bug #665840, bug #673528, bug #682405, bug #708831, bug #728617, bug #731708, bug #733864
  totem: bug #618884, bug #630185, bug #632821, bug #635254, bug #646537, bug #655274, bug #656330, bug #658302, bug #665276, bug #665791, bug #694331, bug #698006, bug #702896, bug #703242, bug #726964, bug #728661, bug #738496

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 703242 ***


Note You need to log in before you can comment on or make changes to this bug.