Bug 604499 - [abrt] crash in midori-0.2.6-1.fc13: malloc_consolidate: Process /usr/bin/midori was killed by signal 11 (SIGSEGV)
[abrt] crash in midori-0.2.6-1.fc13: malloc_consolidate: Process /usr/bin/mid...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: midori (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:2eb750de83a0b6dd7186ba0d24e...
:
: 589787 597957 603884 603978 604469 605208 605379 605439 605614 607320 607971 607972 607973 608766 608924 609396 609535 610065 610335 611791 617848 620335 622035 622104 622144 623031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 00:24 EDT by Amit Shah
Modified: 2011-03-27 17:27 EDT (History)
30 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-27 14:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (45.24 KB, text/plain)
2010-06-16 00:24 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2010-06-16 00:24:04 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: midori
component: midori
crash_function: malloc_consolidate
executable: /usr/bin/midori
global_uuid: 2eb750de83a0b6dd7186ba0d24e7a8c802551868
kernel: 2.6.33.5-112.fc13.x86_64
package: midori-0.2.6-1.fc13
rating: 4
reason: Process /usr/bin/midori was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Start Midori
2. (Click anywhere -- location bar or on the page)
3. Crash

Sometimes step 2 is not needed and midori crashes right after start, before any activity.

I tried the 'disable extensions' and also 'modify preferences', but nothing seems to help.
Comment 1 Amit Shah 2010-06-16 00:24:07 EDT
Created attachment 424343 [details]
File: backtrace
Comment 2 Amit Shah 2010-06-17 22:16:37 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
This is after recent updates to F13 and a system restart. The updated packages are:

Jun 15 09:54:30 Updated: yum-utils-1.1.27-2.fc13.noarch
Jun 15 09:58:01 Updated: gvfs-1.6.2-1.fc13.x86_64
Jun 15 09:58:02 Updated: python-libs-2.6.4-27.fc13.x86_64
Jun 15 09:58:14 Updated: python-2.6.4-27.fc13.x86_64
Jun 15 09:58:15 Updated: ibus-libs-1.3.5-2.fc13.x86_64
Jun 15 09:58:16 Updated: ibus-gtk-1.3.5-2.fc13.x86_64
Jun 15 09:58:31 Updated: ibus-1.3.5-2.fc13.x86_64
Jun 15 09:58:32 Updated: gvfs-afc-1.6.2-1.fc13.x86_64
Jun 15 09:58:35 Updated: sane-backends-libs-1.0.21-2.fc13.x86_64
Jun 15 09:58:38 Updated: sane-backends-1.0.21-2.fc13.x86_64
Jun 15 09:58:41 Updated: policycoreutils-2.0.82-29.fc13.x86_64
Jun 15 09:59:18 Updated: policycoreutils-python-2.0.82-29.fc13.x86_64
Jun 15 09:59:21 Updated: gnome-color-manager-2.30.2-1.fc13.x86_64
Jun 15 09:59:26 Updated: rhythmbox-0.12.8-4.fc13.x86_64
Jun 15 09:59:27 Updated: gvfs-smb-1.6.2-1.fc13.x86_64
Jun 15 09:59:28 Updated: gvfs-archive-1.6.2-1.fc13.x86_64
Jun 15 09:59:29 Updated: gvfs-obexftp-1.6.2-1.fc13.x86_64
Jun 15 09:59:30 Updated: gvfs-fuse-1.6.2-1.fc13.x86_64
Jun 15 09:59:31 Updated: gvfs-gphoto2-1.6.2-1.fc13.x86_64
Jun 15 09:59:32 Updated: dosbox-0.74-1.fc13.x86_64
Jun 15 09:59:42 Updated: gnucash-2.3.13-1.fc13.x86_64
Jun 15 09:59:44 Updated: telepathy-glib-0.10.6-1.fc13.x86_64
Jun 15 09:59:45 Updated: libgnomekbd-2.30.1-2.fc13.x86_64
Jun 15 09:59:46 Updated: cifs-utils-4.5-2.fc13.x86_64
Jun 15 09:59:47 Updated: sudo-1.7.2p6-2.fc13.x86_64
Jun 15 09:59:49 Updated: policycoreutils-gui-2.0.82-29.fc13.x86_64
Jun 15 09:59:50 Updated: policycoreutils-sandbox-2.0.82-29.fc13.x86_64
Jun 15 09:59:51 Updated: fontpackages-filesystem-1.44-1.fc13.noarch
Jun 16 07:31:57 Updated: 1:java-1.6.0-openjdk-1.6.0.0-41.b18.fc13.x86_64
Jun 16 07:31:58 Updated: libudev-151-10.fc13.x86_64
Jun 16 07:32:01 Updated: udev-151-10.fc13.x86_64
Jun 16 07:32:02 Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.x86_64
Jun 16 07:32:03 Updated: 1:make-3.81-19.fc13.x86_64
Jun 16 07:32:05 Updated: openssl-1.0.0a-1.fc13.x86_64
Jun 16 07:32:06 Updated: 12:dhclient-4.1.1-22.P1.fc13.x86_64
Jun 16 07:32:07 Updated: libudev-devel-151-10.fc13.x86_64
Jun 17 17:31:05 Updated: 1:qt-4.6.2-20.fc13.x86_64
Jun 17 17:31:06 Updated: 1:qt-sqlite-4.6.2-20.fc13.x86_64
Jun 17 17:31:06 Updated: gstreamer-tools-0.10.29-2.fc13.x86_64
Jun 17 17:31:09 Updated: gstreamer-0.10.29-2.fc13.x86_64
Jun 17 17:31:14 Updated: 1:qt-x11-4.6.2-20.fc13.x86_64
Jun 17 17:31:17 Updated: libexif-0.6.19-1.fc13.x86_64
Jun 17 17:31:18 Updated: libgudev1-151-10.fc13.x86_64
Jun 17 17:31:21 Updated: python-virtinst-0.500.3-1.fc13.noarch
Jun 17 17:31:30 Updated: virt-manager-0.8.4-1.fc13.noarch
Jun 17 17:31:54 Installed: kernel-devel-2.6.33.5-124.fc13.x86_64
Jun 17 17:31:55 Updated: gnome-icon-theme-extras-2.30.1-2.fc13.noarch
Jun 17 17:31:56 Updated: perf-2.6.33.5-124.fc13.noarch
Jun 17 17:32:01 Updated: kernel-headers-2.6.33.5-124.fc13.x86_64
Jun 17 17:32:03 Updated: system-config-users-1.2.99-1.fc13.noarch
Jun 17 17:32:11 Installed: kernel-2.6.33.5-124.fc13.x86_64

The crash had started happening since the Jun 15 updates. epiphany crashes in a similar manner as well.
Comment 3 Amit Shah 2010-06-18 01:33:16 EDT
Starting midori with a url on the cmd prompt doesn't lead to a crash. When started this way, midori is stable with new tabs, empty tabs, homepage, speed dial, etc.
Comment 4 Mihai Harpau 2010-06-18 07:38:50 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
I tried to start midori
Comment 5 Amit Shah 2010-06-18 08:33:39 EDT
Well, epiphany has stopped crashing now but midori crashes even when starting from the cmd prompt with a url. The logs below indicate it's a bug in midori itself and not in some library.

$ midori http://log.amitshah.net
** (midori:26817): DEBUG: NP_Initialize
** (midori:26817): DEBUG: NP_Initialize succeeded
** (midori:26817): DEBUG: NP_Initialize
** (midori:26817): DEBUG: NP_Initialize succeeded
** (midori:26817): DEBUG: NP_Initialize
** (midori:26817): DEBUG: NP_Initialize succeeded
** (midori:26817): DEBUG: NP_Initialize
** (midori:26817): DEBUG: NP_Initialize succeeded
*** glibc detected *** midori: free(): invalid pointer: 0x0000000001916440 ***
======= Backtrace: =========
/lib64/libc.so.6[0x3213a75726]
/lib64/libglib-2.0.so.0(g_strfreev+0x25)[0x321525c4b5]
/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so(NP_Initialize+0x77b)[0x7f940d35419b]
/usr/lib64/libwebkit-1.0.so.2[0x3cc3794255]
/usr/lib64/libwebkit-1.0.so.2[0x3cc379445b]
/usr/lib64/libwebkit-1.0.so.2[0x3cc3555c04]
/usr/lib64/libwebkit-1.0.so.2[0x3cc354df45]
/usr/lib64/libwebkit-1.0.so.2[0x3cc354fbf3]
/usr/lib64/libwebkit-1.0.so.2[0x3cc3793818]
/usr/lib64/libwebkit-1.0.so.2[0x3cc354bf70]
/usr/lib64/libwebkit-1.0.so.2[0x3cc34c29c8]
/usr/lib64/libwebkit-1.0.so.2[0x3cc354bc09]
/usr/lib64/libwebkit-1.0.so.2[0x3cc3ae7538]
/usr/lib64/libwebkit-1.0.so.2[0x3cc38ec4df]
/usr/lib64/libwebkit-1.0.so.2[0x3cc3878b9d]
/usr/lib64/libwebkit-1.0.so.2[0x3cc384f7fc]
/usr/lib64/libwebkit-1.0.so.2[0x3cc3856a88]
/usr/lib64/libwebkit-1.0.so.2[0x3cc38dae47]
/usr/lib64/libwebkit-1.0.so.2(JSEvaluateScript+0x1f0)[0x3cc382b470]
midori(sokoke_js_script_eval+0x92)[0x46a81e]
midori[0x41ebd0]
/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x1f2)[0x321523bd02]
/lib64/libglib-2.0.so.0[0x321523fae8]
/lib64/libglib-2.0.so.0(g_main_loop_run+0x195)[0x321523fff5]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_main+0xa7)[0x321cf493c7]
midori(main+0x18dc)[0x421488]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x3213a1ec5d]
midori[0x41c429]
======= Memory map: ========
00400000-00496000 r-xp 00000000 fd:03 3670545                            /usr/bin/midori
00696000-006a2000 rw-p 00096000 fd:03 3670545                            /usr/bin/midori
011b9000-01a0f000 rw-p 00000000 00:00 0                                  [heap]
3213600000-321361e000 r-xp 00000000 fd:01 524334                         /lib64/ld-2.12.so
321381e000-321381f000 r--p 0001e000 fd:01 524334                         /lib64/ld-2.12.so
321381f000-3213820000 rw-p 0001f000 fd:01 524334                         /lib64/ld-2.12.so
3213820000-3213821000 rw-p 00000000 00:00 0 
3213a00000-3213b75000 r-xp 00000000 fd:01 525653                         /lib64/libc-2.12.so
3213b75000-3213d75000 ---p 00175000 fd:01 525653                         /lib64/libc-2.12.so
3213d75000-3213d79000 r--p 00175000 fd:01 525653                         /lib64/libc-2.12.so
3213d79000-3213d7a000 rw-p 00179000 fd:01 525653                         /lib64/libc-2.12.so
3213d7a000-3213d7f000 rw-p 00000000 00:00 0 
3213e00000-3213e17000 r-xp 00000000 fd:01 526802                         /lib64/libpthread-2.12.so
3213e17000-3214016000 ---p 00017000 fd:01 526802                         /lib64/libpthread-2.12.so
3214016000-3214017000 r--p 00016000 fd:01 526802                         /lib64/libpthread-2.12.so
3214017000-3214018000 rw-p 00017000 fd:01 526802                         /lib64/libpthread-2.12.so
3214018000-321401c000 rw-p 00000000 00:00 0 
3214200000-3214202000 r-xp 00000000 fd:01 526810                         /lib64/libdl-2.12.so
3214202000-3214402000 ---p 00002000 fd:01 526810                         /lib64/libdl-2.12.so
3214402000-3214403000 r--p 00002000 fd:01 526810                         /lib64/libdl-2.12.so
3214403000-3214404000 rw-p 00003000 fd:01 526810                         /lib64/libdl-2.12.so
3214600000-3214607000 r-xp 00000000 fd:01 526803                         /lib64/librt-2.12.so
3214607000-3214806000 ---p 00007000 fd:01 526803                         /lib64/librt-2.12.so
3214806000-3214807000 r--p 00006000 fd:01 526803                         /lib64/librt-2.12.so
3214807000-3214808000 rw-p 00007000 fd:01 526803                         /lib64/librt-2.12.so
3214a00000-3214a83000 r-xp 00000000 fd:01 526807                         /lib64/libm-2.12.so
3214a83000-3214c82000 ---p 00083000 fd:01 526807                         /lib64/libm-2.12.so
3214c82000-3214c83000 r--p 00082000 fd:01 526807                         /lib64/libm-2.12.so
3214c83000-3214c84000 rw-p 00083000 fd:01 526807                         /lib64/libm-2.12.so
3214e00000-3214e15000 r-xp 00000000 fd:01 526808                         /lib64/libz.so.1.2.3
3214e15000-3215014000 ---p 00015000 fd:01 526808                         /lib64/libz.so.1.2.3
3215014000-3215015000 rw-p 00014000 fd:01 526808                         /lib64/libz.so.1.2.3
3215200000-32152fb000 r-xp 00000000 fd:01 526829                         /lib64/libglib-2.0.so.0.2400.1
32152fb000-32154fa000 ---p 000fb000 fd:01 526829                         /lib64/libglib-2.0.so.0.2400.1
32154fa000-32154fc000 rw-p 000fa000 fd:01 526829                         /lib64/libglib-2.0.so.0.2400.1
3215600000-321561c000 r-xp 00000000 fd:01 526815                         /lib64/libselinux.so.1
321561c000-321581b000 ---p 0001c000 fd:01 526815                         /lib64/libselinux.so.1
321581b000-321581c000 r--p 0001b000 fd:01 526815                         /lib64/libselinux.so.1
321581c000-321581d000 rw-p 0001c000 fd:01 526815                         /lib64/libselinux.so.1
321581d000-321581e000 rw-p 00000000 00:00 0 
3215a00000-3215a04000 r-xp 00000000 fd:01 526830                         /lib64/libgthread-2.0.so.0.2400.1
3215a04000-3215c03000 ---p 00004000 fd:01 526830                         /lib64/libgthread-2.0.so.0.2400.1
3215c03000-3215c04000 rw-p 00003000 fd:01 526830                         /lib64/libgthread-2.0.so.0.2400.1
3215e00000-3215e44000 r-xp 00000000 fd:01 526831                         /lib64/libgobject-2.0.so.0.2400.1
3215e44000-3216044000 ---p 00044000 fd:01 526831                         /lib64/libgobject-2.0.so.0.2400.1
3216044000-3216046000 rw-p 00044000 fd:01 526831                         /lib64/libgobject-2.0.so.0.2400.1
3216200000-3216216000 r-xp 00000000 fd:01 526814                         /lib64/libresolv-2.12.so
3216216000-3216416000 ---p 00016000 fd:01 526814                         /lib64/libresolv-2.12.so
3216416000-3216417000 r--p 00016000 fd:01 526814                         /lib64/libresolv-2.12.so
3216417000-3216418000 rw-p 00017000 fd:01 526814                         /lib64/libresolv-2.12.so
3216418000-321641a000 rw-p 00000000 00:00 0 
3216600000-3216603000 r-xp 00000000 fd:01 526832                         /lib64/libgmodule-2.0.so.0.2400.1
3216603000-3216802000 ---p 00003000 fd:01 526832                         /lib64/libgmodule-2.0.so.0.2400.1
3216802000-3216803000 rw-p 00002000 fd:01 526832                         /lib64/libgmodule-2.0.so.0.2400.1
3216a00000-3216b39000 r-xp 00000000 fd:03 794069                         /usr/lib64/libX11.so.6.3.0java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (fedora-41.b18.fc13-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
Aborted (core dumped)



Package:    	midori-0.2.6-1.fc13
Latest Crash:	Fri 18 Jun 2010 06:03:29 PM 
Command:    	midori http://log.amitshah.net
Reason:     	Process /usr/bin/midori was killed by signal 6 (SIGABRT)
Comment:    	None
Bug Reports:
Comment 6 Nathan Thomas 2010-06-21 10:38:53 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Upgrade Midori from 0.2.4 to 0.2.6
2. Midori consistently crashes upon launch
3.


Comment
-----
I was able to upgrade to 0.2.6 in Fedora 12 x86_64 without any problems.
Comment 7 Nathan Thomas 2010-06-21 18:08:21 EDT
Update: I downgraded to 0.2.4, and still Midori crashes upon launch ("killed by signal 11"). It was working before the upgrade to 0.2.6! However this is a fresh install of F13, so a lot of packages got updated at the same time as Midori. Selecting 'Disable all plugins' from the dialogue box that appeared when I tried to run Midori made no difference.

I upgraded again to 0.2.6, and still Midori crashed when launched using xfrun4 or selecting it in the Applications menu. But then I noticed a strange thing: running Midori from the command line seems to work perfectly. I have no idea why this might be.
Comment 8 Raphael Groner 2010-06-25 06:35:30 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. start midori
2.
3.
Comment 9 Raphael Groner 2010-06-25 06:45:08 EDT
*** Bug 607971 has been marked as a duplicate of this bug. ***
Comment 10 Raphael Groner 2010-06-25 06:47:24 EDT
*** Bug 607972 has been marked as a duplicate of this bug. ***
Comment 11 Raphael Groner 2010-06-25 06:48:21 EDT
*** Bug 607973 has been marked as a duplicate of this bug. ***
Comment 12 Raphael Groner 2010-06-25 06:54:25 EDT
(In reply to comment #7)
Try to run Midori from console with a parameter, "midori 1" or so, to get the crash.
Comment 13 Raphael Groner 2010-06-25 07:16:18 EDT
*** glibc detected *** midori: free(): invalid pointer: 0x000000000168ce50 ***
======= Backtrace: =========
/lib64/libc.so.6[0x346aa75726]
/lib64/libglib-2.0.so.0(g_strfreev+0x25)[0x346c25c4b5]
/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so(NP_Initialize+0x77b)[0x7fed8256e19b]
/usr/lib64/libwebkit-1.0.so.2[0x33bad94255]
/usr/lib64/libwebkit-1.0.so.2[0x33bad9445b]
/usr/lib64/libwebkit-1.0.so.2[0x33bab55c04]
/usr/lib64/libwebkit-1.0.so.2[0x33bab4df45]
/usr/lib64/libwebkit-1.0.so.2[0x33bab4fbf3]
/usr/lib64/libwebkit-1.0.so.2[0x33bad93818]
/usr/lib64/libwebkit-1.0.so.2[0x33bab4bf70]
/usr/lib64/libwebkit-1.0.so.2[0x33baac29c8]
/usr/lib64/libwebkit-1.0.so.2[0x33bab4bc09]
/usr/lib64/libwebkit-1.0.so.2[0x33bb0e7538]
/usr/lib64/libwebkit-1.0.so.2[0x33baeec4df]
/usr/lib64/libwebkit-1.0.so.2[0x33bae78b9d]
/usr/lib64/libwebkit-1.0.so.2[0x33bae4f7fc]
/usr/lib64/libwebkit-1.0.so.2[0x33bae56a88]
/usr/lib64/libwebkit-1.0.so.2[0x33baedae47]
/usr/lib64/libwebkit-1.0.so.2(JSEvaluateScript+0x1f0)[0x33bae2b470]
midori(sokoke_js_script_eval+0x92)[0x46a81e]
midori[0x41ebd0]
/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x1f2)[0x346c23bd02]
/lib64/libglib-2.0.so.0[0x346c23fae8]
/lib64/libglib-2.0.so.0(g_main_loop_run+0x195)[0x346c23fff5]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_main+0xa7)[0x34737493c7]
midori(main+0x18dc)[0x421488]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x346aa1ec5d]
midori[0x41c429]
======= Memory map: ========
00400000-00496000 r-xp 00000000 fd:00 51331                              /usr/bin/midori
00696000-006a2000 rw-p 00096000 fd:00 51331                              /usr/bin/midori
00ac7000-01798000 rw-p 00000000 00:00 0                                  [heap]
31a6000000-31a6004000 r-xp 00000000 fd:00 6434                           /usr/lib64/xulrunner-1.9.2/libxpcom.so
31a6004000-31a6203000 ---p 00004000 fd:00 6434                           /usr/lib64/xulrunner-1.9.2/libxpcom.so
31a6203000-31a6204000 rw-p 00003000 fd:00 6434                           /usr/lib64/xulrunner-1.9.2/libxpcom.so
31a6400000-31a6514000 r-xp 00000000 fd:00 4975                           /usr/lib64/xulrunner-1.9.2/libmozjs.so
31a6514000-31a6713000 ---p 00114000 fd:00 4975                           /usr/lib64/xulrunner-1.9.2/libmozjs.so
31a6713000-31a671f000 rw-p 00113000 fd:00 4975                           /usr/lib64/xulrunner-1.9.2/libmozjs.so
31a6800000-31a7c59000 r-xp 00000000 fd:00 5952                           /usr/lib64/xulrunner-1.9.2/libxul.so
31a7c59000-31a7e58000 ---p 01459000 fd:00 5952                           /usr/lib64/xulrunner-1.9.2/libxul.so
31a7e58000-31a8024000 rw-p 01458000 fd:00 5952                           /usr/lib64/xulrunner-1.9.2/libxul.so
31a8024000-31a803f000 rw-p 00000000 00:00 0 
33b6400000-33b640c000 r-xp 00000000 fd:00 30387                          /usr/lib64/libgstapp-0.10.so.0.20.0
33b640c000-33b660c000 ---p 0000c000 fd:00 30387                          /usr/lib64/libgstapp-0.10.so.0.20.0
33b660c000-33b660d000 rw-p 0000c000 fd:00 30387                          /usr/lib64/libgstapp-0.10.so.0.20.0
33b6800000-33b6807000 r-xp 00000000 fd:00 30397                          /usr/lib64/libgstvideo-0.10.so.0.20.0
33b6807000-33b6a07000 ---p 00007000 fd:00 30397                          /usr/lib64/libgstvideo-0.10.so.0.20.0
33b6a07000-33b6a08000 rw-p 00007000 fd:00 30397                          /usr/lib64/libgstvideo-0.10.so.0.20.0
33b7000000-33b700d000 r-xp 00000000 fd:00 30396                          /usr/lib64/libgstpbutils-0.10.so.0.20.0
33b700d000-33b720c000 ---p 0000d000 fd:00 30396                          /usr/lib64/libgstpbutils-0.10.so.0.20.0
33b720c000-33b720e000 rw-p 0000c000 fd:00 30396                          /usr/lib64/libgstpbutils-0.10.so.0.20.0
33b7400000-33b7533000 r-xp 00000000 fd:00 5010                           /usr/lib64/libnss3.so
33b7533000-33b7732000 ---p 00133000 fd:00 5010                           /usr/lib64/libnss3.so
33b7732000-33b7739000 rw-p 00132000 fd:00 5010                           /usr/lib64/libnss3.so
33b7739000-33b773a000 rw-p 00000000 00:00 0 
33b7800000-33b7828000 r-xp 00000000 fd:00 12043                          /usr/lib64/libsmime3.so
33b7828000-33b7a27000 ---p 00028000 fd:00 12043                          /usr/lib64/libsmime3.so
33b7a27000-33b7a2b000 rw-p 00027000 fd:00 12043                          /usr/lib64/libsmime3.so
33b7c00000-33b7c32000 r-xp 00000000 fd:00 11956                          /usr/lib64/libssl3.so
33b7c32000-33b7e31000 ---p 00032000 fd:00 11956                          /usr/lib64/libssl3.so
33b7e31000-33b7e34000 rw-p 00031000 fd:00 11956                          /usr/lib64/libssl3.so
33b8000000-33b800d000 r-xp 00000000 fd:00 11933                          /lib64/libudev.so.0.6.1
33b800d000-33b820d000 ---p 0000d000 fd:00 11933                          /lib64/libudev.so.0.6.1
33b820d000-33b820e000 rw-p 0000d000 fd:00 11933                          /lib64/libudev.so.0.6.1
33b8400000-33b84d7000 r-xp 00000000 fd:00 30237                          /usr/lib64/libgstreamer-0.10.so.0.25.0
33b84d7000-33b86d7000 ---p 000d7000 fd:00 30237                          /usr/lib64/libgstreamer-0.10.so.0.25.0
33b86d7000-33b86de000 rw-p 000d7000 fd:00 30237                          /usr/lib64/libgstreamer-0.10.so.0.25.0
33b86de000-33b86e0000 rw-p 00000000 00:00 0 
33b8800000-33b889b000 r-xp 00000000 fd:00 16102                          /usr/lib64/libgnutls.so.26.14.12
33b889b000-33b8a9a000 ---p 0009b000 fd:00 16102                          /usr/lib64/libgnutls.so.26.14.12
33b8a9a000-33b8aa1000 rw-p 0009a000 fd:00 16102                          /usr/lib64/libgnutls.so.26.14.12
33b8c00000-33b8c3b000 r-xp 00000000 fd:00 30253                          /usr/lib64/libgstbase-0.10.so.0.25.0
33b8c3b000-33b8e3b000 ---p 0003b000 fd:00 30253                          /usr/lib64/libgstbase-0.10.so.0.25.0
33b8e3b000-33b8e3c000 rw-p 0003b000 fd:00 30253                          /usr/lib64/libgstbase-0.10.so.0.25.0
33b9400000-33b9454000 r-xp 00000000 fd:00 21374                          /usr/lib64/libsoup-2.4.so.1.3.0
33b9454000-33b9654000 ---p 00054000 fd:00 21374                          /usr/lib64/libsoup-2.4.so.1.3.0
33b9654000-33b9657000 rw-p 00054000 fd:00 21374                          /usr/lib64/libsoup-2.4.so.1.3.0
33b9657000-33b9658000 rw-p 00000000 00:00 0 
33ba400000-33bb565000 r-xp 00000000 fd:00 30399                          /usr/lib64/libwebkit-1.0.so.2.17.2
33bb565000-33bb764000 ---p 01165000 fd:00 30399                          /usr/lib64/libwebkit-1.0.so.2.17.2
33bb764000-33bb8b1000 rw-p 01164000 fd:00 30399                          /usr/lib64/libwebkit-1.0.so.2.17.2Abgebrochen (Speicherabzug geschrieben)
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (fedora-41.b18.fc13-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
Comment 14 Raphael Groner 2010-06-25 07:21:55 EDT
See bug #605379, maybe the solution there helps.
Comment 15 Martin Ebourne 2010-06-29 21:09:10 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Navigate to this page: http://gizmodo.com/5571171/iphone-4-loses-reception-when-you-hold-it-by-the-antenna-band
2. Close tab


Comment
-----
Crashed while closing tab the first couple of times, managed ok on about the third go.
Comment 16 Nick Mathew 2010-07-24 12:58:35 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Run midori


Comment
-----
Midorai crashes on start. Disabling extensions and resting preferences don't have an effect. It still crashes
Comment 17 Nathan Thomas 2010-07-24 16:44:47 EDT
Raphael Groner's suggestion from https://bugzilla.redhat.com/show_bug.cgi?id=605379 solved this problem for me:

<quote>Renaming /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/IcedTeaPlugin.so
helps.</quote>

Nathan
Comment 18 Raphael Groner 2010-07-25 05:59:37 EDT
(In reply to comment #17)
I would better suggest - if you do not need openjdk or java at all in the browser - to remove the package java-1.6.0-openjdk-plugin-1:1.6.0.0-41.b18.fc13 (previous comment from Paweł Forysiuk).

An alternative is to install Sun's (or Oracle's) JVM. I have not tested it by myself but read about success story.

If you remove (or rename) only the mentioned .so file, I guess that an update to the package would reinstall this file. I consider the renaming only as a quick and dirty fix.
Comment 19 tomoya tabuchi 2010-07-28 01:06:31 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Start midori
2.That's all
3.


Comment
-----
I started midori on my computer.
The instant the window came out it disappeared.
Comment 20 tomoya tabuchi 2010-07-28 02:17:13 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Start midori
2.That's all
3.


Comment
-----
I started midori on my computer.
The instant the window came out it disappeared.
Comment 21 Andy 2010-08-11 05:07:43 EDT
Package: midori-0.2.6-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Expoted bookmarks with chromium
2.wanted to open these with midori
Comment 22 Dominic Hopf 2010-08-12 15:30:43 EDT
I can fully reproduce this issue here. Having the openjdk browser plugin installed makes midori crash. Removing it via yum solves the issue. I actually do not need java in my browser anyway, but I believe it's the  openjdk plugin which causes the crash, not midori. This is just my thought, I do not have any technical reasoning for that.
Comment 23 Raphael Groner 2010-08-14 04:10:30 EDT
It seems fixed with current java-1.6.0-openjdk-plugin-1.6.0.0-42.b18.fc13.x86_64.
Comment 24 Raphael Groner 2010-08-14 04:15:50 EDT
*** Bug 610335 has been marked as a duplicate of this bug. ***
Comment 25 Kevin Fenzi 2010-08-28 19:41:46 EDT
*** Bug 597957 has been marked as a duplicate of this bug. ***
Comment 26 Kevin Fenzi 2010-08-28 19:43:27 EDT
*** Bug 603884 has been marked as a duplicate of this bug. ***
Comment 27 Kevin Fenzi 2010-08-28 19:43:46 EDT
*** Bug 603978 has been marked as a duplicate of this bug. ***
Comment 28 Kevin Fenzi 2010-08-28 19:44:04 EDT
*** Bug 604469 has been marked as a duplicate of this bug. ***
Comment 29 Kevin Fenzi 2010-08-28 19:45:03 EDT
*** Bug 605208 has been marked as a duplicate of this bug. ***
Comment 30 Kevin Fenzi 2010-08-28 19:45:36 EDT
*** Bug 605379 has been marked as a duplicate of this bug. ***
Comment 31 Kevin Fenzi 2010-08-28 19:46:24 EDT
*** Bug 605439 has been marked as a duplicate of this bug. ***
Comment 32 Kevin Fenzi 2010-08-28 19:47:32 EDT
*** Bug 607320 has been marked as a duplicate of this bug. ***
Comment 33 Kevin Fenzi 2010-08-28 19:49:04 EDT
*** Bug 608766 has been marked as a duplicate of this bug. ***
Comment 34 Kevin Fenzi 2010-08-28 19:49:52 EDT
*** Bug 608924 has been marked as a duplicate of this bug. ***
Comment 35 Kevin Fenzi 2010-08-28 19:51:01 EDT
*** Bug 609396 has been marked as a duplicate of this bug. ***
Comment 36 Kevin Fenzi 2010-08-28 19:53:17 EDT
*** Bug 610065 has been marked as a duplicate of this bug. ***
Comment 37 Kevin Fenzi 2010-08-28 19:54:48 EDT
*** Bug 611791 has been marked as a duplicate of this bug. ***
Comment 38 Kevin Fenzi 2010-08-28 19:56:08 EDT
*** Bug 617848 has been marked as a duplicate of this bug. ***
Comment 39 Kevin Fenzi 2010-08-28 19:57:09 EDT
*** Bug 620335 has been marked as a duplicate of this bug. ***
Comment 40 Kevin Fenzi 2010-08-28 19:59:29 EDT
*** Bug 622035 has been marked as a duplicate of this bug. ***
Comment 41 Kevin Fenzi 2010-08-28 20:00:05 EDT
*** Bug 622104 has been marked as a duplicate of this bug. ***
Comment 42 Kevin Fenzi 2010-08-28 20:00:49 EDT
*** Bug 622144 has been marked as a duplicate of this bug. ***
Comment 43 Kevin Fenzi 2010-08-28 20:01:27 EDT
*** Bug 623031 has been marked as a duplicate of this bug. ***
Comment 44 Kevin Fenzi 2010-08-28 20:04:00 EDT
This should be fixed in the latest java plugin. 

Can everyone who is seeing this please update to that version and confirm?

If it's not, can you try removing the java plugin and see if the crashes go away?
Comment 45 Kevin Fenzi 2010-08-28 20:06:29 EDT
*** Bug 589787 has been marked as a duplicate of this bug. ***
Comment 46 Kevin Fenzi 2010-08-28 20:09:23 EDT
*** Bug 605614 has been marked as a duplicate of this bug. ***
Comment 47 Kevin Fenzi 2010-08-29 15:32:18 EDT
*** Bug 609535 has been marked as a duplicate of this bug. ***
Comment 48 Matthias Runge 2010-08-30 06:30:24 EDT
currently, midori works for me. I could swear, I had plugins disabled, but I can not reproduce the bug at the moment, wether with plugins enabled or disabled.

midori-0.2.6-1.fc13.i686
java-1.6.0-openjdk-plugin-1.6.0.0-42.b18.fc13.i686

Thank you!
Comment 49 Honza 2010-08-30 14:41:42 EDT
midori is working again.
Thank you for our help.
Honza
Comment 50 wmak.othermail 2010-08-30 20:54:52 EDT
Midori is working on my end as well. No changes made, so one of the updates must have fixed it. Thanks Kevin and team.
Comment 51 Noura El hawary 2010-09-02 10:02:15 EDT
test comment please ignore
Comment 52 Dominic Hopf 2010-12-11 17:52:52 EST
This issue is fixed for me since a few weeks. Sorry for my late reply on this issue. I have java-1.6.0-openjdk-plugin-1.6.0.0-49.1.9.3.fc14.x86_64 installed now.
Comment 53 Fedora Admin XMLRPC Client 2011-03-15 13:20:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 54 Kevin Fenzi 2011-03-27 14:10:30 EDT
This seems fixed now, so closing. 

Feel free to re-open if needed.

Note You need to log in before you can comment on or make changes to this bug.