Bug 611580 - [abrt] crash in gnome-settings-daemon when changing colors (SIGSEGV)
[abrt] crash in gnome-settings-daemon when changing colors (SIGSEGV)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libgnomekbd (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:53439533116f11de2ebc63ca8cc...
: Patch, Triaged
: 587951 592158 593053 596512 596675 596756 596958 597109 597478 597494 597563 597738 597882 598093 598096 598149 598190 598366 598954 599231 599234 599238 599239 599244 599312 599462 599909 600128 600234 600908 601331 601368 601710 602203 602433 602743 603555 603689 603816 603822 605511 605680 605684 606225 606300 607160 607614 607933 607993 608324 608337 609013 609219 609259 609709 610468 611003 611103 611439 611460 611463 611525 611853 612356 612827 613060 613199 613378 613381 613382 613385 613418 613421 613783 613932 613961 614115 614179 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 15:01 EDT by Alexander
Modified: 2018-04-11 04:27 EDT (History)
55 users (show)

See Also:
Fixed In Version: libgnomekbd-2.30.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 17:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.91 KB, text/plain)
2010-07-05 15:01 EDT, Alexander
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 618727 None None None Never

  None (edit)
Description Alexander 2010-07-05 15:01:24 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/gnome-settings-daemon
component: gnome-settings-daemon
crash_function: gkbd_indicator_config_load_font
executable: /usr/libexec/gnome-settings-daemon
global_uuid: 53439533116f11de2ebc63ca8ccfce57bd4d4feb
kernel: 2.6.33.5-124.fc13.x86_64
package: gnome-settings-daemon-2.30.1-7.fc13
rating: 4
reason: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. reboot after install updates
2. login
3. ???
4. PROFIT!!!
Comment 1 Alexander 2010-07-05 15:01:27 EDT
Created attachment 429587 [details]
File: backtrace
Comment 2 Igor Katalnikov 2010-07-11 03:59:20 EDT
Package: gnome-settings-daemon-2.30.1-7.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. unknown
2.
3.
Comment 3 Thomas Dall'Agnese 2010-07-13 07:21:38 EDT
Package: gnome-settings-daemon-2.30.1-7.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
no idea
Comment 4 Michal Schmidt 2010-07-13 16:39:22 EDT
Package: gnome-settings-daemon-2.30.1-7.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. launch gnome-appearance-properties
2. Go to Theme -> Customize... -> Colors
3. Change the windows background color.
4. For some reason the change does not take effect immediately, so close it and run gnome-appearance-properties again.
5. For a moment you can see the new color taking effects and then immediately revert to the previous color. The crash is now reported by abrt.


Comment
-----
Trying to change the window background color. It is reproducible.
Note this is F-13 system, only the kernel is from F-14.
Comment 5 Michal Schmidt 2010-07-13 16:46:41 EDT
Looks like this upstream bug (has a patch):
https://bugzilla.gnome.org/show_bug.cgi?id=618727
Comment 6 Michal Schmidt 2010-07-13 17:19:44 EDT
I tested a local build of libgnomekbd with the patch applied and it fixed the bug.
Comment 7 Michal Schmidt 2010-07-13 17:23:01 EDT
*** Bug 592158 has been marked as a duplicate of this bug. ***
Comment 8 Michal Schmidt 2010-07-13 17:54:53 EDT
Note that to reproduce the crash, one must have more than one keyboard layout in gnome-keyboard-properties as it's the layout indicator that's crashing during the style change.

Also note that gnome-settings-daemon currently has 131 NEW/ASSIGNED bugs in F-13. Of those, 75 have an attachment containing the word "gkbd_indicator_config_load_font"...
Comment 9 Matěj Cepl 2010-07-13 18:10:31 EDT
*** Bug 587951 has been marked as a duplicate of this bug. ***
Comment 10 Matěj Cepl 2010-07-13 18:10:31 EDT
*** Bug 596756 has been marked as a duplicate of this bug. ***
Comment 11 Matěj Cepl 2010-07-13 18:10:31 EDT
*** Bug 593053 has been marked as a duplicate of this bug. ***
Comment 12 Matěj Cepl 2010-07-13 18:10:31 EDT
*** Bug 597109 has been marked as a duplicate of this bug. ***
Comment 13 Matěj Cepl 2010-07-13 18:10:31 EDT
*** Bug 596512 has been marked as a duplicate of this bug. ***
Comment 14 Matěj Cepl 2010-07-13 18:10:32 EDT
*** Bug 596958 has been marked as a duplicate of this bug. ***
Comment 15 Matěj Cepl 2010-07-13 18:10:34 EDT
*** Bug 597494 has been marked as a duplicate of this bug. ***
Comment 16 Matěj Cepl 2010-07-13 18:10:34 EDT
*** Bug 597478 has been marked as a duplicate of this bug. ***
Comment 17 Matěj Cepl 2010-07-13 18:10:34 EDT
*** Bug 597563 has been marked as a duplicate of this bug. ***
Comment 18 Matěj Cepl 2010-07-13 18:10:34 EDT
*** Bug 597738 has been marked as a duplicate of this bug. ***
Comment 19 Matěj Cepl 2010-07-13 18:10:34 EDT
*** Bug 597882 has been marked as a duplicate of this bug. ***
Comment 20 Matěj Cepl 2010-07-13 18:10:35 EDT
*** Bug 598093 has been marked as a duplicate of this bug. ***
Comment 21 Matěj Cepl 2010-07-13 18:10:36 EDT
*** Bug 598096 has been marked as a duplicate of this bug. ***
Comment 22 Matěj Cepl 2010-07-13 18:10:36 EDT
*** Bug 598149 has been marked as a duplicate of this bug. ***
Comment 23 Matěj Cepl 2010-07-13 18:10:37 EDT
*** Bug 598190 has been marked as a duplicate of this bug. ***
Comment 24 Matěj Cepl 2010-07-13 18:10:37 EDT
*** Bug 598366 has been marked as a duplicate of this bug. ***
Comment 25 Matěj Cepl 2010-07-13 18:10:38 EDT
*** Bug 598954 has been marked as a duplicate of this bug. ***
Comment 26 Matěj Cepl 2010-07-13 18:10:38 EDT
*** Bug 599231 has been marked as a duplicate of this bug. ***
Comment 27 Matěj Cepl 2010-07-13 18:10:39 EDT
*** Bug 599234 has been marked as a duplicate of this bug. ***
Comment 28 Matěj Cepl 2010-07-13 18:10:39 EDT
*** Bug 599238 has been marked as a duplicate of this bug. ***
Comment 29 Matěj Cepl 2010-07-13 18:10:39 EDT
*** Bug 599239 has been marked as a duplicate of this bug. ***
Comment 30 Matěj Cepl 2010-07-13 18:10:40 EDT
*** Bug 599462 has been marked as a duplicate of this bug. ***
Comment 31 Matěj Cepl 2010-07-13 18:10:41 EDT
*** Bug 599244 has been marked as a duplicate of this bug. ***
Comment 32 Matěj Cepl 2010-07-13 18:10:41 EDT
*** Bug 599312 has been marked as a duplicate of this bug. ***
Comment 33 Matěj Cepl 2010-07-13 18:10:41 EDT
*** Bug 599909 has been marked as a duplicate of this bug. ***
Comment 34 Matěj Cepl 2010-07-13 18:10:42 EDT
*** Bug 600234 has been marked as a duplicate of this bug. ***
Comment 35 Matěj Cepl 2010-07-13 18:10:42 EDT
*** Bug 600128 has been marked as a duplicate of this bug. ***
Comment 36 Matěj Cepl 2010-07-13 18:10:42 EDT
*** Bug 600908 has been marked as a duplicate of this bug. ***
Comment 37 Matěj Cepl 2010-07-13 18:10:43 EDT
*** Bug 601331 has been marked as a duplicate of this bug. ***
Comment 38 Matěj Cepl 2010-07-13 18:10:43 EDT
*** Bug 601368 has been marked as a duplicate of this bug. ***
Comment 39 Matěj Cepl 2010-07-13 18:10:44 EDT
*** Bug 601710 has been marked as a duplicate of this bug. ***
Comment 40 Matěj Cepl 2010-07-13 18:10:44 EDT
*** Bug 602203 has been marked as a duplicate of this bug. ***
Comment 41 Matěj Cepl 2010-07-13 18:10:45 EDT
*** Bug 602433 has been marked as a duplicate of this bug. ***
Comment 42 Matěj Cepl 2010-07-13 18:10:45 EDT
*** Bug 603555 has been marked as a duplicate of this bug. ***
Comment 43 Matěj Cepl 2010-07-13 18:10:45 EDT
*** Bug 603689 has been marked as a duplicate of this bug. ***
Comment 44 Matěj Cepl 2010-07-13 18:10:47 EDT
*** Bug 605511 has been marked as a duplicate of this bug. ***
Comment 45 Matěj Cepl 2010-07-13 18:10:47 EDT
*** Bug 603816 has been marked as a duplicate of this bug. ***
Comment 46 Matěj Cepl 2010-07-13 18:10:47 EDT
*** Bug 603822 has been marked as a duplicate of this bug. ***
Comment 47 Matěj Cepl 2010-07-13 18:10:48 EDT
*** Bug 602743 has been marked as a duplicate of this bug. ***
Comment 48 Matěj Cepl 2010-07-13 18:10:48 EDT
*** Bug 605684 has been marked as a duplicate of this bug. ***
Comment 49 Matěj Cepl 2010-07-13 18:10:49 EDT
*** Bug 606225 has been marked as a duplicate of this bug. ***
Comment 50 Matěj Cepl 2010-07-13 18:10:50 EDT
*** Bug 606300 has been marked as a duplicate of this bug. ***
Comment 51 Matěj Cepl 2010-07-13 18:10:50 EDT
*** Bug 607160 has been marked as a duplicate of this bug. ***
Comment 52 Matěj Cepl 2010-07-13 18:10:50 EDT
*** Bug 607614 has been marked as a duplicate of this bug. ***
Comment 53 Matěj Cepl 2010-07-13 18:10:50 EDT
*** Bug 607933 has been marked as a duplicate of this bug. ***
Comment 54 Matěj Cepl 2010-07-13 18:10:51 EDT
*** Bug 605680 has been marked as a duplicate of this bug. ***
Comment 55 Matěj Cepl 2010-07-13 18:10:52 EDT
*** Bug 607993 has been marked as a duplicate of this bug. ***
Comment 56 Matěj Cepl 2010-07-13 18:10:52 EDT
*** Bug 608324 has been marked as a duplicate of this bug. ***
Comment 57 Matěj Cepl 2010-07-13 18:10:53 EDT
*** Bug 609013 has been marked as a duplicate of this bug. ***
Comment 58 Matěj Cepl 2010-07-13 18:10:53 EDT
*** Bug 609219 has been marked as a duplicate of this bug. ***
Comment 59 Matěj Cepl 2010-07-13 18:10:53 EDT
*** Bug 609259 has been marked as a duplicate of this bug. ***
Comment 60 Matěj Cepl 2010-07-13 18:10:53 EDT
*** Bug 608337 has been marked as a duplicate of this bug. ***
Comment 61 Matěj Cepl 2010-07-13 18:10:54 EDT
*** Bug 609709 has been marked as a duplicate of this bug. ***
Comment 62 Matěj Cepl 2010-07-13 18:10:56 EDT
*** Bug 610468 has been marked as a duplicate of this bug. ***
Comment 63 Matěj Cepl 2010-07-13 18:10:56 EDT
*** Bug 611103 has been marked as a duplicate of this bug. ***
Comment 64 Matěj Cepl 2010-07-13 18:10:56 EDT
*** Bug 611003 has been marked as a duplicate of this bug. ***
Comment 65 Matěj Cepl 2010-07-13 18:10:56 EDT
*** Bug 611439 has been marked as a duplicate of this bug. ***
Comment 66 Matěj Cepl 2010-07-13 18:10:56 EDT
*** Bug 611460 has been marked as a duplicate of this bug. ***
Comment 67 Matěj Cepl 2010-07-13 18:10:57 EDT
*** Bug 611463 has been marked as a duplicate of this bug. ***
Comment 68 Matěj Cepl 2010-07-13 18:10:58 EDT
*** Bug 611525 has been marked as a duplicate of this bug. ***
Comment 69 Matěj Cepl 2010-07-13 18:10:58 EDT
*** Bug 611853 has been marked as a duplicate of this bug. ***
Comment 70 Matěj Cepl 2010-07-13 18:10:58 EDT
*** Bug 612356 has been marked as a duplicate of this bug. ***
Comment 71 Matěj Cepl 2010-07-13 18:10:59 EDT
*** Bug 612827 has been marked as a duplicate of this bug. ***
Comment 72 Matěj Cepl 2010-07-13 18:10:59 EDT
*** Bug 613199 has been marked as a duplicate of this bug. ***
Comment 73 Matěj Cepl 2010-07-13 18:11:01 EDT
*** Bug 613378 has been marked as a duplicate of this bug. ***
Comment 74 Matěj Cepl 2010-07-13 18:11:01 EDT
*** Bug 613381 has been marked as a duplicate of this bug. ***
Comment 75 Matěj Cepl 2010-07-13 18:11:01 EDT
*** Bug 613382 has been marked as a duplicate of this bug. ***
Comment 76 Matěj Cepl 2010-07-13 18:11:02 EDT
*** Bug 613385 has been marked as a duplicate of this bug. ***
Comment 77 Matěj Cepl 2010-07-13 18:11:02 EDT
*** Bug 613418 has been marked as a duplicate of this bug. ***
Comment 78 Matěj Cepl 2010-07-13 18:11:02 EDT
*** Bug 613060 has been marked as a duplicate of this bug. ***
Comment 79 Matěj Cepl 2010-07-13 18:11:04 EDT
*** Bug 613932 has been marked as a duplicate of this bug. ***
Comment 80 Matěj Cepl 2010-07-13 18:11:04 EDT
*** Bug 614115 has been marked as a duplicate of this bug. ***
Comment 81 Matěj Cepl 2010-07-13 18:11:05 EDT
*** Bug 613783 has been marked as a duplicate of this bug. ***
Comment 82 Matěj Cepl 2010-07-13 18:11:05 EDT
*** Bug 613421 has been marked as a duplicate of this bug. ***
Comment 83 Michal Schmidt 2010-07-13 18:18:00 EDT
*** Bug 613961 has been marked as a duplicate of this bug. ***
Comment 84 Michal Schmidt 2010-07-13 18:46:42 EDT
*** Bug 614179 has been marked as a duplicate of this bug. ***
Comment 85 Michal Schmidt 2010-07-14 09:12:56 EDT
Here's a scratch build of libgnomekbd-2.30.2 + the patch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2318882
For me it works.
Comment 86 Matthias Clasen 2010-07-14 11:00:13 EDT
thanks, I have build the same here: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2319142

but I don't have an F13 install to test it with atm.
can you give it a try ? if I get some confirmation that this fixes the problem and doesn't cause new ones, I'll put it in updates-testing.
Comment 87 Michal Schmidt 2010-07-14 11:41:34 EDT
Your build works fine too. No crashes when changing colors. Keyboard layout switching still works.
Comment 88 Fedora Update System 2010-07-14 12:16:31 EDT
libgnomekbd-2.30.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libgnomekbd-2.30.2-1.fc13
Comment 89 Michal Schmidt 2010-07-14 19:05:40 EDT
*** Bug 596675 has been marked as a duplicate of this bug. ***
Comment 90 Fedora Update System 2010-07-14 19:08:09 EDT
libgnomekbd-2.30.2-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libgnomekbd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libgnomekbd-2.30.2-1.fc13
Comment 91 Fedora Update System 2010-07-15 17:02:23 EDT
libgnomekbd-2.30.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.