Bug 877464

Summary: BUG: triggered 'if (priv->num_active_touches > priv->num_slots)'
Product: [Fedora] Fedora Reporter: Frank <lamborghini518>
Component: xorg-x11-drv-synapticsAssignee: Peter Hutterer <peter.hutterer>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: admin, akurtako, alexisbuckens, andreitroie, andrejoh, andre.massing, anprice, belardinellius, boats.muse, danielecoccato, danielsun3164, david, digimer, djuran, dudko, echron, eharney, elia.schneide, elias.johan.liavaag, fred_weigel, gdurandv, grubba, hazlan, igre117, ipaitoo, james, jean-baptiste, jitenmt, jorgerev90, jvnico, kazade, kazuno.shiranui, kgarrison343, krnlbg, k.soze, kurtneuber, kvolny, kzmuhia, lexy.valentina24, loftus.ronan, lso, lyn240690234, mbetak, mitr, msalter, office, ohadlevy, peter.hutterer, peter_snygg, rafaelmajano, redhat, robert.keersse, sapunidze, sastill, sergio, sergisvarda, steevithak, striker.pena, tadej.j, wsmithril, xgl-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:d1ee9383e0e8673ae7aa21785cad4a58a378def3
Fixed In Version: xorg-x11-drv-synaptics-1.7.4-4.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-04-02 05:11:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: executable
none
File: etc_X11_xorg_conf_d.tar.gz
none
File: backtrace_binaries_versions
none
File: usr_share_xorg_conf_d.tar.gz
none
File: dmesg
none
File: Xorg.0.log
none
Xorg.log with traceback none

Description Frank 2012-11-16 10:38:04 EST
Description of problem:
logged into computer

Version-Release number of selected component:
xorg-x11-server-Xorg-1.12.3-2.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
kernel:         3.6.6-1.fc17.x86_64

backtrace:
:0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x4652d6]
:1: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f8d4df82000+0x2e77) [0x7f8d4df84e77]
:2: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f8d4df82000+0x4563) [0x7f8d4df86563]
:3: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f8d4df82000+0x6fa4) [0x7f8d4df88fa4]
:4: /usr/bin/Xorg (0x400000+0x807b7) [0x4807b7]
:5: /usr/bin/Xorg (0x400000+0xa4ab0) [0x4a4ab0]
:6: /lib64/libpthread.so.0 (0x329a600000+0xefe0) [0x329a60efe0]
:7: /lib64/libc.so.6 (ioctl+0x7) [0x329a2ea2f7]
:8: /lib64/libdrm.so.2 (drmIoctl+0x28) [0x3fa0803658]
:9: /lib64/libdrm.so.2 (drmModeGetProperty+0x51) [0x3fa08073e1]
:10: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f8d51a3a000+0x27c17) [0x7f8d51a61c17]
:11: /usr/bin/Xorg (xf86DPMSSet+0xa9) [0x4b23a9]
:12: /usr/bin/Xorg (DPMSSet+0x100) [0x480570]
:13: /usr/bin/Xorg (xf86Wakeup+0x667) [0x481447]
:14: /usr/bin/Xorg (WakeupHandler+0x6b) [0x4383bb]
:15: /usr/bin/Xorg (WaitForSomething+0x1a4) [0x462864]
:16: /usr/bin/Xorg (0x400000+0x34141) [0x434141]
:17: /usr/bin/Xorg (0x400000+0x23485) [0x423485]
:18: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x329a221735]
:19: /usr/bin/Xorg (0x400000+0x2375d) [0x42375d]
Comment 1 Frank 2012-11-16 10:38:07 EST
Created attachment 646411 [details]
File: executable
Comment 2 Frank 2012-11-16 10:38:08 EST
Created attachment 646412 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 3 Frank 2012-11-16 10:38:11 EST
Created attachment 646413 [details]
File: backtrace_binaries_versions
Comment 4 Frank 2012-11-16 10:38:12 EST
Created attachment 646414 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 5 Frank 2012-11-16 10:38:14 EST
Created attachment 646415 [details]
File: dmesg
Comment 6 Frank 2012-11-16 10:38:17 EST
Created attachment 646416 [details]
File: Xorg.0.log
Comment 7 Frank 2012-11-16 10:38:21 EST
logged into computer

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Adam Jackson 2012-11-16 17:18:27 EST
*** Bug 876814 has been marked as a duplicate of this bug. ***
Comment 9 Adam Jackson 2012-11-16 17:18:32 EST
*** Bug 876653 has been marked as a duplicate of this bug. ***
Comment 10 Adam Jackson 2012-11-16 17:18:38 EST
*** Bug 876285 has been marked as a duplicate of this bug. ***
Comment 11 Adam Jackson 2012-11-16 17:18:44 EST
*** Bug 876004 has been marked as a duplicate of this bug. ***
Comment 12 Adam Jackson 2012-11-16 17:18:50 EST
*** Bug 876003 has been marked as a duplicate of this bug. ***
Comment 13 Adam Jackson 2012-11-16 17:18:54 EST
*** Bug 876002 has been marked as a duplicate of this bug. ***
Comment 14 Adam Jackson 2012-11-16 17:19:28 EST
*** Bug 875176 has been marked as a duplicate of this bug. ***
Comment 15 Steevithak 2012-11-18 00:49:53 EST
another X.Org crash

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 16 Steevithak 2012-11-18 00:53:10 EST
Another X.Org crash

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Adam Jackson 2012-11-28 15:06:32 EST
*** Bug 861825 has been marked as a duplicate of this bug. ***
Comment 18 Adam Jackson 2012-11-28 15:06:36 EST
*** Bug 862497 has been marked as a duplicate of this bug. ***
Comment 19 Adam Jackson 2012-11-28 15:06:39 EST
*** Bug 868517 has been marked as a duplicate of this bug. ***
Comment 20 Adam Jackson 2012-11-28 15:06:42 EST
*** Bug 868552 has been marked as a duplicate of this bug. ***
Comment 21 Adam Jackson 2012-11-28 15:06:45 EST
*** Bug 868553 has been marked as a duplicate of this bug. ***
Comment 22 Adam Jackson 2012-11-28 15:06:48 EST
*** Bug 868555 has been marked as a duplicate of this bug. ***
Comment 23 Adam Jackson 2012-11-28 15:06:51 EST
*** Bug 868557 has been marked as a duplicate of this bug. ***
Comment 24 Adam Jackson 2012-11-28 15:06:54 EST
*** Bug 868769 has been marked as a duplicate of this bug. ***
Comment 25 Adam Jackson 2012-11-28 15:06:57 EST
*** Bug 869788 has been marked as a duplicate of this bug. ***
Comment 26 Adam Jackson 2012-11-28 15:07:00 EST
*** Bug 869828 has been marked as a duplicate of this bug. ***
Comment 27 Adam Jackson 2012-11-28 15:07:04 EST
*** Bug 869829 has been marked as a duplicate of this bug. ***
Comment 28 Adam Jackson 2012-11-28 15:07:08 EST
*** Bug 869883 has been marked as a duplicate of this bug. ***
Comment 29 Adam Jackson 2012-11-28 15:07:11 EST
*** Bug 869884 has been marked as a duplicate of this bug. ***
Comment 30 Adam Jackson 2012-11-28 15:07:15 EST
*** Bug 870417 has been marked as a duplicate of this bug. ***
Comment 31 Adam Jackson 2012-11-28 15:07:19 EST
*** Bug 870727 has been marked as a duplicate of this bug. ***
Comment 32 Adam Jackson 2012-11-28 15:07:23 EST
*** Bug 870809 has been marked as a duplicate of this bug. ***
Comment 33 Adam Jackson 2012-11-28 15:07:28 EST
*** Bug 870810 has been marked as a duplicate of this bug. ***
Comment 34 Adam Jackson 2012-11-28 15:07:32 EST
*** Bug 870874 has been marked as a duplicate of this bug. ***
Comment 35 Adam Jackson 2012-11-28 15:07:35 EST
*** Bug 870875 has been marked as a duplicate of this bug. ***
Comment 36 Adam Jackson 2012-11-28 15:07:40 EST
*** Bug 871181 has been marked as a duplicate of this bug. ***
Comment 37 Adam Jackson 2012-11-28 15:07:44 EST
*** Bug 871668 has been marked as a duplicate of this bug. ***
Comment 38 Adam Jackson 2012-11-28 15:07:48 EST
*** Bug 871951 has been marked as a duplicate of this bug. ***
Comment 39 Adam Jackson 2012-11-28 15:07:52 EST
*** Bug 872323 has been marked as a duplicate of this bug. ***
Comment 40 Adam Jackson 2012-11-28 15:07:56 EST
*** Bug 872394 has been marked as a duplicate of this bug. ***
Comment 41 Adam Jackson 2012-11-28 15:08:00 EST
*** Bug 872396 has been marked as a duplicate of this bug. ***
Comment 42 Adam Jackson 2012-11-28 15:08:04 EST
*** Bug 872400 has been marked as a duplicate of this bug. ***
Comment 43 Adam Jackson 2012-11-28 15:08:08 EST
*** Bug 872901 has been marked as a duplicate of this bug. ***
Comment 44 Adam Jackson 2012-11-28 15:08:11 EST
*** Bug 873006 has been marked as a duplicate of this bug. ***
Comment 45 Adam Jackson 2012-11-28 15:08:15 EST
*** Bug 873010 has been marked as a duplicate of this bug. ***
Comment 46 Adam Jackson 2012-11-28 15:08:18 EST
*** Bug 873018 has been marked as a duplicate of this bug. ***
Comment 47 Adam Jackson 2012-11-28 15:08:21 EST
*** Bug 873020 has been marked as a duplicate of this bug. ***
Comment 48 Adam Jackson 2012-11-28 15:08:25 EST
*** Bug 873021 has been marked as a duplicate of this bug. ***
Comment 49 Adam Jackson 2012-11-28 15:08:28 EST
*** Bug 873022 has been marked as a duplicate of this bug. ***
Comment 50 Adam Jackson 2012-11-28 15:08:31 EST
*** Bug 873023 has been marked as a duplicate of this bug. ***
Comment 51 Adam Jackson 2012-11-28 15:08:40 EST
*** Bug 873033 has been marked as a duplicate of this bug. ***
Comment 52 Adam Jackson 2012-11-28 15:08:44 EST
*** Bug 873068 has been marked as a duplicate of this bug. ***
Comment 53 Adam Jackson 2012-11-28 15:08:48 EST
*** Bug 873124 has been marked as a duplicate of this bug. ***
Comment 54 Adam Jackson 2012-11-28 15:08:52 EST
*** Bug 873901 has been marked as a duplicate of this bug. ***
Comment 55 Adam Jackson 2012-11-28 15:08:57 EST
*** Bug 874461 has been marked as a duplicate of this bug. ***
Comment 56 Adam Jackson 2012-11-28 15:09:01 EST
*** Bug 874463 has been marked as a duplicate of this bug. ***
Comment 57 Adam Jackson 2012-11-28 15:09:07 EST
*** Bug 874478 has been marked as a duplicate of this bug. ***
Comment 58 Adam Jackson 2012-11-28 15:09:13 EST
*** Bug 874544 has been marked as a duplicate of this bug. ***
Comment 59 Adam Jackson 2012-11-28 15:09:23 EST
*** Bug 874588 has been marked as a duplicate of this bug. ***
Comment 60 Adam Jackson 2012-11-28 15:09:35 EST
*** Bug 875168 has been marked as a duplicate of this bug. ***
Comment 61 Adam Jackson 2012-11-28 15:09:39 EST
*** Bug 875171 has been marked as a duplicate of this bug. ***
Comment 62 Adam Jackson 2012-11-28 15:09:47 EST
*** Bug 875172 has been marked as a duplicate of this bug. ***
Comment 63 Adam Jackson 2012-11-28 15:09:53 EST
*** Bug 875174 has been marked as a duplicate of this bug. ***
Comment 64 Adam Jackson 2012-11-28 15:10:27 EST
*** Bug 875997 has been marked as a duplicate of this bug. ***
Comment 65 Adam Jackson 2012-11-28 15:10:32 EST
*** Bug 876000 has been marked as a duplicate of this bug. ***
Comment 66 Adam Jackson 2012-11-28 15:10:39 EST
*** Bug 876001 has been marked as a duplicate of this bug. ***
Comment 67 Adam Jackson 2012-11-28 15:10:43 EST
*** Bug 877595 has been marked as a duplicate of this bug. ***
Comment 68 Adam Jackson 2012-11-28 15:10:48 EST
*** Bug 878510 has been marked as a duplicate of this bug. ***
Comment 69 Adam Jackson 2012-11-28 15:10:52 EST
*** Bug 878898 has been marked as a duplicate of this bug. ***
Comment 70 Adam Jackson 2012-11-28 15:10:55 EST
*** Bug 879496 has been marked as a duplicate of this bug. ***
Comment 71 Adam Jackson 2012-11-28 15:11:01 EST
*** Bug 879775 has been marked as a duplicate of this bug. ***
Comment 72 Adam Jackson 2012-11-28 15:11:06 EST
*** Bug 879992 has been marked as a duplicate of this bug. ***
Comment 73 Adam Jackson 2012-11-28 15:11:13 EST
*** Bug 879994 has been marked as a duplicate of this bug. ***
Comment 74 Adam Jackson 2012-11-28 15:11:17 EST
*** Bug 879995 has been marked as a duplicate of this bug. ***
Comment 75 Adam Jackson 2012-11-28 15:11:21 EST
*** Bug 880281 has been marked as a duplicate of this bug. ***
Comment 76 Adam Jackson 2012-11-28 15:11:26 EST
*** Bug 880895 has been marked as a duplicate of this bug. ***
Comment 77 Adam Jackson 2012-11-28 15:41:30 EST
*** Bug 881396 has been marked as a duplicate of this bug. ***
Comment 78 Adam Jackson 2012-11-29 12:06:00 EST
*** Bug 881483 has been marked as a duplicate of this bug. ***
Comment 79 Peter Hutterer 2012-11-29 23:01:33 EST
Anyone with a reproducible test case for this?
Comment 80 belardinellius 2012-12-06 04:57:15 EST
closed and opened the lid

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 81 Steevithak 2012-12-07 23:00:01 EST
another X.Org crash

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 82 David Leon 2012-12-16 13:07:10 EST
I have no idea as the laptop was left alone overnight.

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 83 Steevithak 2012-12-18 11:28:06 EST
Another X.Org crash

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 84 Tadej Janež 2012-12-21 04:55:46 EST
I connected a projector via laptop's VGA interface and then disconnected it. Subsequently, ABRT reported an xserver crash. My X session was not disrupted, however.

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 85 Tadej Janež 2012-12-21 05:01:44 EST
I had four "almost the same" ABRT crash reports for this bug.

Unfortunately, I don't know how to reproduce it.
Comment 86 WsMithril 2013-01-04 21:02:29 EST
Same thing happens here with an *SAME* backtrace.

Going through Xorg.0.log, I found this:
[ 39757.642] BUG: triggered 'if (priv->num_active_touches > priv->num_slots)'
[ 39757.642] BUG: synaptics.c:3122 in UpdateTouchState()
[ 39757.643] 
[ 39757.643] Backtrace:
[ 39757.643] 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x465326]
[ 39757.643] 1: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f96e1f15000+0x2e77) [0x7f96e1f17e77]
[ 39757.643] 2: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f96e1f15000+0x4563) [0x7f96e1f19563]
[ 39757.643] 3: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f96e1f15000+0x6fa4) [0x7f96e1f1bfa4]
[ 39757.643] 4: /usr/bin/Xorg (0x400000+0x80817) [0x480817]
[ 39757.643] 5: /usr/bin/Xorg (0x400000+0xa4b00) [0x4a4b00]
[ 39757.643] 6: /lib64/libpthread.so.0 (0x334e600000+0xefe0) [0x334e60efe0]
[ 39757.643] 7: /lib64/libc.so.6 (sigprocmask+0x10) [0x334e235bf0]
[ 39757.643] 8: /usr/bin/Xorg (WaitForSomething+0x52b) [0x462c3b]
[ 39757.643] 9: /usr/bin/Xorg (0x400000+0x34131) [0x434131]
[ 39757.644] 10: /usr/bin/Xorg (0x400000+0x23475) [0x423475]
[ 39757.644] 11: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x334e221735]
[ 39757.644] 12: /usr/bin/Xorg (0x400000+0x2374d) [0x42374d]

I can reproduce this crash by simply closing the lid. Then Xorg will crash in 5 min for sure, which is quite annoying.

Package:
xorg-x11-drv-synaptics-1.6.2-2.fc17.x86_64
xorg-x11-server-Xorg-1.12.4-2.fc17.x86_64
OS Release: Fedora 17
Comment 87 Peter Hutterer 2013-01-14 20:14:38 EST
I need you to record the events coming from the touchpad. There must be something in the event sequence that matters. Install evemu and then record the touchpad device until it crashes, attach the recording here.

http://people.freedesktop.org/~whot/evemu/
Comment 88 Peter Hutterer 2013-01-14 23:50:02 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=4869553 has a scratch build of the F18 package build for F17. please test that, just in case some unrelated fix upstream fixed this issue.
Comment 89 Bojan Smojver 2013-01-16 07:03:02 EST
(In reply to comment #88)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4869553 has a scratch
> build of the F18 package build for F17. please test that, just in case some
> unrelated fix upstream fixed this issue.

I actually upgraded to F-18. I will let you know if it happens again. And then I can provide some traces of events.
Comment 90 Sergio Monteiro Basto 2013-01-17 14:53:08 EST
testing after: 
rpm -Uvh http://kojipkgs.fedoraproject.org//work/tasks/9554/4869554/xorg-x11-drv-synaptics-1.6.99-2.20130110gitce7565ea6.fc17.x86_64.rpm

I got some issues, after many suspend and resume of my laptop and some days without reboot ... 
So I plan report after one week or two of testings ...
Comment 91 WsMithril 2013-01-20 21:20:28 EST
I have tried this package http://kojipkgs.fedoraproject.org//work/tasks/9554/4869554/xorg-x11-drv-synaptics-1.6.99-2.20130110gitce7565ea6.fc17.x86_64.rpm and still I got Xorg crashes. And I hasn't got the chance to record the X event on synaptics devices, sorry for that.


Now I upgrade to F18 too. And it seems that this problem has gone. I'll let you know if anything changes.
Comment 92 Rafael Majano 2013-01-23 08:37:11 EST
Resume pc after suspention.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 93 Sergio Monteiro Basto 2013-02-22 03:35:50 EST
(In reply to comment #88)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4869553 has a scratch
> build of the F18 package build for F17. please test that, just in case some
> unrelated fix upstream fixed this issue.

Hi, 
F18 have 
xorg-x11-drv-synaptics-1.6.3-1.fc18.x86_64 
not any
xorg-x11-drv-synaptics-1.6.99 

synaptics-1.6.99 works better , I don't need reset touchpad like I had today with  xorg-x11-drv-synaptics-1.6.3-1.fc18.x86_64 .
my reset is swith to vt2 and back again to X :) .
Comment 94 Sergio Monteiro Basto 2013-02-22 20:57:38 EST
Well it easy build xorg-x11-drv-synaptics-1.6.99  from source package

cd fedora-scm/
fedpkg clone xorg-x11-drv-synaptics
cd xorg-x11-drv-synaptics/
fedpkg mockbuild --root fedora-18-x86_64

rpm -Uvh 
results_xorg-x11-drv-synaptics/1.6.99/5.20130214git4cdee4005.fc19/xorg-x11-drv-synaptics-devel-1.6.99-5.20130214git4cdee4005.fc18.x86_64.rpm

I vote in one update of xorg-x11-drv-synaptics for F18
Comment 95 Fedora Update System 2013-04-25 20:36:05 EDT
xorg-x11-drv-synaptics-1.6.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.3-3.fc17
Comment 96 Peter Hutterer 2013-04-25 20:42:50 EDT
I really recommend testing -3, we finally found a stack corruption that only happens on apple touchpads and may be the cause for the issues you all have been seeing.
Comment 97 David Strauss 2013-04-25 20:58:48 EDT
> I really recommend testing -3, we finally found a stack corruption that only happens on apple touchpads and may be the cause for the issues you all have been seeing.

At least in my case, this is a ThinkPad.
Comment 98 Peter Hutterer 2013-04-25 21:16:40 EDT
well, there goes that idea then :) give it a try anyways, though I don't think a Thinkpads ever reports > 10 touchpoints
Comment 99 Fedora Update System 2013-04-26 20:03:08 EDT
Package xorg-x11-drv-synaptics-1.6.3-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.6.3-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6750/xorg-x11-drv-synaptics-1.6.3-3.fc17
then log in and leave karma (feedback).
Comment 100 Peter Hutterer 2013-05-01 01:14:49 EDT
not sure if the package really fixes this but meanwhile, someone please submit the hid-replay recordings for the event sequence when the bug occurs.

http://bentiss.github.io/hid-replay-docs/
Comment 101 Fedora Update System 2013-05-13 21:25:01 EDT
xorg-x11-drv-synaptics-1.6.3-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 102 David Juran 2014-02-03 02:06:31 EST
Not sure if re-opening really is the proper thing to do after all this time, but I'm hitting this issue if my laptop (Lenovo T410) is under heavy (so heavy that it gets almost unresponsive for an extended period of time) I/O load. 

I'm running F20 with xorg-x11-drv-synaptics-1.7.1-6.fc20.x86_64
Comment 103 David Juran 2014-02-03 02:09:56 EST
Created attachment 858392 [details]
Xorg.log with traceback

The attached XOrg.log file contains the traceback from the crashed synaptics driver. Unfortunately it seems Xorg doesn't find the dubuginfo symbols when generating the traceback, would anyone know what the secret to that would be?
Comment 104 Peter Hutterer 2014-03-13 21:23:38 EDT
*** Bug 1062363 has been marked as a duplicate of this bug. ***
Comment 105 Peter Hutterer 2014-03-13 21:24:47 EDT
We've finally identified the issue and it's caused by a SYN_DROPPED event received and not properly handled. I don't have a solution for F20 yet, but if you grab the latest xorg-x11-drv-synaptics from rawhide and recompile it locally, you should no longer see this issue. I'll update this bug once I figured out what to do for F20
Comment 106 Peter Hutterer 2014-03-19 06:50:20 EDT
*** Bug 1076183 has been marked as a duplicate of this bug. ***
Comment 107 Peter Hutterer 2014-03-19 22:04:33 EDT
Alright, I've got a test package that should eliminate this error. Please install it from the Copr below and let me know if that works for you. F19 and F20 packages are available, for rawhide this should already be fixed.

https://copr.fedoraproject.org/coprs/whot/synaptics-syn_dropped/

This is a temporary copr, it will be deleted once this bug is closed.
Comment 108 Sergio Monteiro Basto 2014-03-20 01:10:50 EDT
Hi , 
I expect copr have a higher version than updates and rpm -Uvh says: 
package xorg-x11-drv-synaptics-1.7.4-1.fc20.x86_64 (which is newer than xorg-x11-drv-synaptics-1.7.4-1.bz877464.fc20.x86_64) is already installed

so maybe you should bump relversion to -2 on copr.

I'm testing it now .

Should I recommend test this package for bug #1048314 and bug #1074910 ?
Comment 109 Peter Hutterer 2014-03-20 01:58:24 EDT
yeah, true should've bumped it. I left it at -1 because that way a real update will just remove any Copr-specific packages. next version will have a better number. It wont fix the other two bugs you listed, though.
Comment 110 Fedora Update System 2014-03-23 23:03:40 EDT
xorg-x11-drv-synaptics-1.7.4-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.7.4-3.fc20
Comment 111 Fedora Update System 2014-03-24 01:10:20 EDT
xorg-x11-drv-synaptics-1.7.4-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.7.4-3.fc19
Comment 112 Fedora Update System 2014-03-25 04:14:34 EDT
Package xorg-x11-drv-synaptics-1.7.4-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.7.4-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4291/xorg-x11-drv-synaptics-1.7.4-3.fc20
then log in and leave karma (feedback).
Comment 113 Fedora Update System 2014-03-26 19:52:46 EDT
xorg-x11-drv-synaptics-1.7.4-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.7.4-4.fc20
Comment 114 Fedora Update System 2014-04-02 05:11:25 EDT
xorg-x11-drv-synaptics-1.7.4-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 115 Fedora Update System 2014-04-29 00:13:43 EDT
xorg-x11-drv-synaptics-1.7.4-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.7.4-9.fc19